Page 27 of 31 FirstFirst ... 172526272829 ... LastLast
Results 261 to 270 of 309

Thread: Howto: Install and use projectM music visualizer with pulseaudio support on Hardy

  1. #261
    Join Date
    Nov 2009
    Beans
    10

    Re: Howto: Install and use projectM music visualizer with pulseaudio support on Hard

    Quote Originally Posted by punkrockguy318 View Post
    2.0 is working fine for me, however cmake has trouble detecting that pulseaudio is installed. i had to take out the pulseaudio checking lines in the cmake scripts to get it to compile, but it works great other than that
    How do you do that?? I have the same problem...

    CMake Error at projectM-pulseaudio/CMakeLists.txt:55 (MESSAGE):
    ERROR: Pulse Audio is NOT found. Please install pulse audio 0.9.8 or
    greater from www.pulseaudio.org.

  2. #262
    Join Date
    Sep 2009
    Beans
    4
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Re: Howto: Install and use projectM music visualizer with pulseaudio support on Hard

    hi everybody,

    I get a nasty message when I try to make install ...

    Code:
    bennyto@ubuntulaptop:~/projectm/projectM-Trunk$ sudo make install
    make: *** Pas de règle pour fabriquer la cible « install ». Arrêt.

    what should I do ..?

    ben

  3. #263
    Join Date
    May 2009
    Beans
    14

    Re: Howto: Install and use projectM music visualizer with pulseaudio support on Hard

    Quote Originally Posted by surement View Post
    How do you do that?? I have the same problem...

    CMake Error at projectM-pulseaudio/CMakeLists.txt:55 (MESSAGE):
    ERROR: Pulse Audio is NOT found. Please install pulse audio 0.9.8 or
    greater from www.pulseaudio.org.
    same here..
    i managed to take the lines out, but then i get an error during the install process @88%
    "make[2]: *** [projectM-pulseaudio/CMakeFiles/projectM-pulseaudio.dir/qprojectM-pulseaudio.o] Error 1
    make[1]: *** [projectM-pulseaudio/CMakeFiles/projectM-pulseaudio.dir/all] Error 2
    make: *** [all] Error 2"

    help anyone?

  4. #264
    Join Date
    Jul 2009
    Beans
    850
    Distro
    Ubuntu Development Release

    Re: Howto: Install and use projectM music visualizer with pulseaudio support on Hard

    i made some .debs with checkinstall if anyone wants them.... (compiled with jaunty)
    Last edited by nerdy_kid; January 2nd, 2010 at 10:42 PM.
    "Microsoft Windows: A collection of 32bit extensions and a graphical shell for a 16bit patch to an 8bit O.S. originally coded for a 4bit microprocessor written by a 2bit company who cant stand 1 bit of competition." Jargon File 4.4.7

  5. #265
    Join Date
    Oct 2008
    Beans
    12

    Re: Howto: Install and use projectM music visualizer with pulseaudio support on Hard

    To those of you with problems finding the pulseaudio package information,
    make sure that you have installed the libpulse-dev package. This should clear up any problems with ccmake finding pulseaudio.

    If not, you will still need libpulse-dev (to provide pulseaudio headers), and you may need to modify the CMakeList.txt file.

    Go to the projectM-pulseaudio directory and comment out the following lines from CMakeLists.txt

    pkg_search_module(LIBPULSE REQUIRED libpulse>=0.9.8

    (Line 29)
    and

    if (LIBPULSE_FOUND)
    MESSAGE(STATUS "[projectM-pulseaudio] pulse audio detected.")
    else (LIBPULSE_FOUND)
    MESSAGE(FATAL_ERROR "ERROR: Pulse Audio is NOT found. Please install pulse audio 0.9.8 or greater from www.pulseaudio.org.")
    endif(LIBPULSE_FOUND)

    (lines 43-47)

    Use cmake or ccmake as usual, make, and make install.

  6. #266
    Join Date
    Jul 2009
    Location
    IIT Kanpur
    Beans
    346
    Distro
    Ubuntu Development Release

    Re: Howto: Install and use projectM music visualizer with pulseaudio support on Hard

    Code:
    nishant@nishant-Studio:~$ projectM-pulseaudio
    dir:/usr/share/projectM/config.inp 
    reading ~/.projectM/config.inp 
    
    (<unknown>:14040): Gtk-WARNING **: Theme directory  of theme Azenis Icons has no size field
    
    [projectM] config file: /home/nishant/.projectM/config.inp
    No Textures Loaded from /usr/share/projectM/textures
    [projectM] Allocating idle preset...
    [PresetFactory] path is Geiss & Sperl - Feedback (projectM idle HDR mix).milk
    [PresetFactory] url is idle://Geiss & Sperl - Feedback (projectM idle HDR mix).milk
    unconnected: connecting... 
    connectHelper:  "alsa_output.pci-0000_01_00.1.hdmi-stereo.monitor" 
    Segmentation fault
    Now what?
    Dell Studio 1555
    Intel P8600 2.4 GHz, 4GB DDR2 800MHz RAM, 512 MB ATI Mobility Radeon HD 4570, 320GB 5400 RPM WD Blue Scorpio

  7. #267
    Join Date
    Dec 2004
    Beans
    282

    Re: Howto: Install and use projectM music visualizer with pulseaudio support on Hard

    Quote Originally Posted by nishant.singh28 View Post
    Code:
    nishant@nishant-Studio:~$ projectM-pulseaudio
    dir:/usr/share/projectM/config.inp 
    reading ~/.projectM/config.inp 
    
    (<unknown>:14040): Gtk-WARNING **: Theme directory  of theme Azenis Icons has no size field
    
    [projectM] config file: /home/nishant/.projectM/config.inp
    No Textures Loaded from /usr/share/projectM/textures
    [projectM] Allocating idle preset...
    [PresetFactory] path is Geiss & Sperl - Feedback (projectM idle HDR mix).milk
    [PresetFactory] url is idle://Geiss & Sperl - Feedback (projectM idle HDR mix).milk
    unconnected: connecting... 
    connectHelper:  "alsa_output.pci-0000_01_00.1.hdmi-stereo.monitor" 
    Segmentation fault
    Now what?
    i'm getting the same error here as well

    i've tried not including everything and i'm still getting the error

    if i start it like 10 times in a row it will start but otherwise it will fail with with either that error or a segfault at start

  8. #268
    Join Date
    Jun 2007
    Beans
    1,941

    Re: Howto: Install and use projectM music visualizer with pulseaudio support on Hard

    I believe this is in the repo's now - have you tried installing just "libvisual-projectm"?

  9. #269
    Join Date
    Dec 2004
    Beans
    282

    Re: Howto: Install and use projectM music visualizer with pulseaudio support on Hard

    Quote Originally Posted by arrrghhh View Post
    I believe this is in the repo's now - have you tried installing just "libvisual-projectm"?
    libvisual-projectm is sort of useless

    projectM-pulseaudio is where its at

  10. #270
    Join Date
    Jul 2009
    Location
    #ubuntu
    Beans
    138
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Howto: Install and use projectM music visualizer with pulseaudio support on Hard

    E0: Things in red are obsolete.

    Holy God, thanks for telling me about checkinstall, it is INCREDIBLY useful.

    I made a deb of projectM using the latest svn using checkinstall, which I assume is 2.0 (doesn't say in about!).

    For people who don't want to download the svn and compile and risk breaking something and all that, I have the package attached here. I didn't put any dependencies in it because, well, I don't know them, so you're on your own with that.

    Oh, it's 32 bit. I don't have a 64 bit machine around, so eh. I don't think you can set the architecture in checkinstall.

    Remember, I called the package projectm, so to uninstall it, run

    Code:
    dpkg -r projectm 
    or
    apt-get remove projectm
    or
    apt-get purge projectm
    as root

    Thanks all. Beats the hell out of Rhythmbox's GOOM and monoscope.

    One more thing, I'm just asking, is there a preset kinda like VLC's spectrometer out there? It's really informative.

    E1: Ah shoot, it won't let me upload debs. I'll put it in a zip.

    E2: And while I'm at it, will someone tell me what in Sam Hill this "Easter Egg Parameter" does? Or is it a programmer's secret?

    E3 : I gave the deb to a friend, it didn't install some libs. Specifically, when running projectM-pulseaudio from a terminal, it asked for these:

    • libprojectM-qt.so.1 (symlink of libprojectM-qt.so.1.10)
    • libprojectM.so.2 (symlink of libprojectM.so.2.00)
    • libQtOpenGL.so.4 (symlink of libQtOpenGL.so.4.5.2)

    I Skype'd him these libs, and on his end he moved them to /usr/lib and made the appropriate symlinks. Then it worked fine, albeit slow because of his hardware, but that's besides the point.

    I made a new deb that seems to work. The other one didn't appear to have the libs in it, according to the Included Files tab. The only thing is that is doesn't make the GNOME launcher in the menu though, but no big deal. The icon installs to /usr/share/pixmaps like it's supposed to, so just manually make a launcher.

    For those who installed the first one, don't worry, it still installed to /usr, just uninstall and reinstall with this package.

    This has been quite the learning experience. Thanks for writing such through instructions!


    E4: Now I made a deb out of the tarball from the SourceForge projectM, 2.0.1.
    http://sourceforge.net/projects/projectm/files/
    Attached Files Attached Files
    Last edited by ThatBum; March 22nd, 2010 at 07:43 AM. Reason: made deb of tarball and not svn

Page 27 of 31 FirstFirst ... 172526272829 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •