Results 1 to 9 of 9

Thread: nVidia install

  1. #1
    Join Date
    Mar 2008
    Beans
    2

    Question nVidia install

    hi

    I'm new in Linux and I wanted to install the nVidia drivers. I downloaded the kit in the desktop folder as nVidia.run and in the terminal window I run sh nVidia.run (after i changed to de destop dir). Here I get a message that I should log in as root and run the program.

    Can anyone help me. How can I login as root? what password should I use? I changed the password for the rood user in the users and groups to 123456, after that I restarted and tryed to login as root, but I got another message (administrator can't log here or something like that).

  2. #2
    Join Date
    Aug 2007
    Location
    Twin Cities area, MN
    Beans
    43
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: nVidia install

    I think you can do this a different way -

    Ctrl+Alt+F6 (i think f6 at least) to switch to non-gui mode. Then kill your graphics manager

    GDM:
    sudo /etc/init.d/gdm stop

    KDE:
    only way i know how to do it is killall -9 X (this is kind of harsh way to stop it, anyone else have a better way?)

    then run the script as sudo

  3. #3
    Join Date
    Mar 2007
    Location
    Here & Now
    Beans
    16,549
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: nVidia install

    Ctrl+Alt+F1
    username
    password
    sudo /etc/init.d/gdm stop
    password
    sudo sh /path/to/driver/NVIDIA-Linux-xxxx.run
    Accept the License
    Let the driver compile the module into your kernel
    Let the driver reconfigure your xorg file
    Then: startx
    You need build-essential installed:
    sudo aptitude install build-essential
    (before attempting to install the driver)

    Dr. Fernando Duran Dollenz
    Libertad 584
    6824871

  4. #4
    Join Date
    Aug 2007
    Location
    Twin Cities area, MN
    Beans
    43
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: nVidia install

    Won't ctrl+alt+F1 try to make them login as root? i was trying to get around that since they were having problems?

  5. #5
    Join Date
    Mar 2007
    Location
    Here & Now
    Beans
    16,549
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: nVidia install

    Ctrl+Alt+F1 takes him to a virtual Terminal that will ask him to login with his username and password

    Dr. Fernando Duran Dollenz
    Libertad 584
    6824871

  6. #6
    Join Date
    Aug 2007
    Location
    Twin Cities area, MN
    Beans
    43
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: nVidia install

    I thought that was as root though, and they dont have a root pwd.

    Im at work so i cant check it no biggie

  7. #7
    Join Date
    Mar 2008
    Beans
    2

    Re: nVidia install

    I trye Ctrl+Alt+F1 no luck there
    I'm running VMWare Workstation under Win Vista, my virtual machine is Ubuntu 7.0 Desktop Edition....

    is there another way to disable the graphics manager?

  8. #8
    Join Date
    Aug 2007
    Location
    Kottawa, Sri Lanka
    Beans
    7,387
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: nVidia install

    Unfortunately I do not think you can install the Nvidia driver anyway since, as Ubuntu is being virtualised, the graphics adapter would not be hardware but more software. So this means that the graphics driver is considered to be "generic" by the system being virtualised, this also would mean that the Nvidia driver would not start at all since it requires an Nvidia VGA card to be installed.

    This thread is moved to the Virtualisation section.
    Think carefully before executing commands containing "rm", especially "sudo rm -rf ", if you require more information concerning this matter, read this.
    I am an experimenter, give me the most stable OS and I can make it unstable in a few hours.

    C == seriously fast == FTW!

  9. #9
    Join Date
    Feb 2007
    Location
    Cameron Park CA USA
    Beans
    4,475
    Distro
    Ubuntu Development Release

    Re: nVidia install

    Quote Originally Posted by LunaSanctus View Post
    I trye Ctrl+Alt+F1 no luck there
    I'm running VMWare Workstation under Win Vista, my virtual machine is Ubuntu 7.0 Desktop Edition....

    is there another way to disable the graphics manager?
    Oh, you cannot install video drivers in virtual Windows, period. One of these days, maybe.

    If you have installed the Tools, setup to recognize USBs, etc., the video will be fast as it is in the host, but only 2D, no 3D acceleration.
    Regards, frank, at http://yantrayoga.typepad.com/noname/
    Homebuilt Lian-Li PC-Q30X Intel i5-4670K 4.0GHz, SSDs,16G RAM | Dell laptop E1505n, netbook 10n
    Oracle VBox w/ WinXP/Win8 running Xara Designer, PaintShopPro, and InDesign CS.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •