Results 1 to 3 of 3

Thread: [SOLVED] filesharing between host and vm

  1. #1
    Join Date
    Feb 2008
    Location
    Ohio
    Beans
    48
    Distro
    Ubuntu 10.10 Maverick Meerkat

    [SOLVED] filesharing between host and vm

    how do i set up gutsy and xp to share files with each other when gutsy is the host OS and xp is the guest OS using virtualbox? all the related topics I found were never answered so hopefully this one is
    Current Build
    HP ProLiant DL380 G3:
    2GB DRR RAM
    2x 3.2GHz Intel Xeon

  2. #2
    Join Date
    Feb 2008
    Location
    Ohio
    Beans
    48
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: filesharing between host and vm

    ok I solved it real easy

    first bridge the connection and setup vbox0

    this can be found under the help>contents then
    -innotek Virtualbox user manual
    --virtual networking
    ---host interface networking and bridging on linux hosts
    ----(your distro, mine was ubuntu)

    once you bridge the connection set it as adapter 1 under the settings>network tab assuming adapter 0 is being used to get out to the internet like mine was

    when running the VM click devices>shared folders then add /home/usrname as the folder path and usrname as the folder name
    make sure permanent is checked

    for a VM of XP right click my computer and click map network drive give it a drive letter and type \\VBOXSVR\usrname where usrname is your username on linux
    Current Build
    HP ProLiant DL380 G3:
    2GB DRR RAM
    2x 3.2GHz Intel Xeon

  3. #3
    Join Date
    Dec 2006
    Location
    Kentucky, USA
    Beans
    271
    Distro
    Ubuntu

    Re: filesharing between host and vm

    Actually, you can also have it access just specific files using the 'Shared Folders' Settings. I have it set to access my internet using the network connection, and my home folder using the shared folders

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •