Results 1 to 5 of 5

Thread: Printing from your VirtualBox guest through your Host's printer

  1. #1
    Join Date
    Oct 2010
    Location
    California
    Beans
    15
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Printing from your VirtualBox guest through your Host's printer

    The instructions for enabling access to a Linux host's printer
    from a Windows VirtualBox client goes like this:

    Linux:
    1. Install your printer driver. Get your printer working.
    2. Add your printer to CUPS at http://localhost:631/admin
    If CUPS is not installed in your computer, go to the official CUPS website to download it.
    You may also want to read the Ubuntu Official Documentation here.

    3. Set your virtual machine's Network to Bridged Adapter (eth0) in Settings and connect the cable (Advanced menu).
    4. Start your VirtualBox machine.
    5. Enter "ifconfig" at a terminal prompt to list your current network settings
    and copy down your host's (eth0) address. You can also access this address using Network Tools.

    Windows:
    1. Add a new Network printer in "Printers and Faxes" from the Control Panel
    2. Enter the URL address of your host's printer.
    For example: http://192.168.0.2:631/printers/Your_printer's_name

    You need the :631 after your host's address as this is the port
    that CUPS listens to. Your_printer's_name is the name of the printer you added to CUPS.

    If no connection is made, check your firewall settings.


    If you want a Linux VirtualBox client to access a Window's host's printer, you're going the wrong direction!
    Last edited by amateur_mav; November 6th, 2010 at 07:39 PM.

  2. #2
    Join Date
    Feb 2007
    Location
    Marseille, France
    Beans
    184
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Printing from your VirtualBox guest through your Host's printer

    Hi, thanks for the tip! Isn't it also possible to directly install the printer through the usb connection? I cannot get my guest XP to see the printer. Although it comes up under the shared devices in the virtual box menu, its name is greyed out...

    Any ideas?

  3. #3
    Join Date
    Nov 2009
    Beans
    10

    Re: Printing from your VirtualBox guest through your Host's printer

    Quote Originally Posted by amateur_mav View Post
    The instructions for enabling access to a Linux host's printer
    from a Windows VirtualBox client goes like this:

    Linux:
    1. Install your printer driver. Get your printer working.
    2. Add your printer to CUPS at http://localhost:631/admin
    If CUPS is not installed in your computer, go to the official CUPS website to download it.
    You may also want to read the Ubuntu Official Documentation here.

    3. Set your virtual machine's Network to Bridged Adapter (eth0) in Settings and connect the cable (Advanced menu).
    4. Start your VirtualBox machine.
    5. Enter "ifconfig" at a terminal prompt to list your current network settings
    and copy down your host's (eth0) address. You can also access this address using Network Tools.

    Windows:
    1. Add a new Network printer in "Printers and Faxes" from the Control Panel
    2. Enter the URL address of your host's printer.
    For example: http://192.168.0.2:631/printers/Your_printer's_name

    You need the :631 after your host's address as this is the port
    that CUPS listens to. Your_printer's_name is the name of the printer you added to CUPS.

    If no connection is made, check your firewall settings.


    If you want a Linux VirtualBox client to access a Window's host's printer, you're going the wrong direction!
    Very useful, thanks a lot.

    Let me just add one bit more of information: on the Linux side in System/Administration/Printing/Server/Setting be sure that the flag "Allow printing from the Internet" is set.

  4. #4
    Join Date
    Mar 2012
    Beans
    6

    Re: Printing from your VirtualBox guest through your Host's printer

    Quote Originally Posted by amateur_mav View Post
    The instructions for enabling access to a Linux host's printer
    from a Windows VirtualBox client goes like this:

    Linux:
    1. Install your printer driver. Get your printer working.
    2. Add your printer to CUPS at http://localhost:631/admin
    If CUPS is not installed in your computer, go to the official CUPS website to download it.
    You may also want to read the Ubuntu Official Documentation here.

    3. Set your virtual machine's Network to Bridged Adapter (eth0) in Settings and connect the cable (Advanced menu).
    4. Start your VirtualBox machine.
    5. Enter "ifconfig" at a terminal prompt to list your current network settings
    and copy down your host's (eth0) address. You can also access this address using Network Tools.

    Windows:
    1. Add a new Network printer in "Printers and Faxes" from the Control Panel
    2. Enter the URL address of your host's printer.
    For example: http://192.168.0.2:631/printers/Your_printer's_name

    You need the :631 after your host's address as this is the port
    that CUPS listens to. Your_printer's_name is the name of the printer you added to CUPS.

    If no connection is made, check your firewall settings.


    If you want a Linux VirtualBox client to access a Window's host's printer, you're going the wrong direction!
    I am learning a lot about Mint (ubuntu flavor), but I'm not ready to commit. So, for now, how do I go the "wrong direction"? I cannot get it to hit my Windows 7 printer (Epson Artisan 725).

    Thanks!

  5. #5
    Join Date
    May 2007
    Location
    The New Forest
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Printing from your VirtualBox guest through your Host's printer

    Old thread closed.

    If you need help then please start a new thread - if it's for Mint - try the Mint forums, if you need to post here about Mint then please use the Other O/s Forum - http://ubuntuforums.org/forumdisplay.php?f=401

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •