Results 1 to 7 of 7

Thread: Remote Wonder II

  1. #1
    Join Date
    Oct 2006
    Beans
    23

    Remote Wonder II

    I have been unable to get this remote working in mythbuntu, it works fine if i run

    sudo lircd -d /dev/lirc0 /etc/lirc/lircd.conf

    but on boot it doesn't work at all

    any help?

  2. #2
    Join Date
    Oct 2006
    Beans
    23

    Re: Remote Wonder II

    anyone?

  3. #3
    Join Date
    Oct 2005
    Location
    Austin, TX
    Beans
    2,983
    Distro
    Ubuntu Development Release

    Re: Remote Wonder II

    Post your /etc/lirc/hardware.conf.

    This is the file that is sourced via the init script.

    Also, does it start if you do this:

    Code:
    sudo /etc/init.d/lirc restart
    If so, this likely means that there is something going on with the order things are loading (possibly a module order issue or a blacklist issue)

  4. #4
    Join Date
    Oct 2006
    Beans
    23

    Re: Remote Wonder II

    Code:
    # /etc/lirc/hardware.conf
    #
    #Chosen Remote Control
    REMOTE="ATI/NVidia X10 RF (userspace)"
    
    # Arguments which will be used when launching lircd
    LIRCD_ARGS="-d /dev/lirc0 /etc/lirc/lircd.conf"
    
    #Don't start lircmd even if there seems to be a good config file
    #START_LIRCMD=false
    
    #Try to load appropriate kernel modules
    LOAD_MODULES=true
    
    # Run "lircd --driver=help" for a list of supported drivers.
    DRIVER="atilibusb"
    # If DEVICE is set to /dev/lirc and devfs is in use /dev/lirc/0 will be
    # automatically used instead
    DEVICE="/dev/lirc0"
    MODULES=""
    
    # Default configuration files for your hardware if any
    LIRCD_CONF="/etc/lirc/lircd.conf"
    LIRCMD_CONF=""
    sudo /etc/init.d/lirc does not work because i had altered that script when i was trying to get it to work. can someone post the original file as well?

  5. #5
    Join Date
    Oct 2005
    Location
    Austin, TX
    Beans
    2,983
    Distro
    Ubuntu Development Release

    Re: Remote Wonder II

    Quote Originally Posted by Xenner View Post
    Code:
    # /etc/lirc/hardware.conf
    #
    #Chosen Remote Control
    REMOTE="ATI/NVidia X10 RF (userspace)"
    
    # Arguments which will be used when launching lircd
    LIRCD_ARGS="-d /dev/lirc0 /etc/lirc/lircd.conf"
    
    #Don't start lircmd even if there seems to be a good config file
    #START_LIRCMD=false
    
    #Try to load appropriate kernel modules
    LOAD_MODULES=true
    
    # Run "lircd --driver=help" for a list of supported drivers.
    DRIVER="atilibusb"
    # If DEVICE is set to /dev/lirc and devfs is in use /dev/lirc/0 will be
    # automatically used instead
    DEVICE="/dev/lirc0"
    MODULES=""
    
    # Default configuration files for your hardware if any
    LIRCD_CONF="/etc/lirc/lircd.conf"
    LIRCMD_CONF=""
    sudo /etc/init.d/lirc does not work because i had altered that script when i was trying to get it to work. can someone post the original file as well?
    You can obtain the original by purging lirc and reinstalling or by grabbing it from the deb (extracted).

    Odds are there is your issue, if you can't start it that way. That is the same way it is started when the PC is turned on.

    As for that file, don't specify LIRCD_ARGS like that. (it's not necessary, as they get built from other parameters in that file)

  6. #6
    Join Date
    Oct 2006
    Beans
    23

    Re: Remote Wonder II

    it is still not working, but once again works if i do

    lircd -d /dev/lirc0 /etc/lirc/lircd.conf

    something with the order that these processes are starting maybe?

  7. #7
    Join Date
    Oct 2006
    Beans
    23

    Re: Remote Wonder II

    Fixed by removing all arguments in the DEVICE line.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •