Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Tip: Configuring and Enabling TV out on Nvidia

  1. #1
    Join Date
    Oct 2004
    Location
    NH, USA
    Beans
    300
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Tip: Configuring and Enabling TV out on Nvidia

    BACKGROUND
    I have been a mythtv user for the past two years using Knoppmyth. A few weeks ago I migrated to Mythbuntu. I love Mythbuntu's Myth Control Center and the ability to keep the system updated via Synaptec.

    Knoppmyth was great in that the recent releases of Knoppmyth automatically configured and enabled the TV out on my PVR-350 TV tuner card. After migrating to Mythbuntu, it wasn't long before I discovered that configuring/enabling TV out on the PVR-350 was not going to be as easy.

    I realized that this was an opportunity to begin understanding how to display Mythbuntu on my analog TV via the TV out on my Nvidia 6200 graphics card. This card has D-Sub, DVI, and TV out. The package included a dongle for composite video, s-video, and component. This was a great solution because although I have an analog TV now, sometime in the future I will probably upgrade to a digital/HD TV. The TV out dongle that came with the 6200 will allow me to output video (including the desktop) to an analog TV (via composite and s-video) or, later on, to a digital/HD TV via the component or DVI connector.

    The only problem I had was that I did not have a good understanding of how to configure/enable the TV out on the Nvidia 6200 video card.

    Below is an explanation of how I configured and enabled the TV out on the Nvidia 6200 video card, which allowed me to use the TV out dongle that game with this graphics card.

    NOTE: This post applies specifically to the Nvidia 6200 video card, but may be useful for other Nvidia cards too. This post DOES NOT apply to those using ATI for video output.

    INSTRUCTIONS

    STEP 1. Installed the video card (see manual that came with card).

    STEP 2. Installed nVidia proprietary graphics driver

    Note: Before proceeding, be sure that the machine is connected to the Internet.

    • Click on Settings --> Screens and Graphics
    • Enter the password
    • In the windows titled Screen and Graphics Preferences, Click on the Graphics Card tab.
    • Click on the Driver drop down list
    • Keep the default Choose Driver By Name option and select nvidia.
    • Click the OK button


    The driver will be downloaded and installed. Enter password when prompted.

    Log out and log back in to have the new driver take effect.


    STEP 3. Backup Current XORG.CONF File.

    • At the desktop, click on Applications --> Accessories --> Terminal.
    • Type the following command...
      sudo cp /etc/X11/xorg.conf etc/X11/xorg.conf.backup1


    STEP 3. Create a New XORG.CONF File.

    • Connect the TV out dongle to the back of the Nvidia graphics card, as well as to the analog TV (composite or s-video).
    • Turn ON THE TV - VERY IMPORTANT
    • Launch nvidia-settings by typing the following command...
      sudo nvidia-settings
    • A window titled NVIDIA X Server Settings will appear. Click on the second option in the list (left side) titled X Server Display Configuration
      Note: Two boxes will appear on the right side titled Monitor and TV-Out indicating that the TV has been detected.
    • In the section titled Display, click on the Configure... button.
    • A small window will appear titled Configure Display Device and select the TwinView option (third in the list) and then click on the OK button.
    • Back to the NVIDIA X Server Settings window and in the Display section, click on the Position drop down list and select Clone. Then, click on the Apply button.
      Note: The desktop should now appear on the TV screen.
    • Still in the NVIDIA X Server Settings window, click on the Save to X Configuration File button.
    • A small window will appear titled Save X Configuration.
    • Change the path of the file from /home/username/xorg.conf to /home/username/xorg.conf.twinview
    • Click on the Save button.
    • Back to the NVIDIA X Server Settings window, click on the Quit button.


    You should now be back at the terminal.


    STEP 4. Replace XORG.CONF File with XORG.CONF.TWINVIEW

    • At the terminal, type in the following command...
      sudo cp /home/username/xorg.conf.twinview /etc/X11/xorg.conf


    STEP 5. Restart X Server

    • Click on Applications --> Quit
    • Click on Log Out


    You should now be at a login screen.

    • Click on the user name in the login list
    • Enter the password


    Video should appear on the TV screen AND monitor.

    ALL DONE!!

    I hope this helps others.
    Long time Mythbuntu User. Current Mythbuntu System: Intel i3, 4Gb RAM, 1.3 TB Storage, Mythbuntu 12.04/0.27 fixes, HDTV 5500 Tuner, Ceton Infiniti 4 Tuner

  2. #2
    Join Date
    Feb 2008
    Location
    Ohio, USA
    Beans
    248
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Tip: Configuring and Enabling TV out on Nvidia

    Thanks for posting this, it was exactly what I needed to do.

  3. #3
    Join Date
    Oct 2007
    Beans
    502

    Re: Tip: Configuring and Enabling TV out on Nvidia

    Nice Howto!

    I'm wondering why it didn't work automatically for you? I always thought that you just have to have the TV plugged in at boot and then it works?

    I haven't used an Nvidia TV-Out for quite some time, though
    Please read 'How to get help' before asking a question about Mythbuntu.

  4. #4
    Join Date
    Jun 2007
    Beans
    291
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Tip: Configuring and Enabling TV out on Nvidia

    Not to hi-jack, but does your card detect the TV during boot-up before setting it up like this?

    My issue is this: I just installed a 7600 GT in my system. I have it connected to my TV using the supplied HDTV dongle (essentially 7-pin S-video to RGB component). For some reason I can't get anything on my TV when using the component connection (not even the BIOS screen during boot up).

    However, if I plug the blue cable into the composite video on my TV I get a picture, but with no color.

    I had a similar problem with another machine into which I installed a 7950 GT and was connecting with a plain 4-pin S-video cable (no color, fuzzy picture). I "fixed" it using a workaround I found elsewhere in which you short out a couple of pins with copper wire. (I don't understand why that works, but at least it works.)

    I suppose I could just connect with S-video and use the workaround described above, but I'd rather connect with the component cables.

    Anybody have any suggestions?

  5. #5
    Join Date
    Nov 2008
    Beans
    117
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Tip: Configuring and Enabling TV out on Nvidia

    After a couple of weeks of head scratching, trashed installations and rebuilds I have a couple of tips for anyone struggling to get TV-out working on nVidia boards.

    These are things that may catch you out (to do with video standard and detecting the TV input type).

    They are a couple of settings that you may need to manually add to the /etc/X11/xorg.conf which cannot be set from the nvidia-settings GUI.

    1) Set your TV out standard correctly according to your region. eg. for a PAL-I (like the UK and Japan) region, add the following line to xorg.conf:

    Code:
    Option "TVStandard" "PAL-I"
    2) You may also need to tell the card whether or not you want to use composite video out or S-Video out. Th ecard is supposed to auto-detect this from the TV (!?), but may not, so hard setting it may solve issues of black screens on TVs.

    Code:
    Option "TVOutFormat" "SVIDEO"
    or
    Code:
    Option "TVOutFormat" "COMPOSITE"
    The following page has a list of some of the various options for the settings mentioned in 3 and 4. It's from the manufacturer who make the card I'm using, but it should apply to any vVidia card with TV-out capability.

    http://www.zotac.com/index.php?optio...d=29&Itemid=29

    Finally,

    3) In nvidia-settings make sure to set the card to synch to the TV-Out video, not any other computer display you have connected. If you synch to the computer display rather than the TV-out you may end up with the video 'tearing' with a horizontal line accross the screen, and any digital audio will drop out regularly every second or so.

    Hope this helps someone avoid the headaches I've had over the last 2 weeks trying to get this sorted!

    -FM
    Last edited by fatmonk; November 18th, 2008 at 03:24 PM. Reason: Moved from it's own thread to the How To.
    The Fat Monk
    Systems:
    MythBox: Antec Fusion w/RM200, Gigabyte GA-73PVM-S2H (GeForce 7100/nForce 630i), Core2Duo E8400 3Ghz, 2GB RAM, 160GB+2TB HDD, DVD-RW, Nova-T500, nVidia 8500GT PCI-E 1GB. Mythbuntu 12.04
    Other: Dell XPS15z with Ubuntu 12.04

  6. #6
    Join Date
    Aug 2007
    Beans
    100

    Re: Tip: Configuring and Enabling TV out on Nvidia

    Hello,
    I cannot get this how-to to work for me.
    I am using an asus motherboard with and integrated nvidia geForce 6150.
    The board has composite, s-video and analog video outs.
    I am trying to output video to an analog TV like the original poster.

    When I click 'apply' in the Nvidia X Server Settings after selecting Twinview and Clone, I get this message:

    The mode on X screen 0 has been set. Would you like to keep the current settings?

    But nothing at all happens. My TV is detected in the nvidia settings, and when I restart X the TV flickers during startup indicating that the TV is getting some sort of signal.

    Any Ideas? I'm trying to get this going to add visuals to a DJ performance I'm doing this evening!

    Thanks

  7. #7
    Join Date
    Oct 2006
    Location
    Sydney
    Beans
    111
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Tip: Configuring and Enabling TV out on Nvidia

    does the tv go black after flickering? (may be related to not setting up the tv out signal e.g. pal - b for australia)


    or do you get the blue (no signal) screen


    you say that the tv is being detected how do you know this?

    is there any settings for the tv in the nvidia control panel

    e.g. can you describe the screen position.


    For some reason my nvidia x server does not like to run the tv setup wizard that was located as an option in the panel on the left under display setup wizaed.

    any more - nut you may need to run this and choose pal -B australia if it gives you the option.

  8. #8
    Join Date
    Feb 2007
    Location
    new orleans, la
    Beans
    54
    Distro
    Ubuntu UNR

    Re: Tip: Configuring and Enabling TV out on Nvidia

    Hi, hopefully someone can help me out.

    I'm trying to output using Mythbuntu on an Nvidia card, I have the drivers installed and everything. But for some reason my TV can't output at 1024x768 resolution. I can't figure out a resolution that fits the screen, anything lower is too small. Ideas? Please PM me or respond if you can help.

  9. #9
    Join Date
    Oct 2004
    Location
    NH, USA
    Beans
    300
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Tip: Configuring and Enabling TV out on Nvidia

    Quote Originally Posted by ratdog View Post
    Hello,
    I cannot get this how-to to work for me.
    I am using an asus motherboard with and integrated nvidia geForce 6150.
    The board has composite, s-video and analog video outs.
    I am trying to output video to an analog TV like the original poster.

    When I click 'apply' in the Nvidia X Server Settings after selecting Twinview and Clone, I get this message:

    The mode on X screen 0 has been set. Would you like to keep the current settings?

    But nothing at all happens. My TV is detected in the nvidia settings, and when I restart X the TV flickers during startup indicating that the TV is getting some sort of signal.

    Any Ideas? I'm trying to get this going to add visuals to a DJ performance I'm doing this evening!

    Thanks
    Hello,

    Just to confirm, did you follow steps 3 and 4 above?

    Do you use PAL or NTSC? If PAL, did you try the post above?

    Post the content of the /etc/X11/xorg.conf file.

    Al
    Long time Mythbuntu User. Current Mythbuntu System: Intel i3, 4Gb RAM, 1.3 TB Storage, Mythbuntu 12.04/0.27 fixes, HDTV 5500 Tuner, Ceton Infiniti 4 Tuner

  10. #10
    Join Date
    Jun 2009
    Beans
    4

    Re: Tip: Configuring and Enabling TV out on Nvidia

    I realize that this is a very old thread, but would love is someone could help. I followed the directions in the for an install of Ubuntu 9.04, with an Nvidia card. It worked well and I can now see my TV from the machine, but I seem to have caused some other problems. Terminal will start and I have no text in it, just a white box, as well as not red X in the top right corner. I don't know if it was these directions, or something else I did (complete Linux Noob, and it's kickin' my butt!)

    Please help!
    pblack00

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •