Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: virtualbox-gutsy-usb?

  1. #1
    Join Date
    Sep 2007
    Location
    Florida
    Beans
    81
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    virtualbox-gutsy-usb?

    Heres the problem, Im using xp in a virtual machine, I want xp to see my usb hard drive, Ive read the guides and what not floating around in here, but they all say to go to the usb settings in the virtual machines settings. Hers the issue, I dont have usb options, they arent there. WTF

  2. #2
    Join Date
    Dec 2007
    Location
    London
    Beans
    511
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: virtualbox-gutsy-usb?

    If you have no USB settings you must be using the OSE of VirtualBox. As far as I know you need the closed source edition for USB support. Just download it from the Virtualbox website.

  3. #3
    Join Date
    Sep 2007
    Location
    Florida
    Beans
    81
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Thumbs down Re: virtualbox-gutsy-usb?

    thank you, i didnt notice!

  4. #4
    Join Date
    Jan 2008
    Location
    Sin City
    Beans
    44

    Re: virtualbox-gutsy-usb?

    I had to make several changes to my Gutsy 71.0 configuration to get USB working in VirtualBox 1.5.2 under Windows XP. Here's what I did:

    Downloaded the current version directly from the VirtualBox site, installed, and then made the following two changes to get USB devices working in VirtualBox.

    Note -- I'm running VirtualBox 1.5.2; the web site has a new 1.5.4 version. Not sure these changes are required in 1.5.4. I suspect they are still needed.

    ************************************************** **

    FIRST CHANGE - edits to /etc/init.d/mountdevsubfs.sh

    Support for /proc/bus/usb/* was removed in Ubuntu 7.10. Software developers will (over time) port USB calls to check /dev/bus/usb first but until then the following work-around re-enables /proc/bus/usb/devices in Ubuntu 7.10. It appears that VirtualBox 1.5.2 still calls /proc/bus/usb/devices.

    In a terminal windows execute the following:

    sudo /etc/init.d/mountdevsubfs.sh

    The edits involve simply removing the # (comment symbol) from the mkdir through mount lines (Code after line 40)

    #
    # Magic to make /proc/bus/usb work
    mkdir -p /dev/bus/usb/.usbfs
    domount usbfs "" /dev/bus/usb/.usbfs -obusmode=0700,devmode=0600,listmode=0644
    ln -s .usbfs/devices /dev/bus/usb/devices
    mount --rbind /dev/bus/usb /proc/bus/usb

    Execute the script manually to enable the change before a system reboot by running the following in a terminal window:

    sudo /etc/init.d/mountdevsubfs.sh start

    ************************************************** ***

    SECOND CHANGE - edits to /etc/udev/rules.d/40-permissions.rules

    This provides/enables USB selection icon in VirtualBox. In a terminal window execute the following:

    sudo gedit /etc/udev/rules.d/40-permissions.rules

    Here are the edits in the file.

    #Edited to enable USB devices on VirtualBox
    #Original line commented out under #USB devices (usbfs replacement)
    #added the new line

    # USB devices (usbfs replacement)
    #SUBSYSTEM=="usb_device", MODE="0664" # ORIGINAL
    SUBSYSTEM=="usb_device", MODE="0666" # NEW LINE ENABLES USB ICON

    # Now in VirtualBox select your machine, select USB controller,
    # select Enable USB controller and add filter with blanks

    # On the bottom of the VirtualBox window there is a icon to add USB devices
    # right click and select device - to be safe you should unmount USB device
    # in Ubuntu first

    # ----------END OF COMMENTS -----------------------

    Hope this helps!

  5. #5
    Join Date
    Sep 2007
    Location
    Florida
    Beans
    81
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: virtualbox-gutsy-usb?

    thanx all works great

  6. #6
    Join Date
    Jan 2008
    Location
    Texas
    Beans
    35
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: virtualbox-gutsy-usb?

    umm... yea how do i get this key? i have seen this "download here" on other things but i have no idea how to work it... all it is is txt. i have tried copying it in the terminal and all... please bear with me i'm still new to linux

    EDIT: ok i got it to install but im still curious about how to do those... and now my USB dont work... how do i get it? i read the guy that made changes, but im kinda skeptical fom running chmod 666(cant remember the whole command). if u know what that is then u know i have good reason to be skeptical
    Last edited by blackenedbloodx; January 8th, 2008 at 01:29 AM.
    Death lives, but once, for eternity.

  7. #7
    Join Date
    Oct 2006
    Location
    Los Angeles
    Beans
    119
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    STILL No USB - but so close - what am I missing?

    I'm running Gutsy, Virtualbox 1.5.4 (NOT the OSE edition), WinXP running as a guest. It's been working pretty sweetly for months but try as I might, still no USB access. I have modified fstab, added all users to the usbusers group, etc. etc. I've tried all this and suggestions from other blogs as to how to get USB going, no joy.

    The thing is, I can add the devices in the Virtualbox USB section before starting the VM. While XP is running as a guest. I can check and uncheck the devices, which are correctly identified, in the Machine - Devices - USB Devices menu. In the XP system tray, I can even see a little green-arrowed 'Safely Remove Hardware' icon. But the USB devices (Creative Zen Nano Plus, Lexar SD Media card reader, etc.) never show up, I can't see them in the drive listing under My Computer in an Explorer window, WMP won't recognize the MP3 player, nothing. If I click on the Safely Remove Hardware icon, the window pops up - but there are no devices listed. If I unplug the device, the icon disappears, and if I plug it back in, it reappears, but still not accessible. Weird. I'm probably missing something really stupid but I can't figure it out.

    Any help please please.

  8. #8
    Join Date
    Jan 2008
    Beans
    6

    Re: virtualbox-gutsy-usb?

    Same problem here.

  9. #9
    Join Date
    Jan 2008
    Beans
    6

    Re: virtualbox-gutsy-usb?

    Ok after some more fiddling I managed to get it working.
    First I disabled EHCI Controller under USB settings then I removed all fields (excluding Vendor and Product ID) for my usb device.

    Everything seems to be working now.

  10. #10
    Join Date
    Oct 2006
    Location
    Los Angeles
    Beans
    119
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    @desktopfan Re: virtualbox-gutsy-usb?

    @desktopfan -

    Nice. There are a number of slightly different workarounds floating around I've tried involving a number of different config. files etc. Wonder if you could describe what settings, group id assignment, or changes you made, if any, to these:

    /etc/fstab
    /etc/udev/rules.d/40-permissions.rules
    /etc/init.d/mountdevsubfs.sh

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •