Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: How To: Compile and Install GnuPG from source with Camellia and IDEA ciphers

  1. #11
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,554
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How To: Compile and Install GnuPG from source with Camellia and IDEA ciphers

    Just for the record, I get the same error. I'm trying to contact the developers on freenode to figure out the mess. This may take some time however. The channel is dead. Hopefully more info later

  2. #12
    Join Date
    Jan 2009
    Beans
    34
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How To: Compile and Install GnuPG from source with Camellia and IDEA ciphers

    Actually, it is an easy fix: just open a terminal and type

    "sudo ln -s /usr/local/bin/gpg /usr/bin/gpg"

    (without the quotes). Works like greased lightning after that.

  3. #13
    Join Date
    Sep 2008
    Location
    Bonn, Germany
    Beans
    3
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How To: Compile and Install GnuPG from source with Camellia and IDEA ciphers

    Thanks for the amazing tutorial Kevdog. I was able to install the svn version for gnupg, but when I tried for gnupg2, and typed the command for installing libgcrypt
    Code:
    ./autogen.sh && ./configure --enable-maintainer-mode && make && make check
    I get the following error
    Code:
    checking for gpg-error-config... no
    checking for GPG Error - version >= 1.8... no
    configure: error: libgpg-error is needed.
                    See ftp://ftp.gnupg.org/gcrypt/libgpg-error/ .
    This then doesn't let me further install the gnupg2 svn version.

    I checked on the website, and the file is a normal text file, so I really don't know what to do with it. I tried just copying it into the folder where I am downloading the libgcrypt, but that doesn't work either. It still gives the same error.

    Clearly, even when I trued to run your code for updating the gnupg2 version (hoping it would be updated to a svn version), it gives the same error.

    I would be extremely grateful if anyone would help me out with this fix.

    Thanks!

  4. #14
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,554
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How To: Compile and Install GnuPG from source with Camellia and IDEA ciphers

    gnupg2 is tricky to get going and sometimes doesn't compile for me at all. In your case however you are missing the gpg-error library.

    In order to do this you need to download the source of libgpg-error:
    http://www.gnupg.org/download/index.en.html

    And compile it.

    Just a summary
    download the source
    extract it
    and then its usually ./config, make, sudo make install

    Report back on your success if you have any.
    Hopefully that helps.

  5. #15
    Join Date
    Sep 2008
    Location
    Bonn, Germany
    Beans
    3
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How To: Compile and Install GnuPG from source with Camellia and IDEA ciphers

    Hey Kevdog,

    Thank you for your reply. Unfortunately, it still gives the same error. I downloaded the gzipped file for libgpg-error-1.7, and untarred it, and did the whole deal (./configure, make, sudo make install).

    Still, it gives me the same error when I try installing the svn version for gnupg2. The error obtained again is:

    Code:
    checking for gpg-error-config... /usr/local/bin/gpg-error-config
    checking for GPG Error - version >= 1.8... no
    configure: error: libgpg-error is needed.
                    See ftp://ftp.gnupg.org/gcrypt/libgpg-error/ .
    Thanks.

  6. #16
    Join Date
    Mar 2007
    Beans
    194
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: How To: Compile and Install GnuPG from source with Camellia and IDEA ciphers

    Thanks for this great walk-through. I'm attempting to install gpg from the latest git.


    Code:
    $ ./configure --sysconfdir=/etc --enable-maintainer-mode --enable-camellia
    ...
    configure:
    ***
    *** You need libassuan to build this program.
    *** This library is for example available at
    ***   ftp://ftp.gnupg.org/gcrypt/libassuan/
    *** (at least version 2.1.0 (API 2) is required).
    ***
    configure:
    ***
    *** It is now required to build with support for the
    *** New Portable Threads Library (nPth). Please install this
    *** library first.  The library is for example available at
    ***   ftp://ftp.gnupg.org/gcrypt/npth/
    *** (at least version 0.91 (API 1) is required).
    ***
    configure: error: 
    ***
    *** Required libraries not found. Please consult the above messages
    *** and install them before running configure again.
    ***
    Unfortunately, I am unable to find source or debs for the required libraries. Do you have any suggestions?

    Although Camellia interests me, my biggest goal is the ability to use 8192 RSA keys.

    Thanks again

  7. #17
    Join Date
    Mar 2006
    Beans
    146

    Re: How To: Compile and Install GnuPG from source with Camellia and IDEA ciphers

    Hi,
    the idea.c file is not available anymore in

    where can I get it ?

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •