Page 6 of 31 FirstFirst ... 4567816 ... LastLast
Results 51 to 60 of 308

Thread: Call of duty 4 3D/OpenGL issue

  1. #51
    Join Date
    Jan 2008
    Beans
    6

    Re: Call of duty 4 3D/OpenGL issue

    Ahh nevermind..I figured out you were sending me a link to a how-to to add the entry to my apt list However, the problem still persists "E: Build-dependencies for wine could not be satisfied."

  2. #52
    Join Date
    May 2006
    Beans
    1,892

    Re: Call of duty 4 3D/OpenGL issue

    Sorry, I was too busy editing my previous post to see your replys

    Have a browse over this: https://help.ubuntu.com/community/Repositories/Ubuntu just to make sure the repo's set up properly. Then read the' WineOn64bit' guide which was one of the things I added to my previous post.


  3. #53
    Join Date
    Jan 2008
    Beans
    6

    Re: Call of duty 4 3D/OpenGL issue

    Ah, thanks
    Well I'm trying to compile it but I get an error when running ./configure

    "configure: error: C compiler cannot create executables"
    and also "odin@odin-desktop:~/wine-0.9.50$ make depend && make
    make: *** No rule to make target `depend'. Stop."

  4. #54
    Join Date
    May 2006
    Beans
    1,892

    Re: Call of duty 4 3D/OpenGL issue

    You've got the extra packages & made the appropriate links? It sounds like you've not got 'gcc-4.2-multilib' installed.
    sudo apt-get build-dep wine
    sudo apt-get install libxcomposite-dev gcc-4.2-multilib
    After "patch -p1 < 3dmark.diff" in my guide, continue with "mkdir -p `pwd`/lib32" from the 'WineOn64bit' guide.

    Last edited by ahaslam; February 11th, 2008 at 10:39 PM.

  5. #55
    Join Date
    Jan 2008
    Beans
    6

    Re: Call of duty 4 3D/OpenGL issue

    When I try that code I get :
    $ sudo apt-get install libxcomposite-dev gcc-4.2-multilib
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    libxcomposite-dev is already the newest version.
    libxcomposite-dev set to manual installed.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    gcc-4.2-multilib: Depends: libc6-dev-i386 (>= 2.5) but it is not going to be installed
    E: Broken packages

    and I picked up on the guide where you said too and I get :
    odin@odin-desktop:~/wine-0.9.50$ CC="gcc-4.2 -m32" LDFLAGS="-L/lib32 -L/usr/lib32 -L`pwd`/lib32 -Wl,-rpath,/lib32 -Wl,-rpath,/usr/lib32" ./configure
    checking build system type... x86_64-unknown-linux-gnu
    checking host system type... x86_64-unknown-linux-gnu
    checking whether make sets $(MAKE)... yes
    checking for gcc... gcc-4.2 -m32
    checking for C compiler default output file name...
    configure: error: C compiler cannot create executables
    See `config.log' for more details.

  6. #56
    Join Date
    May 2006
    Beans
    1,892

    Re: Call of duty 4 3D/OpenGL issue

    You need to fix the 1st problem before you continue. You can't compile 32bit apps without a multilib compiler (not without a chroot).

    A quick forum search brought this up: http://ubuntuforums.org/showthread.p...roken+packages

    Hope it helps
    Last edited by ahaslam; February 12th, 2008 at 12:25 AM.

  7. #57
    Join Date
    Feb 2008
    Beans
    13

    Re: Call of duty 4 3D/OpenGL issue

    Hello, just follow the steps you gave us and installed CoD4 in my computer. I noticed that single player works for me (hurray!), but that multiplayer does not (crashes at startup). Currently using patched 0.9.50 v of wine and followed your instructions. Have you got any ideas?

    *using Ubuntu 7.10.

    I just want multiplayer to play on LAN (we don't use Punkbuster).

    Thanks for all,

    JDLF

  8. #58
    Join Date
    May 2006
    Beans
    1,892

    Re: Call of duty 4 3D/OpenGL issue

    Nice to hear you've got the SP up & running at least. There are a couple of things you can try:
    • Is there any difference between accessing MP through the SP menu, or by launching the iw3mp.exe?

    • Have you tried patching the game itself?

    If this gets you nowhere, please post the last few dozen lines of the debugging for us to ponder over.


  9. #59
    Join Date
    Feb 2008
    Beans
    13

    Re: Call of duty 4 3D/OpenGL issue

    Well, there doesn't seem to be any difference between running from single player and then switching to multiplayer and going straight into multiplayer.


    Also, the lines of code that appear when I execute wine from terminal are similar, no matter if it's sp or mp. This is from mp:

    fixme:d3d:tex_bumpenvmat >>>>>>>>>>>>>>>>> GL_INVALID_OPERATION (0x502) from glTexEnvfv(GL_TEXTURE_SHADER_NV, GL_OFFSET_TEXTURE_MATRIX_NV, mat)
    @ state.c / 2503
    fixme:d3d:tex_bumpenvmat >>>>>>>>>>>>>>>>> GL_INVALID_OPERATION (0x502) from glTexEnvfv(GL_TEXTURE_SHADER_NV, GL_OFFSET_TEXTURE_MATRIX_NV, mat)
    @ state.c / 2503
    fixme:d3d:tex_bumpenvmat >>>>>>>>>>>>>>>>> GL_INVALID_OPERATION (0x502) from glTexEnvfv(GL_TEXTURE_SHADER_NV, GL_OFFSET_TEXTURE_MATRIX_NV, mat)
    @ state.c / 2503




    But I found something I don't quite understand (maybe cause I'm newbie )

    jdjd@jdjd-laptop:~/.wine/drive_c/Archivos de programa/Activision/Call of Duty 4 - Modern Warfare$ ls

    binkw32.dll codlogo.bmp iw3sp.exe miles players
    cod4.ico __iw3mp localization.txt Mods zone
    cod.bmp iw3mp.exe main mss32.dll

    iw3mp.exe is in green ¿? also why is there a _iw3mp??

    iw3sp.exe and _iw3mp are normal colour

    I don't have to install any patch to run multiplayer do I? (appart from the ones to update from 1.0)

    Thanks for all,
    JDLF

    PD: Fed up with Sony MP3 players as well Mine NW-A1000 and software provided is crap
    Last edited by jdlf; February 13th, 2008 at 05:28 PM.

  10. #60
    Join Date
    May 2006
    Beans
    1,892

    Re: Call of duty 4 3D/OpenGL issue

    The green highlight means it's flagged as executable, it shouldn't matter either way though. It's strange that you've got a '__iw3mp' - you shouldn't, delete it if you wish. You don't need to patch the game for MP, though it may save you a full reinstall if were corrupted (which is possible).
    Regarding that output, what graphics driver version are you running (100.14.19 here)? I'd feel inclined to switch to FBO rendering, it's often more stable & I've noticed no reduction in performance.

    Should keep you busy for a while

    PS. Yeah, Sony produce some really nice kit, only to spoil it with crap software. They've realized the dissatisfaction now, finally releasing players supporting drag & drop.
    Last edited by ahaslam; February 13th, 2008 at 06:40 PM. Reason: PS

Page 6 of 31 FirstFirst ... 4567816 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •