Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: WoW Issue

  1. #1
    Join Date
    Aug 2007
    Beans
    51

    WoW Issue

    Ok I don't know what is up but I can't even get into WoW, I use the command I always use wine "C:\Program Files\World of Warcraft\WoW.exe" -opengl and it keeps spitting out this error junk:
    err:wgl:get_render_type_from_fbconfig Unknown render_type: 0
    err:d3d:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat
    err:d3d:InitAdapters Failed to get a gl context for default adapter
    err:wine_d3d:WineDirect3DCreate Direct3D9 is not available without opengl
    everything is installed right, I have all the updates. I don't know what to do, can some please give me a hand with

    cheers

  2. #2
    Join Date
    Oct 2005
    Location
    U.S.A.
    Beans
    4,164
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: WoW Issue

    Try changing directories to the game's install directory, then run the executable:
    Code:
    cd .wine/drive_c/Program\ Files/World\ of\ Warcraft/
    wine WoW.exe -opengl
    Also, have you checked the existing WoW how-to thread for help?
    http://ubuntuforums.org/showthread.php?t=579378

    Linux User #355330 | Ubuntu User #15618 | Last.FM

  3. #3
    Join Date
    Aug 2007
    Beans
    51

    Re: WoW Issue

    hey cogadh,
    Thanks for the reply. I tried what you said and sadly it's still not working. I get the same output from before.

    warlock@warlock-desktop:~/.wine/dosdevices/c:/Program Files/World of Warcraft$ wine WoW.exe -opengl
    fixme:advapi:SetSecurityInfo stub
    fixme:ntdll:find_reg_tz_info Can't find matching timezone information in the registry for bias 480, std (d/m/y): 4/11/2007, dlt (d/m/y): 11/03/2007
    fixme:powrprof:DllMain (0x7d610000, 1, (nil)) not fully implemented
    fixme:ntdll:NtPowerInformation Unimplemented NtPowerInformation action: 11
    fixme:powrprof:DllMain (0x7d610000, 0, (nil)) not fully implemented
    fixme:win:EnumDisplayDevicesW ((null),0,0x34ed84,0x00000000), stub!
    err:wgl:get_render_type_from_fbconfig Unknown render_type: 0
    err:d3d:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat
    err:d3d:InitAdapters Failed to get a gl context for default adapter
    err:wine_d3d:WineDirect3DCreate Direct3D9 is not available without opengl

  4. #4
    Join Date
    Oct 2005
    Location
    U.S.A.
    Beans
    4,164
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: WoW Issue

    Something is not right about where you ran that from. It looks like you went into the game's install directory by following the symbolic link in the "dosdevices" directory. I'm not sure that will actually work correctly. Make sure you run the commands exactly as I posted them.

    Linux User #355330 | Ubuntu User #15618 | Last.FM

  5. #5
    Join Date
    Aug 2007
    Beans
    51

    Re: WoW Issue

    Still didn't work. I'm getting the same output as the other two tries =(

  6. #6
    Join Date
    May 2006
    Beans
    6

    Re: WoW Issue

    I get the same errors when trying to run gta-vc, and none of my other games work either.
    Seems like something is wrong in my installation of ubuntu and not wine.

  7. #7
    Join Date
    Oct 2005
    Location
    U.S.A.
    Beans
    4,164
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: WoW Issue

    Have you installed the proper driver for your video hardware? The default drivers in Ubuntu can't do 3D acceleration and could produce those types of errors.

    Linux User #355330 | Ubuntu User #15618 | Last.FM

  8. #8
    Join Date
    May 2006
    Beans
    6

    Re: WoW Issue

    Nvidia drivers are installed, i bet it's a compiz/xgl problem

  9. #9
    Join Date
    Aug 2007
    Beans
    51

    Re: WoW Issue

    ok i've uninstalled everything, then reinstalled Wine. But now i'm getting the following error message:

    warlock@warlock-desktop:~/.wine/drive_c/Program Files/World of Warcraft$ wine WoW.exe -opengl
    fixme:powrprof:DllMain (0x7d680000, 1, (nil)) not fully implemented
    fixme:ntdll:NtPowerInformation semi-stub: SystemPowerCapabilities
    fixme:powrprof:DllMain (0x7d680000, 0, (nil)) not fully implemented
    fixme:win:EnumDisplayDevicesW ((null),0,0x34f230,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x34eee0,0x00000000), stub!
    err:wgl:get_render_type_from_fbconfig Unknown render_type: 0
    err:d3d:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat
    err:d3d:InitAdapters Failed to get a gl context for default adapter
    err:wine_d3d:WineDirect3DCreate Direct3D9 is not available without opengl

    you know ever since 7.10 game out i've lost everything I had installed. And I can't seem to find anything that works anymore. I don't know what else to do can some please help me with this problem.

    cheers

  10. #10
    Join Date
    Aug 2006
    Location
    tuesday
    Beans
    6,502
    Distro
    Kubuntu Development Release

    Re: WoW Issue

    melzanis: Did your upgrade go well or wrere there errors? If you didn't upgrade and installed from scratch however I'm sure the reason things are missing is obvious.

    You may want to check that your video drivers are properly installed?

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •