Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Hauppage remote - configure all buttons on remote

  1. #11
    Join Date
    Nov 2007
    Location
    Chicago, IL
    Beans
    44
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Hauppage remote - configure all buttons on remote

    Quote Originally Posted by rossco View Post
    I assume that lirc is running (how do I tell?) since the remote is working even when the front end is not running as the up and down buttons on the remote work like the up and down arrows on the keyboard.
    Depending on how your remote/IR receiver is recognized by the kernel, up and down buttons on the remote could be translated w/o the help of lirc. To check if lirc is indeed running, run:
    Code:
    ps aux | grep lirc
    Quote Originally Posted by rossco View Post
    It seems to me that the kernel is not using lirc but another driver and interprets the keypresses on the remote as keyboard strokes. Which agrees with what I found when using irw the direction keys on the remote gave the same output as the direction keys on the keyboard.
    You might want to take a look at how the kernel is recognizing your IR receiver.
    Code:
    lsusb
    Code:
    lsusb -D /proc/usb/00?/00?
    You can also check which kernel modules are loaded by grep-ing through:
    Code:
    lsmod
    in case you're not using the Mythbuntu Control Center and are changing things manually.

    Just some thoughts. Hope it helps.

  2. #12
    Join Date
    Sep 2007
    Location
    New Zealand
    Beans
    52
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Hauppage remote - configure all buttons on remote

    Hi everybody,

    Thanks for all your advice. I managed to get the remote to work properly. I used this link to get it to work. The kernel recognises the remote for my card (Nova-S-Plus) as a 'keyboard'. The important part from the guide is to do:

    cat /proc/bus/input/devices
    And look for the event number for the correct input device and enter it into the hardware.conf file. The config files I used from this guide are:

    /etc/lirc/hardware.conf
    ~/.lircrc
    /etc/lirc/lircd.conf

    I haven't changed the name of the remote from hauppauge_nova_t_uk which relates to the Nova-T card in my config file as I am just enjoying that it works now. I checked using irw that all of the buttons are recognised and they are correctly identified. I think I might just need to modify the .lircrc file to suit my tastes.

    Let me know if I should still file a bug report as I haven't done that before. In between figuring this out I reinstalled Windows XP and tried to get MediaPortal to work but Mythbuntu is far better now that I have a taste for it!

  3. #13
    Join Date
    Oct 2005
    Location
    Austin, TX
    Beans
    2,983
    Distro
    Ubuntu Development Release

    Re: Hauppage remote - configure all buttons on remote

    Quote Originally Posted by rossco View Post
    Hi everybody,

    Thanks for all your advice. I managed to get the remote to work properly. I used this link to get it to work. The kernel recognises the remote for my card (Nova-S-Plus) as a 'keyboard'. The important part from the guide is to do:



    And look for the event number for the correct input device and enter it into the hardware.conf file. The config files I used from this guide are:

    /etc/lirc/hardware.conf
    ~/.lircrc
    /etc/lirc/lircd.conf



    Let me know if I should still file a bug report as I haven't done that before. In between figuring this out I reinstalled Windows XP and tried to get MediaPortal to work but Mythbuntu is far better now that I have a taste for it!
    Yes please file a bug against mythbuntu. We can attempt to address this later on to be automatic for a future release. Please attach any relevant items that you had to change, ad well as any information that you used to figure out what event device you had to use. Also be sure to respond to bug mail with what more will be needed. Offhand I can't think of anything else but we might not get to this for a while so just keep your eyes peeled.

  4. #14
    Join Date
    Nov 2005
    Beans
    144
    Distro
    Ubuntu Breezy 5.10

    Re: Hauppage remote - configure all buttons on remote

    I've never managed to get my remote to work. Pre or post Mythbuntu. I was hoping that Mythbuntu would sort it out (one of my main reasons for installing it on top of my Ubuntu/Mythtv system), but still nothing. I have number keys and directional key working, but pretty much nothing else so I have to use my keyboard all or the time.

    I was hoping that this thread would lead to an answer, but it has lead to another dead end.

    I have 2 Hauppage Nova-t cards in my machine and a long ir cable coming out of one of them (I actually spliced two together to make it long enough, but there is input getting in so i don't think that's causing a problem).

    I have just re-looked at the parker site and ran
    cat /proc/bus/input/devices

    where I find I have 2 Hauppage entries (to be expected), on event 5 and evern6.

    Running
    sudo evetest /dev/input/event5
    doesn't do much, but
    sudo evetest /dev/input/event6
    fills me with hope. Everything I press suddenly does give me a response! I don't understand the responses, but they're there

    However, when I go down further to the part where it says:
    As usual, we'll give it a quick test ...
    sudo /usr/sbin/lircd -H dev/input -d /dev/input/event2 -n
    and (in another terminal)
    irw
    "Press some buttons and you should see the events displayed"
    Well, I see nothing at all displayed! Not even the numbers and cursor keys giving any input now!

    I tried looking at the hardware.conf from the parker site and editing mine to include the 'event6', but I've rebooted and now my remote is doing nothing.

    Can anyone tell me what's going on here?

    Hope I'm not hijacking the thread, but I thought these problems might be in ther right ball park. I'll start a new thread if no one can help in here.

    Cheers
    Damian

  5. #15
    Join Date
    Sep 2007
    Location
    New Zealand
    Beans
    52
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Hauppage remote - configure all buttons on remote

    Hey Daminator,

    Sorry you're having trouble too. I will try and help you out as best I can. If you've got Mythbuntu go to the control centre and on the remote section select your remote again and check the box at the bottom which will recreate all the config files and hopefully fix your remote again. Let me know if it doesn't. That way we at least know we can repair any damage we do.

    Also I didn't do much of the checking steps that are on the parker site. I just used the files from the parker site directly assuming that they would work (use the second .lircd.conf file if your cards are new like mine). Then once you have copied the files to the correct locations (note that lircrc files needs to be in two locations as in the guide), either restart the PC or type something like "sudo /etc/init.d/lirc restart" and then type irw and see what kind of output you get.

    note: don't forget to modify the event# in the hardware.conf file.

  6. #16
    Join Date
    Nov 2005
    Beans
    144
    Distro
    Ubuntu Breezy 5.10

    Re: Hauppage remote - configure all buttons on remote

    I don't know what I did differently to the last time I followed that guide, but I've finally got my remote working.
    I'm putting it down to having a bit more linux experience under my belt, helping me to actually put the right files in the right place this time.

    Cheers
    Damian

  7. #17
    Join Date
    Sep 2007
    Location
    New Zealand
    Beans
    52
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Hauppage remote - configure all buttons on remote

    Hey Damian,

    Glad you got it to work. I guess I have to go and log a bug report about it now. I guess we know that this method works for both of us.

    Regards
    Ross

  8. #18
    Join Date
    Nov 2007
    Location
    Berkeley, CA
    Beans
    36
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Hauppage remote - configure all buttons on remote

    Quote Originally Posted by superm1 View Post
    For irw try it like this:
    Code:
    irw /dev/lircd
    (While lirc is running)
    Dude!!!! I just tried this and every button on my Hauppauge remote just worked. On the first try. I can control everything in MythTV. And I didn't do any configuration (which is probably why it works .

  9. #19
    Join Date
    Sep 2007
    Location
    New Zealand
    Beans
    52
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Hauppage remote - configure all buttons on remote

    Quote Originally Posted by spinlock99 View Post
    Dude!!!! I just tried this and every button on my Hauppauge remote just worked. On the first try. I can control everything in MythTV. And I didn't do any configuration (which is probably why it works .
    Does it work on reboot or do you have to type it every time?

  10. #20
    Join Date
    Sep 2007
    Location
    New Zealand
    Beans
    52
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Hauppage remote - configure all buttons on remote

    I had to follow the link at the bottom of the parker guide since my "event#" has started to change. The guide worked first time for me (when I typed the correct line in the config file).

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •