Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: usb not working in Innotek VB on ubuntu710

  1. #11
    Join Date
    Sep 2006
    Location
    France
    Beans
    126

    Re: usb not working in Innotek VB on ubuntu710

    Quote Originally Posted by Steve1961 View Post
    I don't think the ose version supports usb. I installed the version from the virtualbox site by adding their repo to my /etc/apt/sources.list. As a kernel module needs to be compiled you should have build-essential installed
    Thanks for that steve, as I thought. Will I also need the kernel source and headers ?

  2. #12
    Join Date
    Jul 2005
    Location
    /dev/UK
    Beans
    978
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: usb not working in Innotek VB on ubuntu710

    You don't need the kernel source, only the headers. Not sure, but these might even be installed automatically along with build-essential, but if not just install them from synaptic. Or just issue the command:

    sudo apt-get install build-essential linux-headers-`uname -r`
    Last edited by Steve1961; November 4th, 2007 at 01:34 PM.

  3. #13
    Join Date
    Sep 2006
    Location
    France
    Beans
    126

    Re: usb not working in Innotek VB on ubuntu710

    Quote Originally Posted by Steve1961 View Post
    You don't need the kernel source, only the headers. Not sure, but these might even be installed automatically along with build-essential, but if not just install them from synaptic. Or just issue the command:

    sudo apt-get install build-essential linux-headers-`uname -r`
    Thanks once again.

    I will give it a go this pm.

  4. #14
    Join Date
    Sep 2006
    Location
    France
    Beans
    126

    Re: usb not working in Innotek VB on ubuntu710

    Tried all above and failed with error message
    VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED)

    Ran sudo /etc/init.d/vboxdrv setup twice as suggested on other posts and still nothing

    dmesg gave error about adding nmi_watchdog=0 to the kernel command

    Is this normal and safe to do ?

    dmesg output is just over 19.5 limit as one file so have split into 2 attached
    Attached Files Attached Files

  5. #15
    Join Date
    Aug 2007
    Beans
    41

    Re: usb not working in Innotek VB on ubuntu710

    Brilliant! Thank you very much.

  6. #16
    Join Date
    Apr 2007
    Beans
    89

    Re: usb not working in Innotek VB on ubuntu710

    Thanks Steve! I used your solution and now I get to use my USB camera under windows. I also have a USB wireless keyboard and mouse. When I add those to the virtual machine, I get proper input for windows (e.g.: keys stay pressed instead of being repeatedly pressed). The problem is that I'm loosing keyboard support for Ubuntu.

    So, under the present configuration I can have a proper keyboard in windows at the cost of loosing it for Ubuntu (while XP is running) or I can have seamless Ubuntu+XP but without proper keyboard support.

    Any ideas?

  7. #17
    Join Date
    Dec 2007
    Beans
    3

    Re: usb not working in Innotek VB on ubuntu710

    I have followed directions here after installing the latest from the virtualbox site for my AMD computer.

    Now my problem is that the CD is not mounted and does not show upin the drop down.

    I tried mounting with,
    sudo ln -fs /media/cdrom0 /dev/cdrom

    ...this allows me to browse the CD ROM


    If mount from within the Virtual Box GUI I can't install the OS and I get a fata error when starting the VM. How can I get the mounted CD ROM to show up in the "Settings"?

    pr

  8. #18
    Join Date
    May 2007
    Location
    Nevada, US, North America
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: usb not working in Innotek VB on ubuntu710

    Quote Originally Posted by Steve1961 View Post
    or just add this line to /etc/fstab

    none /proc/bus/usb usbfs devgid=1002,devmode=664 0 0

    the devgid number is the vboxusers group id (check to see if yours is different)

    Once you've saved and closed fstab just do a sudo mount -a and you should be good to go.
    Thanks. This worked for me. After VirtualBox was updated, I kept getting error messages about not able to connect to USB Device 'Failed to create a proxy device for the USB device. (Error: VERR_FILE_NOT_FOUND).' My vboxusers group id was different than yours, but looked in System/Administration/Users and Groups/Manage Groups - Properties and changed the 1002 (group id),
    Last edited by bobpress; December 28th, 2007 at 03:58 AM.
    Maverick Meerkat Desktop Ubuntu 10.10, HP Pavilion dv6-1240 with 4G memory. Windows 7 dual boot.
    "Everything should be made as simple as possible, but not simpler."

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •