Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: [SOLVED] Xmltv

  1. #1
    Join Date
    Oct 2007
    Beans
    14

    [SOLVED] Xmltv

    Hey,

    I have now for some days, being figthing with Mythbuntu. Trying to get myth to work with XMLTV.

    I live in Sweden and need XMLTV to get the EPG down. But I can't seem to get it to work.

    I have tryed to install Mythbuntu with XMLTV under the installation. Not working!
    I have tryed to reinstall XMLTV right after. Not working!
    And last I have tryed to install it without XMLTV, and install it after. Not working!

    I can find all the tv_grap_* in /usr/bin/ but not in Mythtv backend under Video source setup.

    What am I doing worng?

    Pease help,

    Best regards,

    Kim

  2. #2
    Join Date
    Dec 2005
    Beans
    4

    Re: Xmltv

    Same problem here! What is up with that?

  3. #3
    Join Date
    Jun 2007
    Beans
    303

    Re: Xmltv

    I also live in sweden and I got almost everyting working. First I must ask you if you use the final release?

  4. #4
    Join Date
    Oct 2007
    Beans
    14

    Re: Xmltv

    Hey,

    I have now checket it out. And it is the final release. So I don't know what to do.


    Kim

  5. #5
    Join Date
    Jun 2007
    Beans
    303

    Re: Xmltv

    That was strange. In the RC the xmltv did work in the installatuion but in the FR it was perfect.
    OK you say it doesn´t work what do mean? Do you see that it is installed in the synaptic?
    Do you see it show up in the mythtv backend videosource/grabber? And if it works so far you should be able to go back to the terminal after have been choosen the right grabber with Alt+Tab. In the terminal you should be able to define what channels you want to choose. please report how far you have come.

  6. #6
    Join Date
    Oct 2007
    Beans
    14

    Re: Xmltv

    I have just downloadet the md5sum from mythbuntu.org to check it up against my .iso file, it says it is the right one. So it is to FR i'am running.

    And I can see in Synaptic that XMLTV is installet.

    I can't chose it under the Mythbackend setup under "Video sources", I can chose:
    North America (SchedulesDirect.org) (Internal), Transmitted guide only (EIT) and No grabber.

    Furter more kan I see in the terminal running behind the Backend setup:

    tv_find_grabbers exited early or we timed out waiting.

    If I run tv_find_grabbers it finds the grabbers, but I don't know if it is too slow. It takes about 35 sek to find them all.
    I have just tryed it on my running mythtv, that one is not faster to find them!


    --
    Kim
    Last edited by weiser; October 31st, 2007 at 07:06 PM.

  7. #7
    Join Date
    Jun 2007
    Beans
    303

    Re: Xmltv

    This is very mysterious. If you just see what you see all signs indicates that XMLTV is not installed.
    Maybe someone else here on the forum have seen this anomali. Mythtv should get the xmltv info automatic. The last way out is to reinstall the final release but wait a few days maybe someone have seen this before. You don´t do anything wrong as far as I know and I mean that the new combinergrabber is wonderful to work with especially since swedb is missing a lot channels in my cable net so you have really something to look forward too.

  8. #8
    Join Date
    Oct 2005
    Location
    Austin, TX
    Beans
    2,983
    Distro
    Ubuntu Development Release

    Re: Xmltv

    For posterities sake you can go out and reinstall xmltv
    Code:
    sudo apt-get install --reinstall xtmlv
    But i would be leaning to issues with that time it's taking.

    Also remove ~/.xmltv and /home/mythtv/.xmtlv if they exist before starting.

    Lastly look at logs from mythbackend as well as mythtv-setup when you are running through.

  9. #9
    Join Date
    Oct 2007
    Beans
    14

    Re: Xmltv

    Hey

    First of all axelsvag, thanks for trying.


    And now for Superm1


    ~/.xmltv did exist so I have removed it, there was no /home/mythtv/.xmltv

    And then I reinstallet xmltv, but no different.


    I have looked into the log for mythbackend, nothing about xmltv or tv_grab*

    Here is the output of the terminal when running mythsetup:

    2007-10-31 20:37:27.154 Using runtime prefix = /usr
    2007-10-31 20:37:27.186 DPMS is active.
    2007-10-31 20:37:27.241 New DB connection, total: 1
    2007-10-31 20:37:27.267 Connected to database 'mythconverg' at host:
    localhost
    2007-10-31 20:37:27.271 Total desktop dim: 800x600, with 1 screen[s].
    2007-10-31 20:37:27.290 Using screen 0, 800x600 at 0,0
    2007-10-31 20:37:27.324 Current Schema Version: 1160
    2007-10-31 20:37:27.394 Total desktop dim: 800x600, with 1 screen[s].
    2007-10-31 20:37:27.400 Using screen 0, 800x600 at 0,0
    2007-10-31 20:37:27.405 Switching to square mode (Mythbuntu)
    2007-10-31 20:37:27.471 Using the Qt painter
    mythtv: could not connect to socket
    mythtv: Connection refused
    lirc_init failed for mythtv, see preceding messages
    2007-10-31 20:37:27.868 Joystick disabled.
    2007-10-31 20:37:28.284 Loading from:
    /usr/share/mythtv/themes/Mythbuntu/base.xml
    2007-10-31 20:37:28.391 Loading from:
    /usr/share/mythtv/themes/default/base.xml
    2007-10-31 20:37:38.282 New DB connection, total: 2
    2007-10-31 20:37:38.284 Connected to database 'mythconverg' at host:
    localhost
    2007-10-31 20:37:38.291 New DB connection, total: 3
    2007-10-31 20:37:38.294 Connected to database 'mythconverg' at host:
    localhost
    2007-10-31 20:37:38.480 New DB connection, total: 4
    2007-10-31 20:37:38.482 Connected to database 'mythconverg' at host:
    localhost
    2007-10-31 20:37:38.489 New DB connection, total: 5
    2007-10-31 20:37:38.490 Connected to database 'mythconverg' at host:
    localhost
    2007-10-31 20:38:07.375 tv_find_grabbers exited early or we timed out waiting


    --
    Kim

  10. #10
    Join Date
    Oct 2007
    Beans
    2

    Re: Xmltv

    First off, I installed on RC so some things might have changed in the final release. These are my notes for getting xmltv to work (in Sweden, comhem), unfortunately my notes are not complete, but they might point you in the right direction.

    I found useful information at: http://hyams.webhop.net/mythtv/myth_ubuntu.html (section 6.1)
    and:
    http://tv.swedb.se/index.php

    you need to download and configure xmltv-util:
    sudo apt-get install xmltv-util

    then run:
    tv_grab_se_swedb --configure --config-file '/home/yourusername/.mythtv/swedb.xmltv'
    say yes to the channels you have

    then run:
    sudo mythfilldatabase --manual


    my list of channels:
    E5 1an
    E7 2an
    E8 4an
    E9 3an
    E10 24an
    E11 Uppsala kanalen
    SE10
    SE11 6an
    SE13 TV4sport
    SE14 MTV
    SE15 5an
    SE16 barn/kunskap
    SE17 TV6(maybe)
    SE18 8an
    S36 9an
    57 TV4+
    66 test kanal e66


    as I said, this is NOT an how-to, but could give you some ideas to try!
    Good luck!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •