Results 1 to 1 of 1

Thread: Can't switch to full screen in VMWare server on Ubuntu Gutsy.

  1. #1
    Join Date
    Aug 2005
    Beans
    27
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Question Can't switch to full screen in VMWare server 1.0.4 on Ubuntu 7.10.

    I have VMWare server 1.0.4 (with VMWare tools) installed on Ubuntu 7.10, I have ATI Mobility Radeon X1400. When I try to switch to full screen I get the error showed on the picture. Virtual machine screen resolution is 1024x768. Here is my xorg.conf file:
    Code:
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "ServerLayout"
        
        # Uncomment if you have a wacom tablet
        #    InputDevice     "stylus"    "SendCoreEvents"
        #    InputDevice     "cursor"    "SendCoreEvents"
        #    InputDevice     "eraser"    "SendCoreEvents"
        Identifier    "Default Layout"
      screen 0 "aticonfig-Screen[0]" 0 0
        Inputdevice    "Generic Keyboard"
        Inputdevice    "Configured Mouse"
        Inputdevice    "Synaptics Touchpad"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
        Load        "glx"
    EndSection
    
    Section "InputDevice"
        Identifier    "Generic Keyboard"
        Driver        "kbd"
        Option        "CoreKeyboard"
        Option        "XkbRules"    "xorg"
        Option        "XkbModel"    "pc105"
        Option        "XkbLayout"    "pl"
        Option        "XkbOptions"    "lv3:ralt_switch"
    EndSection
    
    Section "InputDevice"
        Identifier    "Configured Mouse"
        Driver        "mouse"
        Option        "CorePointer"
        Option        "Device"    "/dev/input/mice"
        Option        "Protocol"    "ImPS/2"
        Option        "ZAxisMapping"    "4 5"
        Option        "Emulate3Buttons"    "true"
    EndSection
    
    Section "InputDevice"
        Identifier    "Synaptics Touchpad"
        Driver        "synaptics"
        Option        "SendCoreEvents"    "true"
        Option        "Device"    "/dev/psaux"
        Option        "Protocol"    "auto-dev"
        Option        "HorizEdgeScroll"    "0"
        Option            "SHMconfig" "on"                 ##Added by me
    EndSection
    
    Section "InputDevice"
        Identifier    "stylus"
        Driver        "wacom"
        Option        "Device"    "/dev/input/wacom"
        Option        "Type"    "stylus"
        Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
        Identifier    "eraser"
        Driver        "wacom"
        Option        "Device"    "/dev/input/wacom"
        Option        "Type"    "eraser"
        Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
        Identifier    "cursor"
        Driver        "wacom"
        Option        "Device"    "/dev/input/wacom"
        Option        "Type"    "cursor"
        Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "Monitor"
        Identifier    "Generic Monitor"
        Option        "DPMS"
    EndSection
    
    Section "Monitor"
        Identifier    "aticonfig-Monitor[0]"
        Option        "VendorName"    "ATI Proprietary Driver"
        Option        "ModelName"    "Generic Autodetecting Monitor"
        Option        "DPMS"    "true"
    EndSection
    
    Section "Device"
        Identifier    "Generic Video Card"
        Driver        "fglrx"
        Busid        "PCI:1:0:0"
    EndSection
    
    Section "Device"
        Identifier    "aticonfig-Device[0]"
        Driver        "fglrx"
        Option        "VideoOverlay"    "on"
        Option        "OpenGLOverlay"    "off"
    EndSection
    
    Section "Screen"
        Identifier    "Default Screen"
        Device        "Generic Video Card"
        Monitor        "Generic Monitor"
        Defaultdepth    24
        SubSection "Display"
            Modes        "1440x900"    "1024x768"
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier    "aticonfig-Screen[0]"
        Device        "aticonfig-Device[0]"
        Monitor        "aticonfig-Monitor[0]"
        Defaultdepth    24
        SubSection "Display"
            Viewport    0    0
            Depth    24
        EndSubSection
    EndSection
    What should I do to correct this?
    Attached Images Attached Images
    Last edited by djRob; October 29th, 2007 at 06:52 AM.
    Ubuntu 7.10, Dell Inspiron 6400, intel Core2 Duo, 2GB RAM, ATI Mobility Radeon X1400.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •