Page 13 of 19 FirstFirst ... 31112131415 ... LastLast
Results 121 to 130 of 185

Thread: HOWTO: Install zsnes with libao support on AMD64

  1. #121
    Join Date
    Dec 2007
    Location
    California
    Beans
    4,900
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: HOWTO: Install zsnes with libao support on AMD64

    Idk; and btw the hardy package works great under Intrepid for me.
    "You can't expect to hold supreme executive power just because some watery tart lobbed a sword at you"

    "Don't let your mind wander -- it's too little to be let out alone."

  2. #122
    Join Date
    Jan 2006
    Beans
    2,031

    Re: HOWTO: Install zsnes with libao support on AMD64

    Downloaded the beta for Intrepid today, tried it from the live CD. My ethernet card was not working, most likely due to the e1000 driver being disabled in Intrepid because of a nasty firmware bug. I also was unable to get anything that used ALSA to output sound, this hopefully will be fixed when they release 8.10.

    So testing pSX was instantly out, since it will crash unless it's able to output sound and only outputs via ALSA. Tried the ZSNES i386 binary that's in the Intrepid repositories, it gave me a nasty buffer overflow crash. Compiled the 1.51b source myself, same crash. Compiled it again using gcc-4.1, worked fine (other than that I was unable to use ALSA, only OSS).

    Once Intrepid gets out of beta, I might try again. Until then, Hardy should hopefully work for everyone.

  3. #123
    Join Date
    Aug 2008
    Beans
    36

    Re: HOWTO: Install zsnes with libao support on AMD64

    Am i the only one who's had trouble installing 1.42?

    I ran into some of the Super Mario RPG bugs while running 1.51 and it seems the only solution thus far is to downgrade to 1.42 or 1.36

    I've tried installing from deb but it doesn't show up in synaptic and I'm still trying to get used to the way linux installs things.

    does anyone host a 1.42 so i can just do an apt-get? or maybe direct me to a newb-friendly guide xD

  4. #124
    Join Date
    Dec 2007
    Location
    California
    Beans
    4,900
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: HOWTO: Install zsnes with libao support on AMD64

    Quote Originally Posted by ynell View Post
    Am i the only one who's had trouble installing 1.42?

    I ran into some of the Super Mario RPG bugs while running 1.51 and it seems the only solution thus far is to downgrade to 1.42 or 1.36

    I've tried installing from deb but it doesn't show up in synaptic and I'm still trying to get used to the way linux installs things.

    does anyone host a 1.42 so i can just do an apt-get? or maybe direct me to a newb-friendly guide xD
    I'm compiling 1.42 right now if I can't get it compiled on my 64-bit machine (I've had problems in the past) then I'll have to have my 400mhz computer do it... might take a while do get it compiled for you if I have to use that computer.
    Last edited by jerome1232; October 16th, 2008 at 05:55 PM.
    "You can't expect to hold supreme executive power just because some watery tart lobbed a sword at you"

    "Don't let your mind wander -- it's too little to be let out alone."

  5. #125
    Join Date
    Aug 2008
    Beans
    36

    Re: HOWTO: Install zsnes with libao support on AMD64

    you don't have to go through all that xD i could try and do it myself if you wanted to link me somewhere haha

    But i also am running amd64

    thanks for your help :]

  6. #126
    Join Date
    Jan 2006
    Beans
    2,031

    Re: HOWTO: Install zsnes with libao support on AMD64

    Quote Originally Posted by jerome1232 View Post
    I'm compiling 1.42 right now if I can't get it compiled on my 64-bit machine (I've had problems in the past) then I'll have to have my 400mhz computer do it... might take a while do get it compiled for you if I have to use that computer.
    I've never been able to compile on a 64-bit machine, trying GCC flags to compile for 32-bit targets and such never worked. Using a chroot worked quite well though, or using a Live CD also works

    Quote Originally Posted by ynell View Post
    Am i the only one who's had trouble installing 1.42?

    I ran into some of the Super Mario RPG bugs while running 1.51 and it seems the only solution thus far is to downgrade to 1.42 or 1.36

    I've tried installing from deb but it doesn't show up in synaptic and I'm still trying to get used to the way linux installs things.

    does anyone host a 1.42 so i can just do an apt-get? or maybe direct me to a newb-friendly guide xD
    I went through my archives and this is what I came up with. Dunno if they will help or not. IIRC, I made these packages for Gutsy. One is a specific build designed for netplay, the other is the standard 1.42 release. They will use the same .zsnes/ configuration files as each other/1.51, so I'd be aware of that as it may cause problems if you have install more than one.
    Last edited by dfreer; October 16th, 2008 at 07:26 PM.

  7. #127
    Join Date
    Aug 2008
    Beans
    36

    Re: HOWTO: Install zsnes with libao support on AMD64

    sweet thanks a ton dfreer, used the standard 1.42 and it works perfectly :] your the man


    Jerome thanks for you good intentions, i appreciate it

  8. #128
    Join Date
    Dec 2007
    Location
    California
    Beans
    4,900
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: HOWTO: Install zsnes with libao support on AMD64

    Lol, well I guess I can stop that computer from compiling (man is it slow!)
    "You can't expect to hold supreme executive power just because some watery tart lobbed a sword at you"

    "Don't let your mind wander -- it's too little to be let out alone."

  9. #129
    Join Date
    Aug 2008
    Beans
    36

    Re: HOWTO: Install zsnes with libao support on AMD64

    Haha yeah nothing worse than a slow computer xD thanks anyways man :]

  10. #130
    Join Date
    Oct 2007
    Location
    Midwestern USA
    Beans
    29
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Install zsnes with libao support on AMD64

    Just wanted to report the zsnes32_1.51b3.5_hardy-amd64.deb is working great for me in Intrepid Ibex w/Compiz running.

    I followed this procedure to get my gamepad working:
    http://ubuntuforums.org/showpost.php...12&postcount=5

    Thank you so much!


    EDIT:

    I am getting considerable tearing in ZSNES, with both Compiz and Metacity. I am running an Nvidia card. Anyone have any suggestions to eliminate the tearing?
    Last edited by JayBee808; October 24th, 2008 at 09:58 PM. Reason: Tearing problem

Page 13 of 19 FirstFirst ... 31112131415 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •