Page 61 of 255 FirstFirst ... 1151596061626371111161 ... LastLast
Results 601 to 610 of 2548

Thread: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

  1. #601
    Join Date
    Nov 2005
    Beans
    56
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Quote Originally Posted by Trampis View Post
    Xlib: extension "GLX" missing on display ":0.0".
    That clearly indicates GLX is not running on your machine. Try 'glxinfo'.

    -Kalle.

    (p.s. And ignore this if for some reason that I can't possibly think of, which was made clear earlier in this thread, the quoted message in fact is invalid and GLX is in fact working. I haven't followed this thread slavishly. d.s.)

  2. #602
    Join Date
    Jul 2007
    Beans
    47
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    perhaps, the video card drivers on the cd are all .exe files so i would have to use wine to open them and i am not so sure how to do that beyond copying them all to the computer, last time i tried updating drivers it crashed the xserver, so i am hesitant to do so. is there a way i can update/install the drivers for my card (nvidia gforce 8600 gt)

    Quote Originally Posted by Kallewoof View Post
    That clearly indicates GLX is not running on your machine. Try 'glxinfo'.

    -Kalle.

    (p.s. And ignore this if for some reason that I can't possibly think of, which was made clear earlier in this thread, the quoted message in fact is invalid and GLX is in fact working. I haven't followed this thread slavishly. d.s.)
    glxinfo
    name of display: :0.0
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    Error: couldn't find RGB GLX visual

    visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
    id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
    ----------------------------------------------------------------------
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    0x21 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    0x22 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    Xlib: extension "GLX" missing on display ":0.0".
    Xlib: extension "GLX" missing on display ":0.0".
    0x3a 32 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
    i also updated the drivers to no avail, unless there is a better way to update than sudo aptitude install nvidia-glx
    Last edited by Trampis; July 28th, 2007 at 04:27 AM. Reason: new responce

  3. #603
    Join Date
    Jul 2007
    Beans
    103
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    The other posibilty is that GL is working,as in direct render with GL says enabled, and gears works etc but WoW just spits errors when you try to run it in GL mode saying not supported.

    Thats the really odd one I still want to work out myself

  4. #604
    Join Date
    Nov 2005
    Beans
    56
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Quote Originally Posted by Trampis View Post
    perhaps, the video card drivers on the cd are all .exe files so i would have to use wine to open them and i am not so sure how to do that beyond copying them all to the computer, last time i tried updating drivers it crashed the xserver, so i am hesitant to do so. is there a way i can update/install the drivers for my card (nvidia gforce 8600 gt)
    You need to install the NVIDIA drivers *for linux* on your machine. You can find them on nvidia.com, or you can use Envy to install them. I suggest using Envy, but yes, there is a chance your X might crash. If it does, you may want to write the following down on a piece of paper as it'll help you get back into X:

    Code:
    If the blue window appears saying it is unable to start X:
    1. Press <alt+f2> (to get a login prompt)
    2. Login as your user
    3. Do:
    sudo nano /etc/X11/xorg.conf
    Password: [your password]
    
    4. Scroll down until you locate something like this:
    Section "Device"
        Identifier     "NVIDIA Corporation NV43 [GeForce 6600 GT]"
        Driver         "nvidia"
    EndSection
    
    5. Change Driver from "nvidia" to "nv"
    
    6. Press <ctrl+X>, then press Y
    
    7. <ctrl+alt+del> to reboot entirely OR do sudo /etc/init.d/gdm restart
    Now... all this will do is get you back on the built-in nvidia driver, which won't let you play fancy games. But it'll let you back into X at least so you can read email and whatnot.

    Envy is available in Synaptic, so I suggest you install it from there. Otherwise you can google for 'nvidia envy' and find a more recent (maybe?) download from there. I know I've had issues with Envy since upgrading to Feisty, but it works most of the time, so I suppose I'm happy.

    -Kalle.

  5. #605
    Join Date
    Jul 2007
    Beans
    47
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    thanks, that got the game to the login screen but for some reason it is really slow or choppy.
    the messages i get back are
    fixme:system:SystemParametersInfoW Unimplemented action: 112 (SPI_GETMOUSESPEED)
    fixme:win:EnumDisplayDevicesW ((null),0,0x33edac,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x33f2d0,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x33f5b0,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x33f5a8,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x33f530,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x33f520,0x00000000), stub!
    fixme:system:SystemParametersInfoW Unimplemented action: 113 (SPI_SETMOUSESPEED)
    err:wgl:ConvertPixelFormatWGLtoGLX invalid iPixelFormat 0
    fixme:win:EnumDisplayDevicesW ((null),0,0x33f008,0x00000000), stub!
    fixme:system:SystemParametersInfoW Unimplemented action: 113 (SPI_SETMOUSESPEED)
    fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONNECT_TIMEOUT (5000): STUB
    fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT not supported on protocol 4
    fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONNECT_TIMEOUT (5000): STUB
    fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT not supported on protocol 4
    fixme:reg:GetNativeSystemInfo (0x37402524) using GetSystemInfo()
    fixmerocess:IsWow64Process (0xffffffff 0x7c8bd4a4) stub!
    fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONTEXT_VALUE; STUB
    fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONTEXT_VALUE; STUB
    fixme:wave:wodPlayer_Reset shouldn't have headers left
    fixme:imm:ImmAssociateContextEx (0x10024, (nil), 16): stub
    fixme:system:SystemParametersInfoW Unimplemented action: 113 (SPI_SETMOUSESPEED)
    any ideas?

  6. #606
    Join Date
    Nov 2005
    Beans
    56
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    What does 'glxinfo' say now?

    -Kalle.

  7. #607
    Join Date
    Jan 2007
    Beans
    Hidden!

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Good morning,

    One thinks its a good idea to make a post like this one, howto install WoW since many people are having huge problem about that.

    Although I also have a little problem, something I'm unable to find an answer to.

    http://ubuntuforums.org/showthread.php?t=511877

    If you could help me I would appreciate it a lot!
    IBM ThinkPad T43 - Born to be root
    CPU Intel Centrino Mobile Technology - 1.86 Ghz
    Memory 2gb 800Mhz

  8. #608
    Join Date
    Jul 2007
    Beans
    103
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Envy is a big help in getting the drivers on, otherwise you are trying to track down all sorts of other packages to compile the video kernel.

    I neded to do that before I could even get the ubuntu desktop gui

  9. #609
    Join Date
    Jul 2007
    Location
    Tucson Arizona
    Beans
    220
    Distro
    Ubuntu Development Release

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    dont you have to unnstall something when the new distro comes out though, i heard it was a major pain in the rear end

  10. #610
    Join Date
    May 2007
    Beans
    20
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Hi-

    I am newbish and when I run "wine WoW.exe" with ' SET axiGL "OpenGL" ' in Config.wtf I get the common - "World of Warcraft was unable to start 3D accelaration". If i use "d3d" it starts but runs very choppy, like .5 fps or something like that.

    I have an HP Pavillion dv6000 series laptop w/ nVidia Corporation C51 [Geforce 6150 Go].

    glxinfo:
    Code:
    glxinfo | grep vendor
    server glx vendor string: SGIt 
    client glx vendor string: SGI
    OpenGL vendor string: Mesa project: www.mesa3d.org
    Code:
    glxinfo | grep direct
    direct rendering: No
    OpenGL renderer string: Mesa GLX Indirect
    Conf.wtf
    Code:
    SET gxApi "OpenGL"
    SET hwDetect "0"
    SET gxColorBits "24"
    SET gxDepthBits "24"
    SET gxResolution "1024x768"
    SET gxRefresh "60"
    SET gxMultisampleQuality "0.000000"
    SET gxFixLag "0"
    SET SOUND ""
    SET fullAlpha "1"
    SET lodDist "100.000000"
    SET SmallCull "0.040000"
    SET DistCull "500.000000"
    SET trilinear "1"
    SET frillDensity "24"
    SET farclip "500.000000"
    SET specular "1"
    SET pixelShaders "1"
    SET particleDensity "1.000000"
    SET unitDrawDist "300.000000"
    SET movie "0"
    SET readTOS "1"
    SET readEULA "1"
    SET readScanning "-1"
    SET readContest "-1"
    SET realmList "us.logon.worldofwarcraft.com"
    SET soundMaxHardwareChannels "12"
    SET locale "enUS"
    SET realmName "Runetotem"
    SET scriptMemory "98304"
    SET gameTip "65"
    SET CombatLogRangeCreature "50"
    SET minimapInsideZoom "0"
    SET minimapZoom "4"
    SET MusicVolume "0.69999998807907"
    SET SoundVolume "0.60000002384186"
    SET MasterVolume "0.90000003576279"
    SET SoundZoneMusicNoDelay "1"
    SET AmbienceVolume "0.60000002384186"
    SET cameraView "2"
    SET expansionMovie "0"
    SET patchlist "us.version.worldofwarcraft.com"
    SET checkAddonVersion "0"
    SET showToolsUI "1"
    SET ffxDeath "0"
    SET ffxGlow "0"
    SET SoundOutputSystem "1"
    SET SoundBufferSize "150"
    I have done the strongly recommended regedit, and updated the drivers (I think) for nVidia with envy. For starters can someone tell me how to enable direct rendering? Any help is greatly appreciated.
    Last edited by dillinger417; July 30th, 2007 at 05:57 PM. Reason: adding info

Page 61 of 255 FirstFirst ... 1151596061626371111161 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •