Page 50 of 255 FirstFirst ... 40484950515260100150 ... LastLast
Results 491 to 500 of 2548

Thread: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

  1. #491
    Join Date
    May 2007
    Beans
    11

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Hurray!!! i finally got rid of the popping texture problem i had in opengl. I'm not 100% sure what did the trick, but i think i know.

    for those who haven't read my earlier post, i had a problem with how the terrain got rendered. When it got in range the texture popped up instead of fading in like normal.

    i was actually trying to fix some jaggies i had in beryl, and i found a howto. I cannot comfirm that this is why the problem got fixed, but it was gone right after i typed this code:

    Code:
    sudo ln -s /usr/lib/libGL.so.1 /usr/lib/libGL.so
    this also fixed the jaggies i had

    i'm pretty new in linux so i don't really know, but maybe it didn't like the name libGL.so.1

    so if anyone has this problem, try it out and let me know if it gets fixed..

  2. #492
    Join Date
    Mar 2006
    Location
    Faroe Islands
    Beans
    917

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Quote Originally Posted by naffenu View Post
    Basically, I copied the files over to the directories as stated, and tried to run the install from there, I get an error now when I try to do that...
    Please post that error message.

  3. #493
    Join Date
    Jun 2007
    Beans
    1

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Hello! I'm new and i got some Fps problems... when i'm in the outland the game fps are always between 6-10 and it makes the game very bad... But when i'm in Stormwind i can reach about 25 Fps... Anyone have the same problem or can help me? Thankss!!

  4. #494
    Join Date
    Jun 2007
    Beans
    2

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Ok so i started over with a fresh install last night.

    I installed my graphics with this guide http://www.psychocats.net/ubuntu/nvidia and i get the correct response when i try to find out if i have direct rendering.

    Now i have a few problems i cant run the game in opengl here is the response thati get in terminal

    ryan@ryan-firelight:~/.wine/drive_c/World of Warcraft$ wine WoW.exe -opengl
    fixme:advapi:SetSecurityInfo stub
    fixme:system:SystemParametersInfoW Unimplemented action: 112 (SPI_GETMOUSESPEED)
    fixmeowrprofllMain (0x7cb10000, 1, (nil)) not fully implemented
    fixme:ntdll:NtPowerInformation Unimplemented NtPowerInformation action: 11
    fixmeowrprofllMain (0x7cb10000, 0, (nil)) not fully implemented
    fixme:win:EnumDisplayDevicesW ((null),0,0x33edac,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x33f2ec,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x33f5cc,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x33f5c0,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x33f530,0x00000000), stub!
    fixme:win:EnumDisplayDevicesW ((null),0,0x33f520,0x00000000), stub!
    fixme:system:SystemParametersInfoW Unimplemented action: 113 (SPI_SETMOUSESPEED)
    err:wgl:ConvertPixelFormatWGLtoGLX invalid iPixelFormat 0
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_EnterSysLevel (0x7edc2940, level 2): Holding 0x7ecaeec0, level 3. Expect deadlock!
    err:syslevel:_CheckNotSysLevel Holding lock 0x7ecaeec0 level 3
    wine: Unhandled page fault on read access to 0x00000154 at address 0x7e06da33 (thread 0009), starting debugger...
    Unhandled exception: page fault on read access to 0x00000154 in 32-bit code (0x7e06da33).
    Register dump:
    CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b
    EIP:7e06da33 ESP:0033f5d0 EBP:7cab7000 EFLAGS:00210206( - 00 - RIP1)
    EAX:00000000 EBX:7c124e78 ECX:00000001 EDX:7c124e03
    ESI:7cabdfa0 EDI:7cad5144
    Stack dump:
    0x0033f5d0: 7cab7000 7cabdfa0 7cad5144 7cad5804
    0x0033f5e0: 00000001 00000001 01856302 00000000
    0x0033f5f0: 7e2e9042 00000000 000019c6 7c0e1f58
    0x0033f600: 00000001 00000005 0033f710 7c0e5654
    0x0033f610: 00000001 00000000 b7e207fc 7c0e1f58
    0x0033f620: 7e3dd830 7e990b2c 00000020 7c0482c8
    Backtrace:
    =>1 0x7e06da33 in libglcore.so.1 (+0x164a33) (0x7cab7000)
    2 0x7e85618c in libgl.so.1 (+0x3f18c) (0x7e844d58)
    3 0x5630ec83 (0x00768dc3)
    4 0x75010c6d (0x8302c783)
    5 0x00000000 (0x00000000)
    0x7e06da33: movl 0x154(%eax),%eax
    Modules:
    Module Address Debug info Name (93 modules)
    PE 340000- 3a9000 Deferred divxdecoder
    PE 400000- ceb000 Deferred wow
    PE 10000000-10090000 Deferred fmod
    ELF 7b800000-7b929000 Deferred kernel32<elf>
    \-PE 7b820000-7b929000 \ kernel32
    ELF 7bc00000-7bc98000 Deferred ntdll<elf>
    \-PE 7bc10000-7bc98000 \ ntdll
    ELF 7bf00000-7bf03000 Deferred <wine-loader>
    ELF 7ca18000-7ca2d000 Deferred psapi<elf>
    \-PE 7ca20000-7ca2d000 \ psapi
    ELF 7ca2d000-7ca77000 Deferred dbghelp<elf>
    \-PE 7ca40000-7ca77000 \ dbghelp
    ELF 7cb49000-7cb7b000 Deferred uxtheme<elf>
    \-PE 7cb50000-7cb7b000 \ uxtheme
    ELF 7cb7b000-7cb90000 Deferred midimap<elf>
    \-PE 7cb80000-7cb90000 \ midimap
    ELF 7cb90000-7cba8000 Deferred msacm32<elf>
    \-PE 7cba0000-7cba8000 \ msacm32
    ELF 7d2ff000-7d33b000 Deferred wineoss<elf>
    \-PE 7d310000-7d33b000 \ wineoss
    ELF 7d33d000-7d342000 Deferred libxfixes.so.3
    ELF 7d342000-7d34b000 Deferred libxcursor.so.1
    ELF 7d34b000-7d351000 Deferred libxrandr.so.2
    ELF 7d351000-7d359000 Deferred libxrender.so.1
    ELF 7d87f000-7d90e000 Deferred winex11<elf>
    \-PE 7d890000-7d90e000 \ winex11
    ELF 7d990000-7d9b0000 Deferred libexpat.so.1
    ELF 7d9b0000-7d9db000 Deferred libfontconfig.so.1
    ELF 7d9db000-7d9ef000 Deferred libz.so.1
    ELF 7d9ef000-7da5a000 Deferred libfreetype.so.6
    ELF 7da5a000-7db17000 Deferred comctl32<elf>
    \-PE 7da60000-7db17000 \ comctl32
    ELF 7db17000-7dc14000 Deferred shell32<elf>
    \-PE 7db30000-7dc14000 \ shell32
    ELF 7dc14000-7dc6d000 Deferred shlwapi<elf>
    \-PE 7dc20000-7dc6d000 \ shlwapi
    ELF 7dc6d000-7dc8d000 Deferred mpr<elf>
    \-PE 7dc70000-7dc8d000 \ mpr
    ELF 7dc8d000-7dcd6000 Deferred wininet<elf>
    \-PE 7dca0000-7dcd6000 \ wininet
    ELF 7dcd6000-7dd2b000 Deferred rpcrt4<elf>
    \-PE 7dce0000-7dd2b000 \ rpcrt4
    ELF 7dd2b000-7ddca000 Deferred ole32<elf>
    \-PE 7dd40000-7ddca000 \ ole32
    ELF 7ddca000-7de31000 Deferred msvcrt<elf>
    \-PE 7dde0000-7de31000 \ msvcrt
    ELF 7de31000-7de57000 Deferred msacm32<elf>
    \-PE 7de40000-7de57000 \ msacm32
    ELF 7de57000-7de74000 Deferred imm32<elf>
    \-PE 7de60000-7de74000 \ imm32
    ELF 7de74000-7de88000 Deferred lz32<elf>
    \-PE 7de80000-7de88000 \ lz32
    ELF 7de88000-7dea2000 Deferred version<elf>
    \-PE 7de90000-7dea2000 \ version
    ELF 7df07000-7df09000 Deferred libnvidia-tls.so.1
    ELF 7df09000-7e78f000 Export libglcore.so.1
    ELF 7e78f000-7e794000 Deferred libxdmcp.so.6
    ELF 7e794000-7e797000 Deferred libxau.so.6
    ELF 7e797000-7e817000 Deferred libglu.so.1
    ELF 7e817000-7e8a3000 Export libgl.so.1
    ELF 7e8a3000-7e994000 Deferred libx11.so.6
    ELF 7e994000-7e9a2000 Deferred libxext.so.6
    ELF 7e9a2000-7e9a7000 Deferred libxxf86vm.so.1
    ELF 7e9a7000-7e9bf000 Deferred libice.so.6
    ELF 7e9bf000-7ea40000 Deferred opengl32<elf>
    \-PE 7e9e0000-7ea40000 \ opengl32
    ELF 7ea40000-7ea53000 Deferred libresolv.so.2
    ELF 7ea53000-7ea71000 Deferred iphlpapi<elf>
    \-PE 7ea60000-7ea71000 \ iphlpapi
    ELF 7ea71000-7ea9e000 Deferred ws2_32<elf>
    \-PE 7ea80000-7ea9e000 \ ws2_32
    ELF 7ea9e000-7eab8000 Deferred wsock32<elf>
    \-PE 7eaa0000-7eab8000 \ wsock32
    ELF 7eab8000-7eb00000 Deferred advapi32<elf>
    \-PE 7eac0000-7eb00000 \ advapi32
    ELF 7eb00000-7eb0c000 Deferred libgcc_s.so.1
    ELF 7eb0d000-7eb16000 Deferred libsm.so.6
    ELF 7ec00000-7ecc0000 Deferred gdi32<elf>
    \-PE 7ec20000-7ecc0000 \ gdi32
    ELF 7ecc0000-7edfd000 Deferred user32<elf>
    \-PE 7ece0000-7edfd000 \ user32
    ELF 7edfd000-7ee8c000 Deferred winmm<elf>
    \-PE 7ee10000-7ee8c000 \ winmm
    ELF 7efa3000-7efae000 Deferred libnss_files.so.2
    ELF 7efae000-7efb8000 Deferred libnss_nis.so.2
    ELF 7efb8000-7efcf000 Deferred libnsl.so.1
    ELF 7efcf000-7eff6000 Deferred libm.so.6
    ELF 7eff7000-7f000000 Deferred libnss_compat.so.2
    ELF b7cd2000-b7cd6000 Deferred libdl.so.2
    ELF b7cd6000-b7e17000 Deferred libc.so.6
    ELF b7e18000-b7e2f000 Deferred libpthread.so.0
    ELF b7e39000-b7f4d000 Deferred libwine.so.1
    ELF b7f4f000-b7f6a000 Deferred ld-linux.so.2
    Threads:
    process tid prio (all id:s are in hex)
    0000000e
    0000000f 0
    0000000a
    0000000c 0
    0000000b 0
    00000008 (D) C:\World of Warcraft\WoW.exe
    00000009 0 <==

    Also here is my config file

    SET gxColorBits "24"
    SET gxDepthBits "24"
    SET gxResolution "1024x768"
    SET gxRefresh "60"
    SET hwDetect "0"
    SET fullAlpha "1"
    SET lodDist "100.000000"
    SET SmallCull "0.040000"
    SET DistCull "500.000000"
    SET trilinear "1"
    SET frillDensity "24"
    SET farclip "500.000000"
    SET specular "1"
    SET pixelShaders "1"
    SET particleDensity "1.000000"
    SET unitDrawDist "300.000000"
    SET movie "0"
    SET readTOS "1"
    SET realmList "us.logon.worldofwarcraft.com"
    SET readEULA "1"
    SET readScanning "-1"
    SET readContest "-1"
    SET gxMultisampleQuality "0.000000"
    SET gxFixLag "0"
    SET realmName "Muradin"
    SET gameTip "81"
    SET mouseSpeed "1"
    SET profanityFilter "0"
    SET MusicVolume "0.40000000596046"
    SET SoundVolume "1"
    SET MasterVolume "0.5"
    SET cameraYawMoveSpeed "180"
    SET cameraYawSmoothSpeed "180"
    SET cameraDistanceMaxFactor "1"
    SET AmbienceVolume "0.60000002384186"
    SET minimapInsideZoom "0"
    SET deselectOnClick "0"
    SET PreferedLocale "enUS"
    SET minimapZoom "0"
    SET scriptMemory "61440"
    SET locale "enUS"
    SET soundMaxHardwareChannels "12"
    SET accountName ""
    SET expansionMovie "0"
    SET CombatLogRangeParty "2000"
    SET CombatLogRangePartyPet "2000"
    SET CombatLogRangeFriendlyPlayers "2000"
    SET CombatLogRangeFriendlyPlayersPets "2000"
    SET CombatLogRangeHostilePlayers "2000"
    SET CombatLogRangeHostilePlayersPets "2000"
    SET CombatLogRangeCreature "2000"
    SET Gamma "1.000000"
    SET patchlist "us.version.worldofwarcraft.com"
    SET checkAddonVersion "0"
    SET EnableMusic "0"
    SET EnableErrorSpeech "0"
    SET EnableAmbience "0"
    SET EmoteSounds "0"
    SET ffxDeath "0"
    SET ffxGlow "0"
    SET SoundOutputSystem "1"
    SET SoundBufferSize "150"

    I can run the game in -d3d but when i do the game is all distorted and has lines in it to were i can barely see the pointer. I have tried uninstalling the graphics card then logging out to let it update then logging back in and reinstalling but it does not work.

    I did uninstall them once and then try the game before i restarted and (i was trying it in d3d) and the graphics were fine and every thing worked nut i only had about 5 fps.

    What is going on here?
    Last edited by Odoylerules; June 11th, 2007 at 12:41 PM.

  5. #495
    Join Date
    May 2007
    Beans
    162
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Okay here is my problem

    I have wow running perfectly on one PC, it runs with no errors at a nice fps. However when I've installed it on a second PC (My girlfriends) I've got it all working, but the fps is really low.

    I have done the registry tweak (And re-done it about four times to make sure there are no spelling errors etc. I've added all of the suggested SET variables to the config.wtf

    I've tried lowering the graphics (not that they should be a problem on this machine) and it managed to run worse (I'm not sure how)

    The FPS sticks around 6-10 when playing, it can sometimes get to 30 if I stand still looking at a wall or look up at the sky. But it's not playable when moving/fighting/looking around.

    The PC is running Ubuntu 7.04
    It has an intel Pentium 4 3.02Ghz processor
    1Gb of DDR2 RAM
    An Nvidia GeForce 6600

    It's running wine version "wine-0.9.38"

    Some other relevant information

    Code:

    glxinfo | grep vendor
    server glx vendor string: NVIDIA Corporation
    client glx vendor string: NVIDIA Corporation
    OpenGL vendor string: NVIDIA Corporation

    Code:

    glxinfo | grep 'OpenGL version'
    OpenGL version string: 2.1.0 NVIDIA 97.55

    I'm really confused as to what the problem is since it worked so well on my other PC. Thanks for any advice or help you can give me

    Nehvrook
    You don't need a reason to help people

    Ubuntu User #15665
    Linux user #450019

  6. #496
    Join Date
    Mar 2006
    Location
    Faroe Islands
    Beans
    917

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    @Nehvrook
    I actually haven't been playing now for a while, but for you I got myself a trial account and updated my WoW installation to 2.1, so I could check out WoW again just for you

    I've got pretty similar system specs, and I am able to run WoW without problems with 30+ fps, with all video settings maxed out.

    Intel P4 3.2 GHz
    2 GB RAM
    Nvidia 6800 256 mb ram
    Newest Nvidia driver and Wine version.

    So you see that in theory, this should be working for you too.

    Try changing the Windows version in winecfg.
    Try deleting Config.wtf (backup first). WoW should make a new clean one.



    @Odoylerules
    Have you tried both the 32 and 64 bit version of Wine? http://wine.budgetdedicated.com/archive/index.html

  7. #497
    Join Date
    May 2007
    Beans
    162
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Wow thanks

    Anyway to the problem

    Yeah we know we should be getting much better results, my own PC is very similar spec but is getting 30+ fps too and her PC runs it in Windows fine.

    We've already tried deleting the WTF folder (And Interface folder to remove mods too) but it makes no difference.

    The only thing I have noticed that makes a difference is removing the registry tweak and running the game with -opengl (Though I think that's done anyway in the config with a SET but since the WTF was deleted we ran it with that).
    When we run the game like this we get good FPS (Around 38 average), but only when running forward or standing still. As soon as we rotate the camera it drops to like 7 fps. With the registry tweak on it's constantly at about 5-7

    I'm really stumped by this, any more idea's?

    EDIT: Oh and we ran it in Windows 2000 compatibility, but I tried it in XP and there was no improvement so I switched it back. Should I try running through all of the different versions?
    Last edited by Nehvrook; June 12th, 2007 at 05:28 PM.
    You don't need a reason to help people

    Ubuntu User #15665
    Linux user #450019

  8. #498
    Join Date
    Jul 2006
    Location
    West Midlands, UK
    Beans
    642

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    There isn't a 32 and 64bit version of Wine, they are both exactly the same (content wise anyway).
    Wine FAQ and Newbie Guide - http://wiki.winehq.org/FAQ
    Please read This Page on how to install Wine.

    RetroTracks.net - Classic Game Music Tracks

  9. #499
    Join Date
    Jun 2007
    Location
    California
    Beans
    22
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Hello. Im experiencing extreme graphical glitching in wow under OpenGL mode with my Radeon 9000 (w/ the open source drivers I believe). None of these glitches are present with d3d but it runs sluggishly when I go to outside environments in that mode. It's hard to explain so here are some pictures. Text also does not load on the menu.









    Thanks in advance.

  10. #500
    Join Date
    Apr 2006
    Beans
    17

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    hi guys

    I've got a presario V3000 laptop
    graphics card : Mobile 945GM/GMS/940GML Express integrated graphics controller
    ram : 1G

    OS : Ubuntu 7.04

    Do you guys reckon that running WOW under wine will work fine in this system? if not then i will not even bother trying..

    Regards,

Page 50 of 255 FirstFirst ... 40484950515260100150 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •