Page 200 of 255 FirstFirst ... 100150190198199200201202210250 ... LastLast
Results 1,991 to 2,000 of 2548

Thread: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

  1. #1991
    Join Date
    Apr 2009
    Beans
    33

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    I actually have no idea what -opelgl means. Do I just type that into the terminal? When I do I get wine: could not load L"C:\\windows\\system32\\wow.exe": Module not found

  2. #1992
    Join Date
    Apr 2009
    Beans
    33

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    still not sure what 'opengl' means, but I disabled the pixel shading in winecfg and I got farther.

    Now it shows the correct load screen, and it actually loads me into the game. THEN it freezes completely to the point that I have to manually push the power button on the tower because nothing will respond.

  3. #1993
    Join Date
    Sep 2007
    Location
    UK
    Beans
    108
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Anyone had any problems running the 3.1.1 patch - I downloaded it as normal, but it bombed just after starting. I patched ok under windows (I share a single WoW installation between vista and heron) and it patched ok, but now it won't start in linux. I have had this problem before, and I solved it by deleting the patch*.mpq files, running repair then completely repatching under WINE (the previous time I had run the last patch on vista), but that won't work this time as that last patch doesn't seem to run. I have seen a problem with the 3.1.1 patch if the FS is ext4 but I think mine is VFAT.

  4. #1994
    Join Date
    May 2008
    Beans
    20

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Quote Originally Posted by horgabob View Post
    I actually have no idea what -opelgl means. Do I just type that into the terminal? When I do I get wine: could not load L"C:\\windows\\system32\\wow.exe": Module not found
    Okay, when you add -opengl to run line you open the game in opengl mod which wine can run the game faster.

    There are 2 ways to do it;
    You can open a console then go to wow folder,
    cd "/home/username/.wine/drive_c/Program Files/World Of Warcraft"
    then wine wow.exe -opengl

    Or you can open the wow folder-> WTF -> Config.wtf file and add SET gxApi "opengl" to that file. And run wow from it's shortcut.

    In opengl mod you should notice the fps increase.

  5. #1995
    Join Date
    May 2008
    Beans
    20

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Quote Originally Posted by Mad-Halfling View Post
    Anyone had any problems running the 3.1.1 patch - I downloaded it as normal, but it bombed just after starting. I patched ok under windows (I share a single WoW installation between vista and heron) and it patched ok, but now it won't start in linux. I have had this problem before, and I solved it by deleting the patch*.mpq files, running repair then completely repatching under WINE (the previous time I had run the last patch on vista), but that won't work this time as that last patch doesn't seem to run. I have seen a problem with the 3.1.1 patch if the FS is ext4 but I think mine is VFAT.
    Do you see any errors?

    Just a thought, check the mpq file names in data folder, i think they have to be in this format "common.MPQ", file names are lower case and file types are capital. This was a problem when wotlk released.

  6. #1996
    Join Date
    Apr 2009
    Beans
    33

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Quote Originally Posted by nsfnd View Post
    Okay, when you add -opengl to run line you open the game in opengl mod which wine can run the game faster.

    There are 2 ways to do it;
    You can open a console then go to wow folder,
    cd "/home/username/.wine/drive_c/Program Files/World Of Warcraft"
    then wine wow.exe -opengl

    Or you can open the wow folder-> WTF -> Config.wtf file and add SET gxApi "opengl" to that file. And run wow from it's shortcut.

    In opengl mod you should notice the fps increase.
    OK, I ran it in opengl, and the picture is incredibly messed up on the load screen. Again, it lets me load into the game, and right after I see my character pop up, it freezes. No errors, nothing, just a total lock up of my computer.

    This is frustrating!

  7. #1997
    Join Date
    May 2008
    Beans
    20

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    I checked winehq app db and saw hope for you

    A few steps you should follow if not already,
    1. Type "regedit" in console
    2. Go to HKEY_CURRENT_USER -> Software -> Wine
    3. Right click on Wine, select "New" then select "Key"
    4. Rename New Key #1 to OpenGL
    5. While the new OpenGL key selected, right click on the right pan, select "New" then select "String Value".
    6. Rename the new String Value to "DisabledExtensions" (case sensitive and without quotas)
    7. Double click on the new string value and type "GL_ARB_vertex_buffer_object" in the box.(case sensitive and without quotas)

    Then a change in the config.wtf, add this SET ffxGlow "0" to turn off fullscreen glow effect.

    And in appdb it says turn off compiz if its running.

    Give these a go. Gl

  8. #1998
    Join Date
    Apr 2009
    Beans
    33

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    I had already tried the regedit. I just tried adding the SET line to the config file, and it lasted about 5 more seconds before it froze...

    I even turned off compiz...even though i REALLY didn't want to lol

    Either way it's not working. I'll keep playing with it but i'm sick of restarting my computer

  9. #1999
    Join Date
    May 2008
    Beans
    20

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Quote Originally Posted by horgabob View Post
    I had already tried the regedit. I just tried adding the SET line to the config file, and it lasted about 5 more seconds before it froze...

    I even turned off compiz...even though i REALLY didn't want to lol

    Either way it's not working. I'll keep playing with it but i'm sick of restarting my computer
    I dont have an ati card so i cant suggest anything more :/

    About frozes, try to hit ctrl+alt+backspace instead of restarting.

  10. #2000
    Join Date
    Apr 2009
    Beans
    33

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Along the lines of it being Video Card specific...I'm pretty sure I have an ATI X1300 (though if someone could remind me of the terminal command to check that I'd double check).

    In 8.10 there was a proprietary driver that I needed to enable. In Jaunty, it doesn't seem to find that driver, or at least it doesn't show up when I go to Hardware Drivers.

    Any ideas or thoughts if that could be causing the problem/how I'd fix it?

Page 200 of 255 FirstFirst ... 100150190198199200201202210250 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •