Page 197 of 255 FirstFirst ... 97147187195196197198199207247 ... LastLast
Results 1,961 to 1,970 of 2548

Thread: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

  1. #1961
    Join Date
    Mar 2009
    Location
    Chicago, IL, USA
    Beans
    30
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Trying to figure out how to get this to work at all

    I try to run it from the terminal and I get this output:

    Code:
    ethan@ewhbuntu:~$ wine "C:\Program Files\World of Warcraft\WoW.exe"
    X Error of failed request:  BadValue (integer parameter out of range for operation)
      Major opcode of failed request:  161 (GLX)
      Minor opcode of failed request:  3 (X_GLXCreateContext)
      Value in failed request:  0x23
      Serial number of failed request:  142
      Current serial number in output stream:  142
    ethan@ewhbuntu:~$

    I'm not really sure what that means...also if I right-click from the "C" folder and "Open With Wine Windows Program Loader" I get some interesting results. If I open the "WoW.exe" file through that then the Blizzard Downloader icon shows up in the upper right corner but it never loads anything (Connection Info and Log show nothing at all, main screen just says "Waiting..." the whole time). If I do it on the Launcher.exe file nothing happens at all.


    Any suggestions?

  2. #1962
    Join Date
    Mar 2009
    Beans
    3

    Angry Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    I know there have been alot of posts here, and I'm not going to pretend that I know exactly how to run Ubuntu necessarily.(I have a friend who works with Ubuntu and he basically had to babystep me through to find my original files) If anyone can help me with my issues though, it would be a great help. Basically WoW is not running correctly (http://farm4.static.flickr.com/3655/...882c42.jpg?v=0)

    I have run all coding said in the post and I have now come to the point where WoW looks somewhat better but still unplayable (http://farm4.static.flickr.com/3628/...f1af42.jpg?v=0)
    With this set up, I can *move* but if i could rate the framerate, I'd put it at a 0, maybe one screen every 15 seconds at best

    My computer is a Sony Vaio VGN- N320E laptop. I have been reading up, and still have no solution Just hoping for someone out there to help little newbie me

  3. #1963
    Join Date
    Mar 2009
    Beans
    2

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Quote Originally Posted by T3X View Post
    I know there have been alot of posts here, and I'm not going to pretend that I know exactly how to run Ubuntu necessarily.(I have a friend who works with Ubuntu and he basically had to babystep me through to find my original files) If anyone can help me with my issues though, it would be a great help. Basically WoW is not running correctly (http://farm4.static.flickr.com/3655/...882c42.jpg?v=0)

    I have run all coding said in the post and I have now come to the point where WoW looks somewhat better but still unplayable (http://farm4.static.flickr.com/3628/...f1af42.jpg?v=0)
    With this set up, I can *move* but if i could rate the framerate, I'd put it at a 0, maybe one screen every 15 seconds at best

    My computer is a Sony Vaio VGN- N320E laptop. I have been reading up, and still have no solution Just hoping for someone out there to help little newbie me
    The following is a repost from http://ubuntuforums.org/showthread.php?t=377139


    OK, Sweet...sorry about my moment of weakness...

    If anyone has this Intel chipset, this is what I did, and it works fantastic!

    Install the latest Wine

    Copy all your WOW cds to a folder (overwriting as prompted)

    Run winecfg from a terminal.
    Change operating mode to Windows XP.
    Click the Audio tab.
    Make sure that OSS is selected for sound.
    Click Apply.
    Exit winecfg.

    Install WOW with wine.

    Go to your wine folder and go into your WOW folder. Then to the WTF folder. Edit the config.wtf. Add these lines:

    SET SoundOutputSystem "1"
    SET SoundBufferSize "150"
    SET gxApi "d3d"
    SET ffxGlow "0"

    (for some reason, the intel integrated graphics chip does not like OpenGL. Running the program in d3d mode works much better.)

    After you login, select your character, and enter the game, hit Escape and reduce all video options to the minimum you can go. Turn off weather effects, etc.

    With this configuration, I was actually able to run WOW with decent fps.

    Hope this helps someone!
    I also have a Sony Vaio VGN series. Mine is the N365E. This post helped me get the game playable, but still nowhere near as playable as the same rig running Windows. I think the main issue is that Intel drivers suck, especially their integrated chip-sets in their laptops.

    Unless Intel releases a better Linux driver, or Blizzard finally creates a Linux client, this is the best you'll be able to do. I hope this helps out out though. I get about 9-12 fps with relatively few graphical anomalies. Give it a try, and be sure to read through the entire thread I linked and follow it's links because there are a few other Intel specific settings you may need to incorporate which I dis-remember off the top of my head.

  4. #1964
    Join Date
    Oct 2008
    Beans
    51

    Exclamation Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    I followed the directions and keep these dialogs.
    I do have Compiz Fusion active. But after the last crashed it was deactivated. So I don't think it was the fault.

    System Information
    Manufacturer: HP Pavilion 061
    Product Name: DW230A-ABA a500n
    * CPU
    AMD Athon XP 2800+
    * RAM
    1.5 GB
    * Graphics card make and model
    nVIDIA 7600 GS 512MB
    * Graphics card driver version number
    I cant recall how to find my driver version.
    I sure it's 169.x
    * Wine version number
    1.0


    URL: http://gallery.pjcii.net/displayimag...album=12&pos=7


    URL: http://gallery.pjcii.net/displayimag...album=12&pos=8
    Ubuntu User #26207
    Slackware User #117
    OS/2 User #1,234,676

  5. #1965
    Join Date
    Jan 2008
    Beans
    11

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Hello. World of Warcraft freezes my whole PC in snowy areas (eg. in Winterspring or Alterac Valley). I can't play in zones with snow because I must reset my PC every ~3-5 minutes..... Can someone help me?

    MyPC
    My PC:
    Intel(R) Core(TM)2 Duo CPU E7200 @ 2.53GHz
    1GB of RAM
    Ati Radeon X300 (128 mb)
    Latest fglrx driver (Catalyst 9.2)
    Wine 1.1.17
    OS - Ubuntu 8.10
    Last edited by ludek_cortex; March 22nd, 2009 at 11:57 AM.

  6. #1966
    Join Date
    Oct 2008
    Beans
    51

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    aoss wine ".wine/drive_c/Program Files/games/World of Warcraft/WoW.exe" -opengl
    This command from the command line allowed me to run WOW. Notice I add aoss. this is a program that allows you run WOW in OSS and ALSA mixed mode. The -opengl uses OpenGL instead of the default DirectX that WOW tries to use even though it's running from Linux
    Last edited by Paulzy; March 24th, 2009 at 10:35 AM. Reason: errata
    Ubuntu User #26207
    Slackware User #117
    OS/2 User #1,234,676

  7. #1967
    Join Date
    Jun 2008
    Location
    London
    Beans
    4
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Okay, so I'm having a problem and I've spent hours searching forums and I can't find anyone else with the same one. Hopefully someone reading this may be able to help me out.

    I'm basically having all the issues described below (quote is taken from: https://help.ubuntu.com/community/Wo...#Configuration). The problem is that adding SET M2UseShaders "0" doesn't work. In fact it doesn't seem to make any difference at all. But from everything I've read it should solve my problem.

    "If you experience a problem with missing character and object models, and/or the login windows background is black, add:

    SET M2UseShaders "0""

    If anyone has any ideas at all as to why this solution isn't working, please let me know, could there be something overriding it? It's the only problem I'm having.

    My graphics card is an ATI Radeon Xpress (the one in the Dell Inspiron 1501). My drivers are up to date and I'm using the latest version of wine.
    I've done everything described in the post I quoted above including the registry config and like I said everything works except this.

    Please help.

  8. #1968
    Join Date
    Jun 2008
    Location
    London
    Beans
    4
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Lol, typically after all these hours of searching I find the solution 2 minutes after giving up and posting in a forum. In case anyone comes across this and is having the problem described in my above post the solution is to put:

    SET fixedFunction "1"
    SET ffx "0"

    in Config.wtf.
    Credit goes to these guys:
    http://forums.wow-europe.com/thread....63168401&sid=1

    Only problem is that my map's gone blank white but I can live with that ^_^

  9. #1969
    Join Date
    Mar 2009
    Beans
    1
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    I an having a problem with the world of warcraft .exe. I installed all parts of game (including lich king) and then after I tried using this one script to make it work better it says
    ERROR #132 (0x85100084) Fatal Exception
    Program: C:\Program Files\World of Warcraft\Wow.exe
    Exception: 0xC0000005 (ACCESS_VIOLATION) at 0073:00000000

    The instruction at 0x00000000 reference memory at 0x000000000
    the memory could not be "read"

    anyway any help I could get for this would be much apreciated. and by the way I am on ubuntu 8.10 intrepid IBEX....

  10. #1970
    Join Date
    Mar 2009
    Location
    Coahuila
    Beans
    1
    Distro
    Ubuntu 8.04 Hardy Heron

    Thumbs down Re: Howto: WOW with Wine (help.ubuntu.com/community/WorldofWarcraft)

    Quote Originally Posted by Paulzy View Post
    I followed the directions and keep these dialogs.
    I do have Compiz Fusion active. But after the last crashed it was deactivated. So I don't think it was the fault.

    System Information
    Manufacturer: HP Pavilion 061
    Product Name: DW230A-ABA a500n
    * CPU
    AMD Athon XP 2800+
    * RAM
    1.5 GB
    * Graphics card make and model
    nVIDIA 7600 GS 512MB
    * Graphics card driver version number
    I cant recall how to find my driver version.
    I sure it's 169.x
    * Wine version number
    1.0


    URL: http://gallery.pjcii.net/displayimag...album=12&pos=7


    URL: http://gallery.pjcii.net/displayimag...album=12&pos=8

    Im new in ubuntu, but a few mins ago i had same issue, same error# and all that stuff, i found somewhere in internet that wine was not "prepared" to run aplications that use DirectX ( as wow do), i found that u had to start wow using OpenGL , since i couldnt find Config.wtf in wow directory (i errased it) i opened a terminal and wrote:
    wine <drag wow.exe from wow directory> -OpenGL

    then wow started, y played a bit then i went to my wow directory and found my Config.wtf again, i opened it with the gedit (similar to windows notepad) and added the next lines (as the 1# post in this topic):

    SET SoundOutputSystem "1"
    SET SoundBufferSize "150"
    SET gxApi "OpenGL"


    PD: srry if u guys take looooong time to understand that ****... im not english speaker so... anyways.. that might be the answer for your problem.. at least it worked on my pc



    Amd athlon 4800 64x2
    1.5g ram Nvidia geforce 9800 512mb
    ubuntu 8.04 (hardy)

Page 197 of 255 FirstFirst ... 97147187195196197198199207247 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •