Results 1 to 6 of 6

Thread: Small but slightly frustrating wireless bug

  1. #1
    Join Date
    May 2005
    Beans
    13

    Wink Small but slightly frustrating wireless bug

    I have a Dlink usb adapter, its a DWL-G122 or something.

    It works fine, was detected in mythbuntu straight away, I used the network manager in xfce/mythbuntu to go in a set the encryption mode to wpa2 personal and put the password in.

    I ok to this and apply it, and my wireless runs beautifully.

    However, if i reboot the machine, the wireless does not automatically connect, I go back into the network config and initially it will display as though its on WPA2 and the password is in there. I close this, then go back in and see that it says WPA Personal (not WPA2) and the password is blank.

    I put it back on WPA2 and put the password in, and then I have my wireless working again!!

    Any help?? Also thought it'd be good to report in case it can be patched up before final.

  2. #2
    Join Date
    Oct 2005
    Location
    Austin, TX
    Beans
    2,983
    Distro
    Ubuntu Development Release

    Re: Small but slightly frustrating wireless bug

    Is this the only network you ever connect to?

    If so, then click the wireless icon and choose manual connection. You can configure permanent settings there.

  3. #3
    Join Date
    May 2005
    Beans
    13

    Wink Re: Small but slightly frustrating wireless bug

    Yep, this is at my home, I've got two myth combined backend/frontend systems both running mythbuntu ( I posted my two hardware configs a minute ago).

    The box in my bedroom is the one with the wireless issue, the one in my lounge room is wired with gigabit ethernet, so I can't confirm whether its just the specific hardware at this stage. I will do what you've suggested the second I get home from work.

    Thanks a lot.
    Last edited by propagandhi; October 12th, 2007 at 05:33 AM. Reason: incomplete reply posted last time

  4. #4
    Join Date
    Oct 2005
    Location
    Austin, TX
    Beans
    2,983
    Distro
    Ubuntu Development Release

    Re: Small but slightly frustrating wireless bug

    Well the issue at hand unfortunately affects both Ubuntu and Mythbuntu. It's because the password gets stored to a gnome keyring. In order to access that keyring, you need to actually login to the box (not automatic login). To automatically unlock it, you need libgnome-pam-keyring installed and to have your password that you login with set to the same as your keyring password.

    If you can configure it using manual configuration, you should be able to avoid these problems.

  5. #5
    Join Date
    May 2005
    Beans
    13

    Wink Re: Small but slightly frustrating wireless bug

    Excellent, thank you very much for your prompt and informative response. I'm just wondering if you ever find time to sleep....

  6. #6
    Join Date
    Oct 2007
    Beans
    502

    Re: Small but slightly frustrating wireless bug

    Quote Originally Posted by propagandhi View Post
    I'm just wondering if you ever find time to sleep....
    Most of the developers wonder about that, but we try not to wonder too much - just appreciate it

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •