Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 31

Thread: znes problems

  1. #21
    Join Date
    May 2007
    Location
    Sheffield, UK
    Beans
    1,219

    Re: znes problems

    I have this problem too. It's been filed as a bug from what I can tell, so hopefully there'll be some sort of fix coming shortly. The above commands didn't work for me unfortunately.

  2. #22
    Join Date
    Sep 2007
    Location
    On a small blue planet.
    Beans
    Hidden!

    Wink Re: znes problems

    Okay let me try again.

    Code:
    mkdir ~/.kde/socket-`hostname`
    chown -hR `id -n -g` ~/.kde
    chmod 755 -R ~/.kde
    How about that?

    I didn't actually test this on my box, no .kde folder... Anyway, I've used the commands before.

    Ideally, it will make the dir zsnes looks for. Make sure it's owned by your username, and that its permissions match those of the home folder.

    Pears for your heirs
    My GNU/Linux and Emulation blog.
    Resources for the nostalgic emulation enthusiast.

  3. #23
    Join Date
    Feb 2007
    Beans
    222
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: znes problems

    Thanks, problem sorted now . Seems that my suggestion was only a temporary fix.

  4. #24
    Join Date
    Jul 2007
    Beans
    399

    Re: znes problems

    Quote Originally Posted by chriswyatt View Post
    Fixed all those polling errors by allowing read permissions , ZSNES still won't run though.

    EDIT: It seems that if you run a KDE app before starting ZSNES it works! I'm not yet sure if this is permanent, but I'm guessing it probably is .
    Works for me. I start SMplayer b4 starting ZSNES

  5. #25
    Join Date
    May 2007
    Location
    Sheffield, UK
    Beans
    1,219

    Re: znes problems

    Quote Originally Posted by FranMichaels View Post
    Okay let me try again.

    Code:
    mkdir ~/.kde/socket-`hostname`
    chown -hR `id -n -g` ~/.kde
    chmod 755 -R ~/.kde
    How about that?

    I didn't actually test this on my box, no .kde folder... Anyway, I've used the commands before.

    Ideally, it will make the dir zsnes looks for. Make sure it's owned by your username, and that its permissions match those of the home folder.

    Ah haah! This worked for me! Thanks very much! It's a silly thing to go wrong though isn't it?

    But nevertheless, cheers for the lesson in bash.


  6. #26
    Join Date
    Sep 2007
    Location
    On a small blue planet.
    Beans
    Hidden!

    Wink Re: znes problems

    Quote Originally Posted by BigSilly View Post
    Ah haah! This worked for me! Thanks very much! It's a silly thing to go wrong though isn't it?

    But nevertheless, cheers for the lesson in bash.

    Hey, I am very glad it worked

    It was a learning experience for me too.

    As for the nature of bugs, of all the things to go wrong with emulating hardware, directory permissions? Very unrelated indeed

    P.S. I will submit this as an UbuntuForums How-To. Thank you for letting me know that it works!
    Pears for your heirs
    My GNU/Linux and Emulation blog.
    Resources for the nostalgic emulation enthusiast.

  7. #27
    Join Date
    Jun 2006
    Location
    a place.
    Beans
    37
    Distro
    Ubuntu Mate 14.04 Trusty Tahr

    Re: znes problems

    Since this thread is still rather live, I want to post an issue I'm having.

    I can get zsnes to load on 7.04 feisty with zsnes 1.51. But when the program loads, it detects my controller, a mayflash PS2 control to USB adapter, without any hat controls. I'm using the Gnome Joystick configuration utility and it detects the hat switch and analog sticks fine. Any idea how to fix this?

    Here's my terminal readout:

    Code:
    ZSNES v1.51, (c) 1997-2007, ZSNES Team
    Be sure to check http://www.zsnes.com/ for the latest version.
    
    ZSNES is written by the ZSNES Team (See AUTHORS.TXT)
    ZSNES comes with ABSOLUTELY NO WARRANTY.  This is free software,
    and you are welcome to redistribute it under certain conditions;
    please read 'LICENSE.TXT' thoroughly before doing so.
    
    Use ZSNES -? for command line definitions.
    
    Starting Mouse detection.
    Unable to poll /dev/input/event7. Make sure you have read permissions to it.
    Unable to poll /dev/input/event6. Make sure you have read permissions to it.
    Unable to poll /dev/input/event2. Make sure you have read permissions to it.
    Unable to poll /dev/input/event5. Make sure you have read permissions to it.
    Unable to poll /dev/input/event4. Make sure you have read permissions to it.
    Unable to poll /dev/input/event1. Make sure you have read permissions to it.
    Unable to poll /dev/input/event3. Make sure you have read permissions to it.
    Unable to poll /dev/input/event0. Make sure you have read permissions to it.
    ManyMouse: 0 mice detected.
    
    Audio Opened.
    Driver: Advanced Linux Sound Architecture (ALSA) output
    Channels: 2
    Rate: 32000
    
    Device 0 WiseGroup.,Ltd MP-8866 Dual USB Joypad
      6 axis, 12 buttons, 0 hats, 0 balls
    And as always... thanks to all for any help on this one.
    - herrdoktor330
    new rig! VIA pc-1 2500e mobo w/ 1.5ghtz C7-D, 1gb DDR2 533
    ...
    Your PIII is still faster.

  8. #28
    Join Date
    May 2007
    Beans
    646
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: znes problems

    "I'm using the Gnome Joystick configuration utility," herrdoktor330? AFAIK there isn't a joystick configuration utility included in Gnome. My guess is you've installed jscalibrator, which is likely the cause of your problem. It seems to disable the directional controls of controllers, while reporting that they're working perfectly.

    I'd suggest removing jscalibrator completely, including its configuration. You may have to restart X as well, or even reboot, to make sure your controller is properly re-detected.

  9. #29
    Join Date
    Aug 2007
    Beans
    83

    Re: znes problems

    When I first installed zsnes with add/remove programs it came up fine in windowed mode. Inside that window I changed it to go full screen(don't remember how) Now it opens the screen goas black for half a second and then it closes. I have uninstalled it with A/R and then reinstalled it, same result. I read on the forums about video output so I did the gedit ~/.zsnes/zsnesl.cfg and changed the video values to very low settings and it does the same thing.
    Anyone help me?
    I am using a old gateway 700 with 128 of ram and a vodoo 3 3000 vid card with 16 megs of ram on it.

  10. #30
    Join Date
    Sep 2007
    Location
    On a small blue planet.
    Beans
    Hidden!

    Cool Re: znes problems

    Try running zsnes from terminal. If it shows anything with the word mcop in it, look at the link in my sig for the solution.

    If it's a configuration problem, make sure the video options you chose in zsnesl.cfg don't have full (if fullscreen mode is really the problem... I don't think so though...) next to them.

    If neither of the above work, then rename or delete zsnesl.cfg
    Zsnes will have a fresh start.

    Pears for your heirs
    My GNU/Linux and Emulation blog.
    Resources for the nostalgic emulation enthusiast.

Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •