Page 88 of 99 FirstFirst ... 3878868788899098 ... LastLast
Results 871 to 880 of 981

Thread: How To: Manual Network Configuration without the need for Network Manager

  1. #871
    Join Date
    Oct 2007
    Location
    hk
    Beans
    707
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: How To: Manual Network Configuration without the need for Network Manager

    Hi, I finally got the native driver rtl8187 installed. But this time I cannot connect even without encryption.

    Here's the result:
    Code:
    coppen@coppen-laptop:~$ iwlist scan
    lo        Interface doesn't support scanning.
    
    eth0      Interface doesn't support scanning.
    
    wmaster0  Interface doesn't support scanning.
    
    wlan0     No scan results
    
    coppen@coppen-laptop:~$ sudo ifconfig wlan0 down
    [sudo] password for coppen: 
    coppen@coppen-laptop:~$ sudo dhclient -r wlan0
    Internet Systems Consortium DHCP Client V3.1.1
    Copyright 2004-2008 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/
    
    wmaster0: unknown hardware address type 801
    wmaster0: unknown hardware address type 801
    Listening on LPF/wlan0/00:22:43:74:7b:05
    Sending on   LPF/wlan0/00:22:43:74:7b:05
    Sending on   Socket/fallback
    DHCPRELEASE on wlan0 to 192.168.123.1 port 67
    send_packet: Network is unreachable
    send_packet: please consult README file regarding broadcast address.
    coppen@coppen-laptop:~$ sudo ifconfig wlan0 up
    coppen@coppen-laptop:~$ sudo iwconfig wlan0 essid "homerouter269x"
    coppen@coppen-laptop:~$ sudo iwconfig wlan0 mode Managed
    coppen@coppen-laptop:~$ sudo dhclient wlan0
    Internet Systems Consortium DHCP Client V3.1.1
    Copyright 2004-2008 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/
    
    wmaster0: unknown hardware address type 801
    wmaster0: unknown hardware address type 801
    Listening on LPF/wlan0/00:22:43:74:7b:05
    Sending on   LPF/wlan0/00:22:43:74:7b:05
    Sending on   Socket/fallback
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 19
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.
    Then I tried install wicd and wicd connected immediately. But wicd suffered from random disconnection due to the lack of a suffix on ESSID as you mentioned on the first post.
    Why this time I can't get dhclient work with the native driver?
    Thanks!

    EDIT: or is their any method to add a suffix for ESSID in wicd? Sorry that it is off-topic.
    Last edited by afeasfaerw23231233; March 4th, 2009 at 06:18 PM.
    Ubuntu 7.10 on P4 1.8G and PIII 933mHz

  2. #872
    Join Date
    Feb 2009
    Beans
    2

    Re: How To: Manual Network Configuration without the need for Network Manager

    This HowTo is excellent. However it is missing one important thing: if NetworkManager is installed (which it is by default, at least on Jaunty), you must first stop NetworkManager:

    sudo /etc/init.d/NetworkManager stop

    If you don't do this, and you're not running the NetworkManager applet (I run FVWM instead of gnome), then everything looks perfect in ifconfig and iwconfig, yet the wireless card will not associate with an access point.

  3. #873
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,554
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How To: Manual Network Configuration without the need for Network Manager

    I'm not sure if what you are telling me is correct. Ive been able to make a manual connection with network manager connected and running in the background. I haven't used Jaunty yet, however I can confirm this statement based on all versions back to Feisty. Its possible the interface wasn't taken down correctly or something. Maybe I can confirm your statement later when Jaunty final is released and I actually install it!

  4. #874
    Join Date
    Dec 2007
    Location
    Sitting on my bed
    Beans
    266
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How To: Manual Network Configuration without the need for Network Manager

    I am using Intrepid running on an Acer 5735. My router is an Orange Livebox

    I followed the WEP instructions and sudo dhclient wlan0 gave this

    Code:
    neil@neil-laptop:~$ sudo dhclient wlan0
    There is already a pid file /var/run/dhclient.pid with pid 17562
    killed old client process, removed PID file
    Internet Systems Consortium DHCP Client V3.1.1
    Copyright 2004-2008 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/
    
    wmaster0: unknown hardware address type 801
    wmaster0: unknown hardware address type 801
    Listening on LPF/wlan0/00:21:5d:74:69:f4
    Sending on   LPF/wlan0/00:21:5d:74:69:f4
    Sending on   Socket/fallback
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 19
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.
    What are the last two lines about
    If I ifconfig eth0 down I get
    Code:
    There is already a pid file /var/run/dhclient.pid with pid 20547
    Internet Systems Consortium DHCP Client V3.1.1
    Copyright 2004-2008 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/
    
    wmaster0: unknown hardware address type 801
    can't create /var/lib/dhcp3/dhclient.leases: Permission denied
    SIOCSIFADDR: Permission denied
    SIOCSIFFLAGS: Permission denied
    SIOCSIFFLAGS: Permission denied
    wmaster0: unknown hardware address type 801
    Open a socket for LPF: Operation not permitted
    Last edited by gleble; April 8th, 2009 at 01:20 PM. Reason: more info

  5. #875
    Join Date
    Dec 2007
    Location
    Sitting on my bed
    Beans
    266
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How To: Manual Network Configuration without the need for Network Manager

    Solved, pressed button 2 on the Livebox and everything works so I must have got it configured right anyway.

  6. #876
    Join Date
    Nov 2007
    Location
    Connecticut, USA
    Beans
    35
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: How To: Manual Network Configuration without the need for Network Manager

    This was helpful.
    I removed gnome-network-manager, and lost my connection, and couldn't bring it back up until I saw this.
    Now, the question I have is, what to do if I don't know the essid?
    I want the laptop to auto connect to wifi when I go to coffee shops, and stuff.
    I suppose now that I have the connection up again, I could re apt-get gnome-network-manager, but I don't use gnome (prefer openbox).
    I want to be able to connect from openbox, without gnome tools, and when I am roaming (unknown essid).
    How do I do that?
    --
    http://www.baldwinlinguas.com/ - translations & localization

  7. #877
    Join Date
    Oct 2006
    Location
    UK
    Beans
    54

    Re: How To: Manual Network Configuration without the need for Network Manager

    kevdog,

    I have an RT2500 pci wireless card that connects fine with the latest network manager applet in Jaunty using WPA....however any idea how to connect with WPA via a CLI only system?

    You mention using iwconfig and iwpriv in your guide, but the in-built RT2x00 drivers in Jaunty don't allow you to inject a key via iwpriv any more, returning "no private ioctls" when tried.

    Also I assume the serialmonkey route is now closed as they've dropped legacy support and it is their drivers that are built into the kernel.

    So how do you connect a RT2500 wifi card via the CLI with WPA now? Thanks.

  8. #878
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,554
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How To: Manual Network Configuration without the need for Network Manager

    TonyTraductor

    To see the networks around you:

    sudo iwlist scan

    This will show you the essids of the networks around you, and then you can connect.

    Its also possible to install and run wicd within openbox (Ive done this within e17). If you need a system tray app (trayer or docker), a wicd icon can be placed within the tray to give you feedback.

    stansford:

    Have you just tried the same old method as everyone else with the use of wpa supplicant?

  9. #879
    Join Date
    Oct 2006
    Location
    UK
    Beans
    54

    Re: How To: Manual Network Configuration without the need for Network Manager

    Quote Originally Posted by kevdog View Post
    TonyTraductor

    stansford:

    Have you just tried the same old method as everyone else with the use of wpa supplicant?

    - Yes I'm trying that method but have a problem (or two!).
    Don't know if you can help:

    1. From the articles I've read etc there seems to be confusion about what config info to place where. Eg Do you need to put info into /etc/network/interfaces or is it sufficient to specify ssid, WPA key etc in wpa_supplicant.conf alone?

    I'm not really clear about why you'd need both as it seems the information is duplicated if you put it in both files.

    Anyway, here's my wpa_supplicant.conf file:

    #--------
    ctrl_interface=/var/run/wpa_supplicant
    eapol_version=1
    ap_scan=1
    fast_reauth=1
    network={
    ssid="my-ssid"
    proto=WPA
    key_mgmt=WPA-PSK
    pairwise=TKIP
    group=TKIP
    psk=hex-key
    priority=5
    }

    Here's my /etc/network/interfaces file:

    auto wlan0
    iface wlan0 inet dhcp
    wpa-driver wext
    wpa-ssid my_essid
    wpa-ap-scan 1
    wpa-proto WPA
    wpa-pairwise TKIP
    wpa-group TKIP
    wpa-key-mgmt WPA-PSK
    wpa-psk hex_key

    I did a network restart:

    #sudo /etc/init.d/networking restart

    then bring up wlan0:

    #iwconfig wlan0 essid my-ssid
    -returns with no ouput

    then the command:
    #wpa_supplicant –iwlan0 –c~/wpa.conf -ddd
    - this is where the problem starts.
    - I don't seem to be able to associate with my router....I don't know why. I can see the message "no keys have been configured - skip keyring clearing" - then it times out and starts trying again.
    Eventually I control-C to quit

    I can attach the wpa_supplicant output if you want, but there is a lot of debugging stuff in there that I don't understand. However I see that wpa_supplicant does find my router and there's talk about WPA and wlan0 being up etc so it kinda feels like I'm not a million miles away and yet.....

    I appreciate this may not be your thing, but any help, answers/suggestion gratefully received. Thanks

  10. #880
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,554
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How To: Manual Network Configuration without the need for Network Manager

    Ok

    Lets clear up a few misconceptions that run across these forums.

    The /etc/network/interfaces file:

    This file is read when the command "ifup" is executed. You can think of it as the configuration file when ifup is executed. Processess such as Network Manager that run ifup, read this file. Note that the ifup (interfaces up) command is a much higher level command than the more basic command "ifconfig <interface name -- ie wlan0> up". ifup not only calls the ifconfig command given the paramaters in the /etc/network/interfaces file, but it also tries to set the route statement. I know the differences between the ifup and ifconfig <interface name> up command seems confusing, however the man pages -- man ip and man ifconfig may help to clear up the confusion. Bottom line however ifconfig <interface> up is a more lower level command than ifup and using the ifconfig command means the /etc/network/interfaces file is never read. So hence you don't need this command at all -- and hence you never need to do a sudo /etc/init.d/networking restart command.

    You wpa_supplicant.conf file is where you set your parameters that are read when you run the wpa_supplicant command. Ive noticed your wpa_supplicant.conf file is quite wordy. Meaning it seems to contain parameters that are excessive. I usually find a smaller wpa_supplicant.conf file to be more helpful than a larger one. I provided some examples in the instructions, and I would stick right now to using the format of the examples until things work. Adding a bunch of extra parameters -- although the man pages state you can do this -- in my experience usually messes up things.

    I also don't understand this statment:

    then bring up wlan0:

    #iwconfig wlan0 essid my-ssid
    -returns with no ouput


    What exactly is your interface name? Is it wlan0 or eth1 or something else? Usually typing ifconfig at the command line will help you with this, or typing lshw -C network, and then examining the ouput will help

    Bringing the interface up manually is usually like this:
    sudo ifconfig <interface -- wlan0 for example> up

    This activates the network card.

    To scan for networks
    sudo iwlist scan

    You don't need specify a interface specifically with this command although you could -- sudo iwlist <interface> scan. Without the interface parameter, the command will be run on all interfaces and not just on the one designated interface.

Page 88 of 99 FirstFirst ... 3878868788899098 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •