Page 38 of 99 FirstFirst ... 2836373839404888 ... LastLast
Results 371 to 380 of 981

Thread: How To: Manual Network Configuration without the need for Network Manager

  1. #371
    Join Date
    Mar 2008
    Beans
    4

    Re: How To: Manual Network Configuration without the need for Network Manager

    Doesn't work for my WPA setup (Atheros chipset).

    Here's the commands I've run and their outputs:

    --> lshw -C network

    *-network:0 DISABLED
    description: Ethernet interface
    product: 82801DB PRO/100 VE (LOM) Ethernet Controller
    vendor: Intel Corporation
    physical id: 8
    bus info: pci@0000:02:08.0
    logical name: eth0
    version: 81
    serial: 00:07:e9:e9:96:f1
    size: 10MB/s
    capacity: 100MB/s
    width: 32 bits
    clock: 33MHz
    capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.17-k4-NAPI duplex=half firmware=N/A latency=64 link=no maxlatency=56 mingnt=8 module=e100 multicast=yes port=MII speed=10MB/s
    *-network:1 DISABLED
    description: Wireless interface
    product: AR2413 802.11bg NIC
    vendor: Atheros Communications, Inc.
    physical id: c
    bus info: pci@0000:02:0c.0
    logical name: wifi0
    version: 01
    serial: 00:11:50:6f:a3:1e
    width: 32 bits
    clock: 33MHz
    capabilities: pm bus_master cap_list logical ethernet physical wireless
    configuration: broadcast=yes driver=ath_pci driverversion=0.9.4.5 (0.9.3.2) latency=168 maxlatency=28 mingnt=10 module=ath_pci multicast=yes wireless=IEEE 802.11g


    so, from the how to, the logical interface is "wifi0".

    next, I run:
    --> ifconfig wifi0 down
    --> dhclient -r wifi0

    There is already a pid file /var/run/dhclient.pid with pid 134519120
    Internet Systems Consortium DHCP Client V3.0.5
    Copyright 2004-2006 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/

    wifi0: unknown hardware address type 801
    wifi0: unknown hardware address type 801
    Listening on LPF/wifi0/
    Sending on LPF/wifi0/
    Sending on Socket/fallback


    Next, created file /etc/wpa_supplicant.conf

    ap_scan=1
    ctrl_interface=/var/run/wpa_supplicant

    network={
    ssid="Fretnoise"
    proto=WPA
    key_mgmt=WPA-PSK
    psk="welcome"
    pairwise=TKIP
    group=TKIP
    }


    Next, I run
    --> wpa_supplicant -w -Dmadwifi -iwifi0 -c/etc/wpa_supplicant.conf
    using "-Dmadwifi" because I have the ath_pci driver, and "-iwifi0" because that's the logical
    name...

    But, the output is:

    ioctl[SIOCSIWPMKSA]: Invalid argument
    ioctl[SIOCSIWMODE]: Invalid argument
    Could not configure driver to use managed mode
    ioctl[SIOCGIWRANGE]: Invalid argument
    ioctl[IEEE80211_IOCTL_SETPARAM]: Invalid argument
    ioctl[SIOCSIWAP]: Invalid argument
    Failed to initialize driver interface


    Hm... so, instead, I try
    --> wpa_supplicant -w -Dmadwifi -iath0 -c/etc/wpa_supplicant.conf

    which gives:

    ioctl[IEEE80211_IOCTL_SETMLME]: Invalid argument
    Association request to the driver failed
    Authentication with 00:00:00:00:00:00 timed out.
    ioctl[SIOCSIWSCAN]: Network is down
    Failed to initiate AP scan.


    Because it complains that network is down, I run
    --> ifconfig ath0 up

    and then again
    --> wpa_supplicant -w -Dmadwifi -iath0 -c/etc/wpa_supplicant.conf

    which now shows

    Trying to associate with 00:13:49:ee:7f:74 (SSID='Fretnoise' freq=2437 MHz)
    ioctl[IEEE80211_IOCTL_SETMLME]: Invalid argument
    Association request to the driver failed
    Associated with 00:13:49:ee:7f:74
    WPA: Key negotiation completed with 00:13:49:ee:7f:74 [PTK=TKIP GTK=TKIP]
    CTRL-EVENT-CONNECTED - Connection to 00:13:49:ee:7f:74 completed (auth) [id=0 id_str=]


    seems to look good, but the wpa_supplicant command doesn't stop, so I have to hit
    Control-C.

    Before I hit control C, so while wpa_supplicant was running, I run the following on another
    terminal:

    --> iwconfig

    lo no wireless extensions.

    eth0 no wireless extensions.

    wifi0 no wireless extensions.

    ath0 IEEE 802.11g ESSID:"Fretnoise" Nickname:""
    Mode:Managed Frequency:2.437 GHz Access Point: 00:13:49:EE:7F:74
    Bit Rate:1 Mb/s Tx-Power:9 dBm Sensitivity=1/1
    Retry: off RTS thr: off Fragment thr: off
    Encryption key:EF11-3FE9-DAA2-C8F1-AFD6-6A8C-C5CF-022E Security mode:restricted
    Power Management: off
    Link Quality=22/70 Signal level=-76 dBm Noise level=-98 dBm
    Rx invalid nwid:10896 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0


    after I've hit Control-C to stop wpa_supplicant, I run iwconfig on another terminal again, and
    now I get:

    ath0 IEEE 802.11g ESSID:"Fretnoise" Nickname:""
    Mode:Managed Channel:0 Access Point: Not-Associated
    Bit Rate:0 kb/s Tx-Power:9 dBm Sensitivity=1/1
    Retry: off RTS thr: off Fragment thr: off
    Encryption key: off
    Power Management: off
    Link Quality=0/70 Signal level=-99 dBm Noise level=-99 dBm
    Rx invalid nwid:15241 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0



    After this, I've followed with the other commands:
    --> ifconfig wifi0 up
    --> iwconfig wifi0 mode Managed
    --> dhclient wifi0

    For dhclient, the output was:

    There is already a pid file /var/run/dhclient.pid with pid 134519120
    Internet Systems Consortium DHCP Client V3.0.5
    Copyright 2004-2006 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/

    wifi0: unknown hardware address type 801
    wifi0: unknown hardware address type 801
    Listening on LPF/wifi0/
    Sending on LPF/wifi0/
    Sending on Socket/fallback
    DHCPDISCOVER on wifi0 to 255.255.255.255 port 67 interval 8
    DHCPDISCOVER on wifi0 to 255.255.255.255 port 67 interval 11
    DHCPDISCOVER on wifi0 to 255.255.255.255 port 67 interval 12
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.


    same result for using ath0 as interface, and while wpa_supplicant has associated
    access point, but hasn't stopped yet.



    Here's some facts:

    (1) I was able to connect using WPA before using Network Manager, then wasn't. After about 20
    tries, it worked again, but now it doesn't work anymore.

    (2) The HOWTO instructed me to use the logical name "wifi0" for <interface> - but that did not
    work for wpa_supplicant's -i argument

    (3) wpa_supplicant doesn't quick after it's associated the access point

    (4) when I run wpa_supplicant in the background, it associates AP, but running dhclient doesn't
    get a DHCHOFFER...

    (5) When I do a scan, the output is:

    Cell 03 - Address: 00:13:49:EE:7F:74
    ESSID:"Fretnoise"
    Mode:Master
    Frequency:2.437 GHz (Channel 6)
    Quality=15/70 Signal level=-80 dBm Noise level=-95 dBm
    Encryption keyn
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
    9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
    48 Mb/s; 54 Mb/s
    Extra:bcn_int=100
    IE: WPA Version 1
    Group Cipher : WEP-40
    Pairwise Ciphers (1) : WEP-40
    Authentication Suites (1) : PSK



    (6) wifi0: unknown hardware address type 801 --> is this really bad??



    What am I doing wrong?

    Thank's a bunch

  2. #372
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,605
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How To: Manual Network Configuration without the need for Network Manager

    For madwifi -- the actual hardware address is wifi0, however the way the driver is made it creates virtual interfaces to talk with the physical device. The first virtual interface made is ath0. You can only physically change the settings in the device by working through the ath0 interface and not wifi0. Please note this is special to the madwifi driver.

    Next there is one thing you posted that troubles me:

    *-network:1 DISABLED
    description: Wireless interface
    product: AR2413 802.11bg NIC
    vendor: Atheros Communications, Inc.
    physical id: c
    bus info: pci@0000:02:0c.0
    logical name: wifi0
    version: 01
    serial: 00:11:50:6f:a3:1e
    width: 32 bits
    clock: 33MHz
    capabilities: pm bus_master cap_list logical ethernet physical wireless
    configuration: broadcast=yes driver=ath_pci driverversion=0.9.4.5 (0.9.3.2) latency=168 maxlatency=28 mingnt=10 module=ath_pci multicast=yes wireless=IEEE 802.11g

    It states disabled. Does it still say this if you put
    sudo ifconfig ath0 up

    Does it still come back as disabled?

  3. #373
    Join Date
    Mar 2008
    Beans
    4

    Re: How To: Manual Network Configuration without the need for Network Manager

    It comes up as enabled when I run ifconfig ath0 up.

    After I sent this post, I rebooted later, and nm_applet and
    Network Manager have automatically succeeded in setting up
    wireless. But, it sporadically worked before, so I thought I was
    just lucky.... but, after 4 reboots, it still connects fine. And I did
    not run anything manually... confused but pleasantly surprised.

    So, I guess I'm good for now. Thank's for writing the HOWTO, even
    though it's confusing when configuring for ath0 and wifi0, since
    the same interface name cannot be used as stated in the HOWTO.
    Maybe the HOWTO could reflect this?

    Thank's

  4. #374
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,605
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How To: Manual Network Configuration without the need for Network Manager

    Yea I probably should change the instructions however with madwifi drivers they are the exception. Always exceptions to the rules which stick when trying to write a "general"tutorial

  5. #375
    Join Date
    Jan 2008
    Location
    Croatia
    Beans
    22

    Re: How To: Manual Network Configuration without the need for Network Manager

    when i do sudo dhclient it says cannot read or parse file /etc/wpa_supplicant.conf...
    How can i solve that?

  6. #376
    Join Date
    Mar 2008
    Beans
    4

    Re: How To: Manual Network Configuration without the need for Network Manager

    Ok, starting today it's not working again. Today I booted, logged in, and nm_applet connected me. After some hours, networking wasn't working, although nm_applet showed me the "staircaise". Trying to reconnect with nm_applet did not work. Reboot did not work (tried it twice).

    Since I could not get manual configuration working either, I'm out in the cold. Could you let me know what I did wrong when I tried to configure it manually? Should I post any syslog here? (I have logs for both successful and failed wireless networking).

    Thank's

  7. #377
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,605
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How To: Manual Network Configuration without the need for Network Manager

    Quote Originally Posted by archman View Post
    when i do sudo dhclient it says cannot read or parse file /etc/wpa_supplicant.conf...
    How can i solve that?

    Can you post your wpa_supplicant.conf file?

  8. #378
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,605
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How To: Manual Network Configuration without the need for Network Manager

    Quote Originally Posted by fretnoise View Post
    Ok, starting today it's not working again. Today I booted, logged in, and nm_applet connected me. After some hours, networking wasn't working, although nm_applet showed me the "staircaise". Trying to reconnect with nm_applet did not work. Reboot did not work (tried it twice).

    Since I could not get manual configuration working either, I'm out in the cold. Could you let me know what I did wrong when I tried to configure it manually? Should I post any syslog here? (I have logs for both successful and failed wireless networking).

    Thank's
    Just an idea since I see that you like the gui network manager gives you (a lot of people do). Uninstall network manager and try WICD. This provides a GUI, and I bet you will find this much more reliable.

  9. #379
    Join Date
    Jan 2008
    Location
    Croatia
    Beans
    22

    Re: How To: Manual Network Configuration without the need for Network Manager

    Quote Originally Posted by kevdog View Post
    Can you post your wpa_supplicant.conf file?
    ap_scan=1
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=0
    eapol_version=1
    ap_scan=0
    network={
    key_mgmt=IEEE8021X
    eap=TTLS
    anonymous_identity="xxx@yyy.yy"
    phase2="auth=PAP"
    identitctrl_interface=/var/run/wpa_supplicant
    ctrl_interfy="xxx@yyy.yy"
    password="xxx"
    }

    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=0
    eapol_version=1
    ap_scan=1
    network={
    ssid="eduroam"
    proto=WPA WPA2
    key_mgmt=WPA-EAP
    group=CCMP TKIP
    eap=TTLS
    anonymous_identity="xxx@yyy.yy"
    phase2="auth=PAP"
    identity="xxx@yyy.yy"
    password="xxx"
    }

  10. #380
    Join Date
    Mar 2008
    Location
    England
    Beans
    3
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: How To: Manual Network Configuration without the need for Network Manager

    stumped in this, I got as far as:
    sudo iwconfig <interface> essid "name"
    to be told its not supported - which is very nice, the wireless is connecting but I am not able to use firefox, or any other form of internet useage.

    will carry on searching but any suggestions would be gratefully recieved as I have 5 more of these waiting for the same treatment.
    driver is a b44, 1.01

Page 38 of 99 FirstFirst ... 2836373839404888 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •