Page 22 of 99 FirstFirst ... 1220212223243272 ... LastLast
Results 211 to 220 of 981

Thread: How To: Manual Network Configuration without the need for Network Manager

  1. #211
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,609
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How To: Manual Network Configuration without the need for Network Manager

    Can you list ifconfig? Your interface name is not wmaster.

  2. #212
    Join Date
    Feb 2007
    Location
    Germany
    Beans
    160
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How To: Manual Network Configuration without the need for Network Manager

    Quote Originally Posted by kevdog View Post
    Can you list ifconfig? Your interface name is not wmaster.
    Here is the output of lshw. I don't know how to list ifconfig.

    hugo@hugo-laptop:~$ lshw -C network
    WARNING: you should run this program as super-user.
    *-network:0 DISABLED
    description: Wireless interface
    product: RT2500 802.11g Cardbus/mini-PCI
    vendor: RaLink
    physical id: a
    bus info: pci@00:0a.0
    logical name: wmaster0
    version: 01
    serial: 00:10:60:65:a5:8f
    width: 32 bits
    clock: 33MHz
    capabilities: bus_master cap_list logical ethernet physical wireless
    configuration: broadcast=yes driver=rt2500pci latency=128 multicast=yes wireless=IEEE 802.11g
    resources: iomemory:f0000000-f0001fff irq:20
    *-network:1
    description: Ethernet interface
    product: VT6102 [Rhine-II]
    vendor: VIA Technologies, Inc.
    physical id: 12
    bus info: pci@00:12.0
    logical name: eth0
    version: 74
    serial: 00:40:d0:97:93:c7
    width: 32 bits
    clock: 33MHz
    capabilities: bus_master cap_list ethernet physical
    configuration: broadcast=yes driver=via-rhine driverversion=1.4.3 ip=192.168.2.20 latency=128 maxlatency=8 mingnt=3 multicast=yes
    resources: ioport:e200-e2ff iomemory:f0002100-f00021ff irq:19
    BenQ Joybook LIte U102
    Ubuntu isn't all that I hoped it would be because I WANT IT ALL

  3. #213
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,609
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How To: Manual Network Configuration without the need for Network Manager

    This is your wireless driver:
    driver=rt2500pci

    The built-in rt2500pci driver in gutsy is sketchy. Id recommend a different driver. You have 3 options:

    1. The serial monkey rt2500 cvs driver: http://ubuntuforums.org/showthread.p...ghlight=rt2500
    2. Ndiswrapper + windowsxp driver: http://ubuntuforums.org/showthread.p...ht=ndiswrapper
    3. Upgrade to Hardy's developing kernel and use the rt2x00 driver: http://ubuntuforums.org/showthread.php?t=646755

    The first option is probably the easiest, but they all work.

  4. #214
    Join Date
    Aug 2005
    Location
    North of the Artic
    Beans
    85
    Distro
    Ubuntu Intrepid Ibex (testing)

    Re: How To: Manual Network Configuration without the need for Network Manager

    Thanks Kevdog, good hints here

    I forgot that love existed - Van Morrison

  5. #215
    Join Date
    May 2007
    Location
    San Francisco
    Beans
    9
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Question Re: How To: Manual Network Configuration without the need for Network Manager

    Quote Originally Posted by kevdog View Post
    You've got me on that one. Id make sure your router was not doing any MAC filtering or have any other restrictive protocols in place. Ive only read of a few others reporting chipset/router combination problems, and I've wondered if its actually true.
    I'm looking through my router settings. It's funny that another laptop running Ubuntu (with a different wireless device chipset) is able to easily connect. Additionally, I have one other laptop with exactly the same wireless device chipset running Winders and it is unable to connect to the access point too.

  6. #216
    Join Date
    Jan 2008
    Location
    Galway, Ireland
    Beans
    26
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: How To: Troubleshoot your Wireless Network Connection - Connecting at Command Li

    Quote Originally Posted by walterhisownself View Post
    I can see my network with "iwlist scan" or "iwlist ath0 scanning"


    Here's the output:


    Cell 02 - Address: 02:19:5B:C7:8F:97
    ESSID:"collards"
    Mode:Master
    Frequency:2.462 GHz (Channel 11)
    Quality=46/70 Signal level=-49 dBm Noise level=-95 dBm
    Encryption keyff
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
    24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
    12 Mb/s; 48 Mb/s


    I can see other networks and actually the laptop connected automatically when I unplugged it from ethernet to another unsecured network because I have it in roaming mode. I saw the Network Manager icon in the upper right panel attempt to connect to any unsecured network and it was successful in joining that network.
    Apologies for parachuting in like this. I've been haunting this thread for a while trying to solve an issue hugely similar to the above. Same symptoms, different hardware. The PCI card is an Encore ENPWI-G2 card with a Realtek 8185 chipset.

    I've ndiswrapper'd the driver from the factory CD and loaded it.

    Code:
     ndiswrapper -l
    net8185 : driver installed
    
     lsmod
    Module                  Size  Used by
    ndiswrapper           185240  0 
    
     ifconfig
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:66 errors:  0  dropped:  0  overruns:  0  frame: 0
              TX packets:66 errors:  0  dropped:  0  overruns:  0  carrier: 0
              collisions:  0  txqueuelen:  0  
              RX bytes:5104 (4.9 KB)  TX bytes:5104 (4.9 KB)
    
    wlan0     Link encap:Ethernet  HWaddr 00:08:54:AF:4B:C8  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:  0  errors:  0  dropped:  0  overruns:  0  frame: 0
              TX packets:1 errors:  0  dropped:  0  overruns:  0  carrier: 0
              collisions:  0  txqueuelen:1000 
              RX bytes:  0  (0.0 b)  TX bytes:  0  (0.0 b)
              Interrupt:11 Memory:34000000-34000025 
    
     iwconfig
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11g  ESSID:off/any  
              Mode:Auto  Frequency:2.412 GHz  Access Point: Not-Associated   
              Bit Rate:54 Mb/s   Tx-Power:-2147483648 dBm   Sensitivity=0/3  
              RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality:  0   Signal level:  0   Noise level:0
              Rx invalid nwid:  0   Rx invalid crypt:  0   Rx invalid frag: 0
              Tx excessive retries:  0   Invalid misc:  0    Missed beacon: 0
    
     sudo lshw -C network
    
      *-network               
           description: Wireless interface
           product: RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 1
           bus info: pci@0000: 02: 00.0
           logical name: wlan0
           version: 20
           serial: 00: 08:54:af:4b:c8
           width: 32 bits
           clock: 33MHz
           capabilities: pm bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=ndiswrapper+net8185 driverversion=1.45+Realtek,02/08/2006,5.105.0. latency=64 link=no maxlatency=64 mingnt=32 module=ndiswrapper multicast=yes wireless=IEEE 802.11g
    
     sudo iwlist wlan0 scan
    wlan0     Scan completed :
              Cell 01 - Address: 00: 0F:CC:AB:9F:F4
                        ESSID:"KennyNET"
                        Protocol:IEEE 802.11g
                        Mode:Managed
                        Frequency:2.442 GHz (Channel 7)
                        Quality:79/100  Signal level:-45 dBm  Noise level:-96 dBm
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
                        Extra:bcn_int=100
                        Extra:atim=0
    
     sudo ifconfig wlan0 down
    
     sudo dhclient -r
    
    Internet Systems Consortium DHCP Client V3.0.5
    Copyright 2004-2006 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/
    
    Listening on LPF/wlan0/00:08:54:af:4b:c8
    Sending on   LPF/wlan0/00:08:54:af:4b:c8
    Sending on   Socket/fallback
    
     sudo iwconfig wlan0 essid "KennyNET" key restricted s:************************** mode Managed
    
     sudo dhclient wlan0
    
    There is already a pid file /var/run/dhclient.pid with pid 134519120
    Internet Systems Consortium DHCP Client V3.0.5
    Copyright 2004-2006 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/
    
    Listening on LPF/wlan0/00:  08:54:af:4b:c8
    Sending on   LPF/wlan0/00:  08:54:af:4b:c8
    Sending on   Socket/fallback
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.
    
     iwconfig
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11g  ESSID:off/any  
              Mode:Auto  Frequency:2.442 GHz  Access Point: Not-Associated   
              Bit Rate:54 Mb/s   Tx-Power:-2147483648 dBm   Sensitivity=0/3  
              RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality:  0   Signal level:  0   Noise level:0
              Rx invalid nwid:  0   Rx invalid crypt:  0   Rx invalid frag:  0
              Tx excessive retries:  0   Invalid misc:  0    Missed beacon:  0
    
     ifconfig
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:66 errors:  0  dropped:  0  overruns:  0  frame:  0
              TX packets:66 errors:  0  dropped:  0  overruns:  0  carrier:  0
              collisions:  0  txqueuelen:  0  
              RX bytes:5104 (4.9 KB)  TX bytes:5104 (4.9 KB)
    
    wlan0     Link encap:Ethernet  HWaddr 00:08:54:AF:4B:C8  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:  0  errors:  0  dropped:  0  overruns:  0  frame:  0
              TX packets:1 errors:  0  dropped:  0  overruns:  0  carrier:  0
              collisions:  0  txqueuelen:1000 
              RX bytes:  0  (0.0 b)  TX bytes:  0  (0.0 b)
              Interrupt:11 Memory:34000000-34000025 
    
    wlan0:ava Link encap:Ethernet  HWaddr 00:08:54:AF:4B:C8  
              inet addr:169.254.7.210  Bcast:169.254.255.255  Mask:255.255.0.0
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              Interrupt:11 Memory:34000000-34000025
    That's about all the diagnostic I know how to run. I can ping the loopback device 127.0.0.1 but not the router 192.168.1.254. As far as I can see I don't have MAC address filtering enabled on the router and I'm broadcasting the SSID.

    I've been slowly chipping away at this for a few weeks but I've finally plateau'd in terms of things to try.

    Any new avenues to disappear down would be gratefully accepted.

    Here's hoping',
    dee_kay

  7. #217
    Join Date
    Jun 2007
    Beans
    26
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How To: Manual Network Configuration without the need for Network Manager

    I'm not sure if anyone is having these same problems setting up wpa_supplicant manually per the tutorial here, but if someone could help diagnose my problem that would be great --

    Attached is the terminal output from setting up wpa_supplicant and the relevant driver and config information.

    Thanks in advance!

    scott@scott-laptop:~$ sudo ifconfig wifi0 down

    scott@scott-laptop:~$ sudo dhclient -r wifi0
    Internet Systems Consortium DHCP Client V3.0.5
    Copyright 2004-2006 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/

    wifi0: unknown hardware address type 801
    wifi0: unknown hardware address type 801
    Listening on LPF/wifi0/
    Sending on LPF/wifi0/
    Sending on Socket/fallback


    scott@scott-laptop:~$ sudo wpa_supplicant -w -Dmadwifi -iwifi0 -c/etc/wpa_supplicant.conf
    ioctl[SIOCSIWPMKSA]: Invalid argument
    ioctl[SIOCSIWMODE]: Invalid argument
    Could not configure driver to use managed mode
    ioctl[SIOCGIWRANGE]: Invalid argument
    ioctl[IEEE80211_IOCTL_SETPARAM]: Invalid argument
    ioctl[SIOCSIWAP]: Invalid argument
    Failed to initialize driver interface


    scott@scott-laptop:~$ sudo ifconfig ath0 down

    scott@scott-laptop:~$ sudo wpa_supplicant -w -Dmadwifi -iath0 -c/etc/wpa_supplicant.conf
    Trying to associate with 00:1d:7e:3a:cb:6e (SSID='Linksys54G' freq=2452 MHz)
    Associated with 00:1d:7e:3a:cb:6e
    WPA: 4-Way Handshake failed - pre-shared key may be incorrect
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys


    .....when trying to run the wpa_supplicant.conf again, I get this message:

    scott@scott-laptop:~$ sudo wpa_supplicant -w -Dmadwifi -iath0 -c/etc/wpa_supplicant.conf
    ctrl_iface exists and seems to be in use - cannot override it
    Delete '/var/run/wpa_supplicant/ath0' manually if it is not used anymore
    Failed to initialize control interface '/var/run/wpa_supplicant'.
    You may have another wpa_supplicant process already running or the file was
    left by an unclean termination of wpa_supplicant in which case you will need
    to manually remove this file before starting wpa_supplicant again.


    __________________________________________________ ______________________________________

    scott@scott-laptop:~$ lshw -C network
    *-network
    description: Ethernet interface
    product: 88E8039 PCI-E Fast Ethernet Controller
    vendor: Marvell Technology Group Ltd.
    physical id: 0
    bus info: pci@0000:02:00.0
    logical name: eth0
    version: 15
    serial: 00:1a:80:24:d7:fa
    width: 64 bits
    clock: 33MHz
    capabilities: bus_master cap_list ethernet physical
    configuration: broadcast=yes driver=sky2 driverversion=1.18 firmware=N/A latency=0 module=sky2 multicast=yes
    *-network
    description: Wireless interface
    product: AR5006EG 802.11 b/g Wireless PCI Express Adapter
    vendor: Atheros Communications, Inc.
    physical id: 0
    bus info: pci@0000:06:00.0
    logical name: wifi0
    version: 01
    serial: 00:1d:d9:de:5b:a8
    width: 64 bits
    clock: 33MHz
    capabilities: bus_master cap_list logical ethernet physical wireless
    configuration: broadcast=yes driver=ath_pci latency=0 module=ath_pci multicast=yes wireless=IEEE 802.11g

    scott@scott-laptop:~$ sudo ifconfig
    ath0 Link encap:Ethernet HWaddr 00:1D: D 9: DE:5B:A8
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:19 errors:0 dropped:0 overruns:0 frame:0
    TX packets:22 errors:5 dropped:5 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:2147 (2.0 KB) TX bytes:2727 (2.6 KB)

    eth0 Link encap:Ethernet HWaddr 00:1A:80:24: D7:FA
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:17

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    wifi0 Link encap:UNSPEC HWaddr 00-1D-D9-DE-5B-A8-00-00-00-00-00-00-00-00-00-00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:3359 errors:0 dropped:0 overruns:0 frame:138
    TX packets:517 errors:0 dropped:5 overruns:0 carrier:0
    collisions:0 txqueuelen:199
    RX bytes:496502 (484.8 KB) TX bytes:27625 (26.9 KB)
    Interrupt:18


    scott@scott-laptop:~$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wifi0 no wireless extensions.

    ath0 IEEE 802.11g ESSID:"Linksys54G" Nickname:""
    Mode:Managed Frequency:2.452 GHz Access Point: 00:1D:7E:3A:CB:6E
    Bit Rate:54 Mb/s Tx-Power:15 dBm Sensitivity=1/1
    Retry: off RTS thr: off Fragment thr: off
    Power Management: off
    Link Quality=21/70 Signal level=-69 dBm Noise level=-90 dBm
    Rx invalid nwid:5989 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    scott@scott-laptop:~$ iwlist scan
    lo Interface doesn't support scanning.

    eth0 Interface doesn't support scanning.

    wifi0 Interface doesn't support scanning.

    ath0 Scan completed :

    Cell 02 - Address: 00:1D:7E:3A:CB:6E
    ESSID:"Linksys54G"
    Mode:Master
    Frequency:2.452 GHz (Channel 9)
    Quality=16/70 Signal level=-79 dBm Noise level=-95 dBm
    Encryption key: on
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
    24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
    12 Mb/s; 48 Mb/s
    Extra:bcn_int=100
    IE: WPA Version 1
    Group Cipher : WEP-40
    Pairwise Ciphers (1) : WEP-40
    Authentication Suites (1) : PSK

  8. #218
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,609
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How To: Manual Network Configuration without the need for Network Manager

    scott@scott-laptop:~$ sudo wpa_supplicant -w -Dmadwifi -iath0 -c/etc/wpa_supplicant.conf
    Trying to associate with 00:1d:7e:3a:cb:6e (SSID='Linksys54G' freq=2452 MHz)
    Associated with 00:1d:7e:3a:cb:6e
    WPA: 4-Way Handshake failed - pre-shared key may be incorrect
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys

    The command line seems to be correct. Can you attempt to start the process including a -dd flag -- it should list more output that might help.

  9. #219
    Join Date
    Jun 2005
    Beans
    40

    Re: How To: Manual Network Configuration without the need for Network Manager

    Hi folks,

    I'm having a hard time connecting to my wireless network

    I have a RT2500 (Ralink) card. If I follow the instructions set out on this thread: http://ubuntuforums.org/showthread.php?t=571188 (the "WPA with Ra Based Chipsets" bit) it looks like I'm connected to the network (i.e. the network icon on the top right of the screen shows as being connected). However even though I can connect to my router I cannot connect to the wider internet.

    Doesn't make any sense to me... but I'd love any help anyone could offer.

    (I'm on Ubuntu 7.04, would 7.10 be a better bet?)
    Last edited by jackwhite; February 10th, 2008 at 05:06 PM.

  10. #220
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,609
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How To: Manual Network Configuration without the need for Network Manager

    Ok lets just test a few things since its either a route or gateway problem.


    Can you ping the router by IP address or google by IP address
    64.233.187.99? If you get a response its a DNS problem

    Can you also post route -n

Page 22 of 99 FirstFirst ... 1220212223243272 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •