Quote Originally Posted by Lytspeed View Post
Hello again,

Someone please tell me what I'm missing. There has to be a better solution than this to let me access the :0 screen from my inferior XP box!
Check that the vnc module is being loaded when X starts... should say so in the /var/log/Xorg.0.log

---
(II) LoadModule: "vnc"
(II) Loading /usr/lib/xorg/modules/extensions//libvnc.so
(II) Module vnc: vendor="RealVNC Ltd"
compiled for 4.3.99.902, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension VNC
---

Also check that the /etc/X11/xorg.conf file contains the appropriate vncpassword file. Should be something like

---
Section "Screen"
Identifier "Dummy Screen"
Device "Dummy GFX Card"
Monitor "Dummy Monitor"
DefaultDepth 16
SubSection "Display"
Modes "1024x768" "800x600" "640x480"
EndSubSection
Option "PasswordFile" "/root/.vnc/passwd"
EndSection
---

Good luck,
Munge.