View Poll Results: Has this thread been helpful?

Voters
182. You may not vote on this poll
  • Yes

    94 51.65%
  • No

    38 20.88%
  • Somewhat

    50 27.47%
Page 51 of 70 FirstFirst ... 41495051525361 ... LastLast
Results 501 to 510 of 700

Thread: HOWTO: RT2500, etc. wireless cards

  1. #501
    Join Date
    May 2006
    Location
    100acrewood
    Beans
    7,467
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: HOWTO: RT2500, etc. wireless cards

    Quote Originally Posted by studentz View Post
    Hi weiman01.

    My laptop is 32-bit before I upgraded to hardy my wireless worked fine.
    I post the rest of inf.

    Thanks
    OK then. Could you point me to the driver that you have used? Just want to check something.

  2. #502
    Join Date
    Sep 2007
    Beans
    19

    Re: HOWTO: RT2500, etc. wireless cards

    I use the driver shipped by the laptop manufacturer (last version WinXP)
    Here is the drive inf
    ~$ dmesg | grep rt2500
    [ 63.403908] ndiswrapper: driver rt2500 (Ralink Technology, Inc.,06/10/2004, 2.02.06.0000) loaded
    [ 63.654592] wlan0: ethernet device 00:11:09:0f:1e:ae using NDIS driver: rt2500, version: 0x20001, NDIS version: 0x500, vendor: 'IEEE 802.11g Wireless Card.', 1814:0201.5.conf

  3. #503
    Join Date
    May 2006
    Location
    100acrewood
    Beans
    7,467
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: HOWTO: RT2500, etc. wireless cards

    studentz,

    Really beats me...

  4. #504
    Join Date
    Sep 2007
    Beans
    19

    Re: HOWTO: RT2500, etc. wireless cards

    Hi weiman01

    Here is something interesting. I use my old pcmcia network card with a similar chipset Ralink rt2500 and it works. Unfortunately, I cannot use my pcmcia port with my nice sound card. I post all inf.

    Other forum suggests to use the serial monkey rt2500 driver and blacklist the alternative driver rt2500pci which comes with the kernel. I tried to blacklist rt2500pci using "echo 'blacklist rt2500pci' | sudo tee -a /etc/modprobe.d/blacklist".This command add the line "blacklist rt2500pci" to blacklist, but when you ask for ndiswrapper -l you still can see the alternative driver, and the wlan0 did not work.

    Any suggestions?

    Thanks for your time and support.



    ~$ lspci -nn | grep Network
    00:09.0 Network controller [0280]: RaLink RT2500 802.11g Cardbus/mini-PCI [1814:0201] (rev 01)
    02:00.0 Network controller [0280]: RaLink RT2500 802.11g Cardbus/mini-PCI [1814:0201] (rev 01)

    ~$ dmesg | grep rt2500
    [ 59.360469] ndiswrapper: driver rt2500 (Ralink Technology, Inc.,06/10/2004, 2.02.06.0000) loaded
    [ 59.611257] wlan0: ethernet device 00:11:09:0f:1e:ae using NDIS driver: rt2500, version: 0x20001, NDIS version: 0x500, vendor: 'IEEE 802.11g Wireless Card.', 1814:0201.5.conf
    [ 288.764000] wlan1: ethernet device 00:50:18:2e:6a:83 using NDIS driver: rt2500, version: 0x20001, NDIS version: 0x500, vendor: 'IEEE 802.11g Wireless Card.', 1814:0201.5.conf


    ~$ lshw -C network

    *-network
    description: Wireless interface
    product: RT2500 802.11g Cardbus/mini-PCI
    vendor: RaLink
    physical id: 0
    bus info: pci@0000:02:00.0
    logical name: wlan1
    version: 01
    serial: 00:50:18:2e:6a:83
    width: 32 bits
    clock: 33MHz
    capabilities: bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=ndiswrapper+rt2500 driverversion=1.45+Ralink Technology, Inc.,06/ ip=192.168.2.108 latency=64 module=ndiswrapper multicast=yes wireless=IEEE 802.11g


    *-network:0
    description: Wireless interface
    product: RT2500 802.11g Cardbus/mini-PCI
    vendor: RaLink
    physical id: 9
    bus info: pci@0000:00:09.0
    logical name: wlan0
    version: 01
    serial: 00:11:09:0f:1e:ae
    width: 32 bits
    clock: 33MHz
    capabilities: bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=ndiswrapper+rt2500 driverversion=1.45+Ralink Technology, Inc.,06/ latency=64 module=ndiswrapper multicast=yes wireless=IEEE 802.11g
    *-network:1
    description: Ethernet interface
    product: VT6102 [Rhine-II]
    vendor: VIA Technologies, Inc.
    physical id: 12
    bus info: pci@0000:00:12.0
    logical name: eth0
    version: 74
    serial: 00:40:45:27:32:14
    width: 32 bits
    clock: 33MHz
    capabilities: bus_master cap_list ethernet physical
    configuration: broadcast=yes driver=via-rhine driverversion=1.4.3 latency=64 maxlatency=8 mingnt=3 module=via_rhine multicast=yes


    ~$ sudo ifconfig
    eth0 Link encap:Ethernet HWaddr 00:40:45:27:32:14
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:510 errors:0 dropped:0 overruns:0 frame:0
    TX packets:243 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:97102 (94.8 KB) TX bytes:36866 (36.0 KB)
    Interrupt:18 Base address:0xd400

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:1261 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1261 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:178041 (173.8 KB) TX bytes:178041 (173.8 KB)

    wlan0 Link encap:Ethernet HWaddr 00:11:09:0f:1e:ae
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:19 Memory:febfe000-fec00000

    wlan1 Link encap:Ethernet HWaddr 00:50:18:2e:6a:83
    inet addr:192.168.2.108 Bcast:192.168.2.255 Mask:255.255.255.0
    inet6 addr: fe80::250:18ff:fe2e:6a83/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:3090 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3047 errors:0 dropped:2 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:2961200 (2.8 MB) TX bytes:421361 (411.4 KB)
    Interrupt:16 Memory:24000000-24002000

    ~$ sudo ifconfig
    eth0 Link encap:Ethernet HWaddr 00:40:45:27:32:14
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:510 errors:0 dropped:0 overruns:0 frame:0
    TX packets:243 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:97102 (94.8 KB) TX bytes:36866 (36.0 KB)
    Interrupt:18 Base address:0xd400

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:1261 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1261 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:178041 (173.8 KB) TX bytes:178041 (173.8 KB)

    wlan0 Link encap:Ethernet HWaddr 00:11:09:0f:1e:ae
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:19 Memory:febfe000-fec00000

    wlan1 Link encap:Ethernet HWaddr 00:50:18:2e:6a:83
    inet addr:192.168.2.108 Bcast:192.168.2.255 Mask:255.255.255.0
    inet6 addr: fe80::250:18ff:fe2e:6a83/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:3090 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3047 errors:0 dropped:2 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:2961200 (2.8 MB) TX bytes:421361 (411.4 KB)
    Interrupt:16 Memory:24000000-24002000

    ~$ sudo iwlist scan
    lo Interface doesn't support scanning.

    eth0 Interface doesn't support scanning.

    wlan0 No scan results

    wlan1 Scan completed :
    Cell 01 - Address: 00:18:39:72:57:AD
    ESSID:"TEST"
    Protocol:IEEE 802.11b
    Mode:Managed
    Frequency:2.437 GHz (Channel 6)
    Quality:60/100 Signal level:-57 dBm Noise level:-96 dBm
    Encryption keyn
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
    24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
    12 Mb/s; 48 Mb/s
    Extra:bcn_int=100
    Extra:atim=0
    IE: WPA Version 1
    Group Cipher : TKIP
    Pairwise Ciphers (1) : TKIP
    Authentication Suites (1) : PSK

    Last edited by studentz; April 30th, 2008 at 05:12 PM.

  5. #505
    Join Date
    May 2006
    Location
    100acrewood
    Beans
    7,467
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: HOWTO: RT2500, etc. wireless cards

    Serialmonkey's driver is an option, however, it does not work at all with Network Manager. You will have to configure your network from command line.

    If you decide to use their driver, then you have to remove 'ndiswrapper' entirely. Just remove it using Synaptics as it will confict with the other driver.

  6. #506
    Join Date
    Sep 2007
    Beans
    19

    Re: HOWTO: RT2500, etc. wireless cards

    Hi weiman01

    My subliminal question was How I can blacklist alternative drive rt2500pci so I only will have rt2500 drive working.

    Thanks

  7. #507
    Join Date
    May 2006
    Location
    100acrewood
    Beans
    7,467
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: HOWTO: RT2500, etc. wireless cards

    You can just open the blacklist by issuing:
    sudo gedit /etc/modprobe.d/blacklist
    Then add:
    rt2500pci
    That should do. Just play around with the blacklist.

  8. #508
    Join Date
    May 2008
    Beans
    2

    Re: HOWTO: RT2500, etc. wireless cards

    Hello everyone. I am running Hardy 64 with a rt2500pci on a asus m2n-e sli.

    The good news is out of the box I could connect to my wpa 1/2 tkip/aes network! I had upgraded from gutsy 64 to hardy. And after messing with wcid and trying to reinstall gnome network manager I messed up everything pretty badly and was getting some HAL initialization error.

    Well I now have a fresh install of hardy that I am going to treat very gently now. The problem is that I am maxing out at 30 kb/s on all networking things combined(media streaming from my media server, internet, everything). I know it is not my modem (I'm downloading things at 800 kb/s on my torrent box...)

    My router is a wrt54gl with tomato 1.19(most recent i believe) on it.

    While I realize I am way ahead of some as far as out of the box working... I really don't want to copy all of my hd movies to my computer and would LOVE to be back up to my wonderful xp wireless speeds.

    I am a complete noob on Ubuntu and would love to keep using it as my desktop (i even got all my games working under wine!!!) so please help me find a way around this problem and get it all up to speed... i dont want something this minor to force me back to windows.

    let me know what you want me to pull up in terminal if you want to see some settings. Also if the windows driver wrapper is my best bet and i should just follow the guide let me know, but if it is already sortof working that seams possibly counter productive.

  9. #509
    Join Date
    May 2006
    Location
    100acrewood
    Beans
    7,467
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: HOWTO: RT2500, etc. wireless cards

    samm71790,

    As far as I can tell you are one of the lucky ones as your adapters works out of the box. As for your performance issues, all I can advise is that you try this tutorial and use "ndiswraper" rather than the orginial driver.

    Problem is that you are on 64-bit which is a headache for some. You will have to get a copy of the 64-bit XP drivers in order for this tutorial to work. Will that be a problem?

  10. #510
    Join Date
    Feb 2007
    Location
    Germany
    Beans
    160
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: RT2500, etc. wireless cards

    I run Hardy 64 and I followed the instructions on my Laptop with integrated RT2500 chip.
    Works great until I try to hibernate when it tells me I am attempting to run a 32 bit driver on a 64 bit kernel. You don't need to be Sherlock Holmes to work out what the problem is...Is there a way around this, because on resume I have no wireless even though Wiradar sees the network.
    BenQ Joybook LIte U102
    Ubuntu isn't all that I hoped it would be because I WANT IT ALL

Page 51 of 70 FirstFirst ... 41495051525361 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •