Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: call of duty

  1. #1
    Join Date
    Apr 2007
    Location
    Hale Bopp
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Wink call of duty

    HI All

    tried to intall COD1 via wine on 6.10. CD1 works fine but wont let me intall CD2.

    any ideas

    regards

  2. #2
    Join Date
    Apr 2007
    Location
    Stockholm, Sweden
    Beans
    2,042

    Re: call of duty

    What does it say?
    nissband.com my post-metal/instrumental

  3. #3
    Join Date
    Oct 2005
    Location
    U.S.A.
    Beans
    4,164
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: call of duty

    Call of Duty can't be installed normally through Wine. You can get around the CD switch problem by entering "wine eject D:" in a terminal, but the install will fail completely when you have to switch back to the first CD. There is a Loki installer script that can install the game for you, you can get it here (right-click the link and "Save link as"):
    http://mirrors.reallan.net/pub/games....5-english.run

    Linux User #355330 | Ubuntu User #15618 | Last.FM

  4. #4
    Join Date
    Apr 2007
    Location
    Hale Bopp
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: call of duty

    HI Guys

    thanks for that

    regards

  5. #5
    Join Date
    Oct 2005
    Location
    U.S.A.
    Beans
    4,164
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: call of duty

    Almost forgot, after the install completes, you will likely get a "wine is not in your PATH" error when you try to run the codsp or codmp launch scripts. You can get around it by running the script with bash instead os "sh" or "./".
    Code:
    bash codsp

    Linux User #355330 | Ubuntu User #15618 | Last.FM

  6. #6
    Join Date
    Apr 2007
    Location
    Hale Bopp
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Red face Re: call of duty

    Thanks for that.

    im new to Ubuntu. can you tell me next steps after downloading the loki installer?

    much obliged

  7. #7
    Join Date
    Apr 2007
    Location
    Stockholm, Sweden
    Beans
    2,042

    Re: call of duty

    You don't need loki installer, I didn't
    nissband.com my post-metal/instrumental

  8. #8
    Join Date
    Oct 2005
    Location
    U.S.A.
    Beans
    4,164
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: call of duty

    Okay, first you need to make the script executable. Open a terminal and run this:
    Code:
    chmod +x call.of.duty_1.5-english.run
    The script requires the libgtk 1.2 package if you don't already have it installed, run this:
    Code:
    sudo apt-get install libgtk1.2
    Then put in the first CoD cd, change directories to wherever you downloaded the script and run the installer like this:
    Code:
    ./call.of.duty_1.5-english.run
    You can accept the default install options. The installer will likely produce one warning (Gdk-WARNING **: locale not supported by C library) and one error (ERROR: No matching delta for /home/<username>/cod/Main/pak0.pk3), both can be ignored. Once the installer completes, change directories to the game's install directory (default is "/home/<username>/cod") and run the game like this:
    Code:
    bash codsp
    For multiplayer, run this:
    Code:
    bash codmp
    That should be it.

    Quote Originally Posted by Tux0r View Post
    You don't need loki installer, I didn't
    How did you get past the error after the second CD swap? That one still occurs for me and it prevents the single player game from running. I think multiplayer might work, but that doesn't really matter since PunkBuster can't work anyway. Whatever caused the error also prevents me from updating the game to 1.5 or installing the United Offensive expansion pack.
    Last edited by cogadh; September 28th, 2007 at 03:52 PM.

    Linux User #355330 | Ubuntu User #15618 | Last.FM

  9. #9
    Join Date
    Apr 2007
    Location
    Hale Bopp
    Beans
    Hidden!
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Talking Re: call of duty

    Hi

    superb advice. Game running well.

    i am indebted to you.

    regards

  10. #10
    Join Date
    Oct 2007
    Location
    wrong planet
    Beans
    746
    Distro
    Ubuntu 9.10 Karmic Koala

    Exclamation Re: call of duty

    Quote Originally Posted by cogadh View Post
    Call of Duty can't be installed normally through Wine. You can get around the CD switch problem by entering "wine eject D:" in a terminal, but the install will fail completely when you have to switch back to the first CD. There is a Loki installer script that can install the game for you, you can get it here (right-click the link and "Save link as"):
    http://mirrors.reallan.net/pub/games....5-english.run
    Which other Call of Duties can run native in Linux? That would be nice, but I don't think COD4 can.
    Linux Advanced Guides and News!
    http://linuxinnovations.blogspot.com/

    Green means go, Yellow means faster, Red means don't stop.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •