Page 13 of 48 FirstFirst ... 3111213141523 ... LastLast
Results 121 to 130 of 477

Thread: [Howto] Successfully install the svn MPlayer under Hardy Heron

  1. #121
    Join Date
    Oct 2007
    Location
    Bristol, England
    Beans
    40

    Re: [Howto] Successfully install the svn mplayer + gmplayer + all the codecs.

    I'd imagine it would not work, as the PS3 would require specific PowerPC builds.

    But there is a guide on here about installing a custom PS3 mplayer build http://linux.yes.nu/PS3Ubuntu/

  2. #122
    Join Date
    Dec 2006
    Beans
    7,299

    Re: [Howto] Successfully install the svn mplayer + gmplayer + all the codecs.

    Hi,

    Took me a while to realise that you meant Play Station 3 Obviously I am a little behind the times as I had no idea a Linux distro could be placed on such a machine!

    Quote Originally Posted by mrdustinf View Post
    Im not sure if anyone else is having this problem or not. Im trying to install Mplayer using your walkthrough but Im installing it on the PS3 with Gutsy.

    When it trys to install the dev files you have listed the first one gives an error
    E: Couldn't find package avifile-divx-plugin

    Im very new to linux so any help will be appreciated. Thanks alot.
    Nevertheless the avifile-divx-plugin does exist, but you will have to enable the multiverse repositories. From the following page:

    http://packages.ubuntu.com/gutsy/allpackages

    avifile-divx-plugin (1:0.7.47.20070718-1ubuntu2) [multiverse]
    Divx4Linux video de/encoding plugin for libavifile
    Best place to look at changing your sources list is:

    http://www.ubuntu-nl.org/source-o-matic/

    Good luck with the PS3 thing

    Andrew
    You think that's air you're breathing now?

  3. #123
    Join Date
    Oct 2007
    Location
    Bristol, England
    Beans
    40

    Re: [Howto] Successfully install the svn mplayer + gmplayer + all the codecs.

    Linux is supported on PS3 completely officially, endorsed by Sony, no modification needed Just install from CDR. Unfortunately it runs in some kind of hypervisor mode with limited access to the hardware, hence the ps3-modified versions of certain files found in the link I posted. Even then, it only just about manages standard definition files

  4. #124
    Join Date
    Dec 2006
    Beans
    7,299

    Re: [Howto] Successfully install the svn mplayer + gmplayer + all the codecs.

    Hi!

    Wooooooo hoooooooooooooo!!!! 12,000 views!!!!! What about a free Ubuntu T-shirt and a coffee mug????!!!!!

    Andrew
    You think that's air you're breathing now?

  5. #125
    Join Date
    Dec 2006
    Beans
    7,299

    Re: [Howto] Successfully install the svn mplayer + gmplayer + all the codecs.

    Hi,

    If anybody is interested I have rejoined the Ubuntu ranks with a dual boot Slackware / Ubuntu system and high on the agenda is a reworked version of this 'Howto' for Hardy Heron when it comes out.

    I have in mind roughly the same format but differences will be:
    1. Different -dev files of course
    2. Installation of some extra 'skins' + description of skin browser
    3. Addition of checkinstall in the installation
    4. Description of version locking to prevent Repository 'updating'
    5. Anything anybody suggests in the next month or two
    Andrew
    Last edited by andrew.46; January 15th, 2008 at 11:47 AM.
    You think that's air you're breathing now?

  6. #126
    Join Date
    Apr 2006
    Beans
    131

    Re: [Howto] Successfully install the svn mplayer + gmplayer + all the codecs.

    Hey, first thanks for great post.
    I'm just having a little issue since some weeks now installing mplayer 1.0 rc2.

    I just used ./configure --enable-largefiles --enable-gui , make goes fine, but after installing, my side buttons (mouse 6 and 7) wont control volume anymore.
    I tried editing the inputrc file, as advised on mplayer's mailing list but without succes.

    Just wondering if anyone here had the same issue?

    Note: i used svn mplayer.

  7. #127
    Join Date
    Apr 2007
    Beans
    Hidden!

    Re: [Howto] Successfully install the svn mplayer + gmplayer + all the codecs.

    hey

    lately i've been having problems compiling mplayer, after updating from the svn

    Code:
    ./configure --enable-gui --enable-largefiles
    returns:

    Code:
    Detected operating system: Linux
    Detected host architecture: i386
    Checking for cc version ... 4.1.3, ok 
    Checking for host cc ... cc 
    Checking for cross compilation ... yes 
    Checking for CPU vendor ... GenuineIntel (6:15:6) 
    Checking for CPU type ...  Intel(R) Core(TM)2 CPU          6300  @ 1.86GHz 
    Checking for kernel support of mmx ... failed 
    It seems that your kernel does not correctly support mmx.
    To use mmx extensions in MPlayer, you have to upgrade/recompile your kernel!
    Checking for kernel support of mmxext ... failed 
    It seems that your kernel does not correctly support mmxext.
    To use mmxext extensions in MPlayer, you have to upgrade/recompile your kernel!
    Checking for kernel support of sse ... failed 
    It seems that your kernel does not correctly support sse.
    To use sse extensions in MPlayer, you have to upgrade/recompile your kernel!
    Checking for kernel support of sse2 ... failed 
    It seems that your kernel does not correctly support sse2.
    To use sse2 extensions in MPlayer, you have to upgrade/recompile your kernel!
    Checking for kernel support of ssse3 ... failed 
    It seems that your kernel does not correctly support ssse3.
    To use ssse3 extensions in MPlayer, you have to upgrade/recompile your kernel!
    Checking for kernel support of cmov ... failed 
    It seems that your kernel does not correctly support cmov.
    To use cmov extensions in MPlayer, you have to upgrade/recompile your kernel!
    Checking for mtrr support ... yes 
    Checking for GCC & CPU optimization abilities ... CPU optimization disabled. CPU not recognized or your compiler is too old. 
    error 
    Checking for assembler support of -pipe option ... no 
    Checking for compiler support of named assembler arguments ... yes 
    Checking for assembler (as ) ... ok 
    Checking for .align is a power of two ... no 
    Checking for Linux kernel version ... 2.6.22-14-generic, ok 
    Checking for -lposix ... no 
    Checking for -lm ... no 
    Checking for langinfo ... no 
    Checking for language ... using en (man pages: en ) 
    Checking for enable sighandler ... yes 
    Checking for runtime cpudetection ... no 
    Checking for restrict keyword ... none 
    Checking for __builtin_expect ... no 
    Checking for kstat ... no 
    Checking for posix4 ... no 
    Checking for llrint ... no 
    Checking for lrint ... no 
    Checking for lrintf ... no 
    Checking for round ... no 
    Checking for roundf ... no 
    Checking for mkstemp ... no 
    Checking for nanosleep ... no 
    Checking for socklib ... no 
    Checking for inet_pton() ... no (trying inet_aton next)
    Checking for inet_aton() ... no (network support disabled)
    Checking for network ... no 
    Checking for inttypes.h (required) ... no 
    Checking for bitypes.h (inttypes.h predecessor) ... 
    Error: Cannot find header either inttypes.h or bitypes.h. There is no chance for compilation to succeed.
    
    Check "configure.log" if you do not understand why it failed.
    Any ideas as to what causes the problem and how I can fix it?

    PS: I'm using the official kernel packages

  8. #128
    Join Date
    Dec 2006
    Beans
    7,299

    Re: [Howto] Successfully install the svn mplayer + gmplayer + all the codecs.

    Hi,

    Sorry to see that you are having a little trouble:

    Quote Originally Posted by csulok View Post
    hey
    lately i've been having problems compiling mplayer, after updating from the svn
    I will have to admit it does not sound like a specifically svn problem. There are 2 things you could try:

    1. Try to backtrack to the last successful svn version that you used. To do this simply add -R <revision number> to the svn command.
    2. Try to compile the mplayer rc2 instead.
    Mplayer rc2 can be found at:

    http://www3.mplayerhq.hu/MPlayer/rel...1.0rc2.tar.bz2

    All the best,

    Andrew
    You think that's air you're breathing now?

  9. #129
    Join Date
    Aug 2006
    Beans
    382
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: [Howto] Successfully install the svn mplayer + gmplayer + all the codecs.

    In case you have wondered why checking for dvdnav has resulted in no, it is because mplayer now depends on the libdvdnav source maintained by the MPlayer project.

    First remove the old version od libdvdnav:
    Code:
    sudo apt-get remove libdvdnav4
    Then, we will compile and install the newer version, at least until the Ubuntu developers decide to start using the new source files:
    Code:
    svn co svn://svn.mplayerhq.hu/dvdnav/trunk/libdvdnav libdvdnav
    cd libdvdnav
    ./autogen.sh --enable-static --enable-shared --prefix=/usr
    make
    sudo make install
    Then proceed with compiling mplayer-svn.
    For those of you that are using checkinstall to create a deb file of mplayer, you should instead use:
    Code:
    fakeroot debian/rules binary

  10. #130
    Join Date
    Apr 2007
    Beans
    Hidden!

    Re: [Howto] Successfully install the svn mplayer + gmplayer + all the codecs.

    Quote Originally Posted by andrew.46 View Post
    Hi,

    Sorry to see that you are having a little trouble:



    I will have to admit it does not sound like a specifically svn problem. There are 2 things you could try:

    1. Try to backtrack to the last successful svn version that you used. To do this simply add -R <revision number> to the svn command.
    2. Try to compile the mplayer rc2 instead.
    Mplayer rc2 can be found at:

    http://www3.mplayerhq.hu/MPlayer/rel...1.0rc2.tar.bz2

    All the best,

    Andrew
    I can't compile the 1.0rc2 build, I get the exact same messages.
    I can't compile revision 25426 either, exact same message, even though i successfully compiled it on december 16th and i'm using that package right now.

    It has nothing to do with mplayer i'm afraid. there was an ubuntu kernel update during my xmas holiday, that upgraded the kernel from 2.6.22-13 to 2.6.22-14. i suspect this to be the cause (the error messages state something similar too), but i can't downgrade to confirm it :/
    Last edited by csulok; January 19th, 2008 at 07:50 PM.

Page 13 of 48 FirstFirst ... 3111213141523 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •