Results 1 to 9 of 9

Thread: Problems with Guildwars and Wine

  1. #1
    Join Date
    Dec 2006
    Beans
    315
    Distro
    Ubuntu

    Problems with Guildwars and Wine

    Hi,

    I have just installed Guildwars under Wine and all seemed to go ok, I have't had the problem with no mouse, like then I tried to install peviously, but I have encountered a couple other issues, not sure if anyone has any ideas.

    1. The FPS is at 6 (much too slow), I am running Xgl with Compiz, bu I cant think of any reason why this could be the cause of the slow FPS

    2. The Game was in the process of downloading (after logon and selection to play with character), and it suddenly just crashed, or at least the game window vanished

    3. After this happening Guildwars wont startup again (I have run wine Gw.exe -dx8), and if I click on the desktop icon X just restarts

    Can anyone help.


    Thanks,


    Gavin,

  2. #2
    Join Date
    Apr 2006
    Location
    E Sussex, U.K
    Beans
    220
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Problems with Guildwars and Wine

    XGL can mess badly with games presumably because of the resources required. I reckon you should switch back to regular Gnome and see if your fps improves. I seem to get an average of about 15-30 fps which, while not great, is at least playable.

    I run the following arguaments:
    Code:
    -dsound -noshaders -dx8 flags -repair -image
    I don't know if they are all strictly required but it seems to work for me.

    Good luck. And if you get it working join my guild.
    If you had a million Shakespeares, could they write like a monkey?

  3. #3
    Join Date
    Dec 2006
    Beans
    315
    Distro
    Ubuntu

    Re: Problems with Guildwars and Wine

    Thanks,

    That has at least sorted the FPS (or better at any rate 15-20), but now I have another issue

    When GuildWars open everything is ok, but then after a few seconds the mouse pointer vanishes and nothing seems to be able to get it back (I have tried the right click I have heard about).

    In the end I do Alt+F2 xkill on guildwars, and then for some reason if I try to start GuildWars again it hangs on the update screen and the main logon screen never loads again (or not until I reboot anyway)



    Gavin,

  4. #4
    Join Date
    Oct 2005
    Location
    Sweden
    Beans
    1,039
    Distro
    Ubuntu

    Re: Problems with Guildwars and Wine

    You can try ALT + ENTER when the pointer goes, can help, or try looking down in to the ground if in game and klick some more.

    if you can't restart it prolly it's cause you have a ghost, open the system monitor and see if you can find it

  5. #5
    Join Date
    Dec 2006
    Beans
    315
    Distro
    Ubuntu

    Re: Problems with Guildwars and Wine

    Thanks,

    I found a script on this forum, to install Wine and Guildwars, and it seems to have solved most of my problems except I have no sound, any ideas

    The link to the Script is here http://ubuntuforums.org/showthread.p...ight=guildwars

    Thanks,


    Gavin,

  6. #6
    Join Date
    Oct 2005
    Location
    Sweden
    Beans
    1,039
    Distro
    Ubuntu

    Re: Problems with Guildwars and Wine

    Quote Originally Posted by gavinjb View Post
    Thanks,

    I found a script on this forum, to install Wine and Guildwars, and it seems to have solved most of my problems except I have no sound, any ideas

    The link to the Script is here http://ubuntuforums.org/showthread.p...ight=guildwars

    Thanks,


    Gavin,
    http://ubuntuforums.org/showpost.php...&postcount=659

  7. #7
    Join Date
    Dec 2006
    Beans
    315
    Distro
    Ubuntu

    Re: Problems with Guildwars and Wine

    Thanks,

    I have now applied the settings, but when I start GuildWars still no sound on the Intro Screen.

    I have also noticed that when I goto the Options Screen and click on Sound, that the Use 3D Audio Hardware option is greyout, even though in the topic it mentions ticking this.

    Also when I first ran Winecfg and went to Audio the 3 Drivers at the top were all deselected (EsounD Driver, OSS Driver & NAS Driver), I have currently ticket them all.


    Thanks,



    Gavin,

  8. #8
    Join Date
    Oct 2005
    Location
    Sweden
    Beans
    1,039
    Distro
    Ubuntu

    Re: Problems with Guildwars and Wine

    Quote Originally Posted by gavinjb View Post
    Thanks,

    I have now applied the settings, but when I start GuildWars still no sound on the Intro Screen.

    I have also noticed that when I goto the Options Screen and click on Sound, that the Use 3D Audio Hardware option is greyout, even though in the topic it mentions ticking this.

    Also when I first ran Winecfg and went to Audio the 3 Drivers at the top were all deselected (EsounD Driver, OSS Driver & NAS Driver), I have currently ticket them all.


    Thanks,



    Gavin,
    Try just checking the OSS

  9. #9
    Join Date
    Dec 2006
    Beans
    315
    Distro
    Ubuntu

    Re: Problems with Guildwars and Wine

    Thanks,

    But it made no difference, this is strange, if I install wine through the repo, then I get slow FPS but sound, I install through the GuildWars + Wine install script and I get much better FPS (definately playable with ATI Card), but no sound.

    Gavin,

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •