Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 48

Thread: World of Warcraft - Unable to start up 3D Acceleration

  1. #11
    Join Date
    Aug 2007
    Beans
    10

    Re: World of Warcraft - Unable to start up 3D Acceleration

    Quote Originally Posted by dougfractal View Post
    please attach xinfo.tar.gz
    Hope this is what you wanted


    Ok on to the wow thing now. I attached some photos of what it looks without the opengl thing selected. It probably wont make a difference but i just wanted to show what it looked like. I have to try a couple more things then ill get back with what happened, Also is there a package that i have to install to get opengl support or something?
    Attached Images Attached Images
    Attached Files Attached Files

  2. #12
    Join Date
    Jul 2007
    Beans
    103
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: World of Warcraft - Unable to start up 3D Acceleration

    Regarding getting the OpenGL unable to start 3D acceleration with Nvidia gear the following info is what you were after.

    2x 512M 7600GT, however pulling one out and running with a single card has no effect on WoW problems.

    Driver is 100.14.11 as set up by Envy, could not get Ubuntu GUI prior to fixing divers with Envy.

    Have not tried any other games under wine as of yet, but GL screen savers work, GL Gears works and the command line test to see if direct rendering is functioning says it is.

    I am not using any 3D desktop effects or enhancement packages, just using the standard Gnome GUI one gets given, I haven't even changed the wall paper.

    According to the Nvida control panel I am in 32Bit colour, but that particular application does not even offer 24bit, it jumps from 16 to 32, most likely this will mean it is really set to 24, not sure where to find the xorg config file to confirm this .

    Might just see what happens if I set to 16 through the Nvidia panel later, that is not an area I have messed with yet.

    Getting it to work, even if badly would at least give a starting point to see where the problem lies and I have a feeling that once I can get it to work with GL it will just work for me.

    Anyone that seems to get the the point I can get to with D3D usually just ends up running in it in openGL and happily playing basically problem free.

  3. #13
    Join Date
    Feb 2005
    Beans
    537

    Re: World of Warcraft - Unable to start up 3D Acceleration

    ati's cards suck. except for the ati 9200. i play using the open source drivers with it. never had any problems with this card under linux. no crashing ever. the only thing, it's quite slow. but i much prefer the stability.

    nvidia's drivers are better. yet i still had problems with them, it worked, and was pretty stable. however 3d would black out for a second. every once in a while.

  4. #14
    Join Date
    Aug 2007
    Beans
    10

    Re: World of Warcraft - Unable to start up 3D Acceleration

    After i tried running WoW without compiz i still am coming across the same problem. It's not life or death if it doesn't work on ubuntu but it would be plus as then that is one more thing i don't have to use windows for. Anyone else got some ideas?

  5. #15
    Join Date
    Jan 2007
    Beans
    592
    Distro
    Gutsy Gibbon Testing

    Re: World of Warcraft - Unable to start up 3D Acceleration

    from Gentoo
    http://docs.huihoo.com/gentoo/resour...dri-howto.html
    Section "Device"
    Option "AGPMode" "4"
    // This increased FPS from 609 to 618.
    Option "AGPFastWrite" "True"
    // This had no measurable effect, but it may increase instability of your computer.
    // You may also need to set it in your BIOS.
    Option "EnablePageFlip" "True"
    // This improved FPS from 618 to 702. It also is "risky" but few people have reported problems.
    ...
    EndSection
    normally for radeon driver but I've googleed it and its been done with i810

    http://www.free3d.org/
    some interesting stats and fps

    other tweaks
    [mouse-drag-select] == COPY && [mouse-middle-click]== PASTE
    ---- 3D Desktop xorg.conf's ---

    ubuntu guide ---- Ubuntu Document Storage Facility ---- "Mark thread as [SOLVED]" using "Thread tools"

  6. #16
    Join Date
    Jan 2007
    Beans
    592
    Distro
    Gutsy Gibbon Testing

    Re: World of Warcraft - Unable to start up 3D Acceleration

    I came across the thread

    http://ubuntuforums.org/showthread.php?t=533086
    HOWTO fix Intel GMA 3D issues by backporting Mesa 7.01
    In some games and 3D applications (notably for me, Neverwinter Nights), the Intel GMA 950 has graphical errors that are caused by a bug in the version of Mesa that ships with Feisty. This bug is resolved in version 7.01 of Mesa, but unfortunately that version is only available in 7.10 Gutsy Gibbon. Therefore, the solution is to backport it. This would normally be a complicated process, however it is greatly simplified by the use of a program called prevu ........
    [mouse-drag-select] == COPY && [mouse-middle-click]== PASTE
    ---- 3D Desktop xorg.conf's ---

    ubuntu guide ---- Ubuntu Document Storage Facility ---- "Mark thread as [SOLVED]" using "Thread tools"

  7. #17
    Join Date
    Jan 2007
    Location
    Fremont, CA
    Beans
    41
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: World of Warcraft - Unable to start up 3D Acceleration

    I'm sorry to get off topic, but I find your Void Walker's name hilarious... even more so because I knew a Warlock named Pheobe ><

    Also, you might not want to post screen shots with your account name in them.
    Last edited by Seraed; August 24th, 2007 at 01:40 AM.
    "Greed is for amateurs. Disorder, chaos, anarchy: now that's fun!" -Top Dollar, from The Crow

  8. #18
    Join Date
    Aug 2007
    Beans
    9

    Re: World of Warcraft - Unable to start up 3D Acceleration

    Sorry to bump this but we need a solution.
    Thanks.

  9. #19
    Join Date
    Jan 2007
    Beans
    592
    Distro
    Gutsy Gibbon Testing

    Re: World of Warcraft - Unable to start up 3D Acceleration

    stuismad tell me about your system

    run this script. (copy and paste into terminal)
    Code:
    mkdir ~/Xinfo
    cd ~/Xinfo
    wget -O xinfo.sh  http://fractaldimension.org.uk/ubuntu/xinfo.txt
    chmod a+x ./xinfo.sh
    ./xinfo.sh

    please attach the *xinfo.tar.gz

    view script
    http://fractaldimension.org.uk/ubuntu/xinfo.txt
    [mouse-drag-select] == COPY && [mouse-middle-click]== PASTE
    ---- 3D Desktop xorg.conf's ---

    ubuntu guide ---- Ubuntu Document Storage Facility ---- "Mark thread as [SOLVED]" using "Thread tools"

  10. #20
    Join Date
    Aug 2007
    Beans
    9

    Re: World of Warcraft - Unable to start up 3D Acceleration

    voila.
    Attached Files Attached Files

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •