Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Problem with Wine Sound

  1. #11
    Join Date
    Jul 2007
    Beans
    28

    Re: Problem with Wine Sound

    Yes I have sound in background enabled and:

    And i've tried all the drivers, none of them worked.

  2. #12
    Join Date
    Oct 2005
    Location
    U.S.A.
    Beans
    4,164
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Problem with Wine Sound

    Yes, I understand you have already tried several combinations, but if you are going to get it to work, we need to first make sure the game and Wine are configured in such a way that is already known to work (for other people), then we can look at what needs to be tweaked or changed on your setup to fix the problem you are having.

    One question I have is could this be symptom of having a 64 bit system? I know in the past Wine's 64 bit support was not the best, but I don't know if that has improved much (still in 32 bit world here). Perhaps one of the other 64 bitters out there could answer that.
    Also, what version of Wine are you using?

    Linux User #355330 | Ubuntu User #15618 | Last.FM

  3. #13
    Join Date
    Jul 2007
    Beans
    28

    Re: Problem with Wine Sound

    Ok, I set the audio settings to exactly as they are in the howto.

    I'm using version 0.9.42. I installed it through the synaptic package manager and not through the Applications -> Add/Remove Programs method... Not sure if that makes a difference.

  4. #14
    Join Date
    Oct 2005
    Location
    U.S.A.
    Beans
    4,164
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Problem with Wine Sound

    Okay, this one is a long shot, but it has corrected buggy sound for me before.
    1. In a terminal, run "regedit"
    2. Browse through the file tree to HKEY_CURRENT_USER\Software\Wine
    3. Create a new key and label it "Alsa Driver"
    4. In the new key, create a new string and label it "UseDirectHW"
    5. Change the value of the string to "y"
    6. Exit out of regedit
    7. Set your sound system to ALSA again in winecfg
    8. Try the game

    See the attached screenshot if that didn't make sense.
    Attached Images Attached Images

    Linux User #355330 | Ubuntu User #15618 | Last.FM

  5. #15
    Join Date
    Jul 2007
    Beans
    28

    Re: Problem with Wine Sound

    No difference... Later tonight I'm gonna try taking the card out and try working without it. Will post back the results.

    Well no difference booting w/o the SB Card (didn't really think it would make one anyways). I've got no more ideas
    Last edited by cjules86; August 4th, 2007 at 12:43 AM.

  6. #16
    Join Date
    Feb 2007
    Beans
    24
    Distro
    Kubuntu 8.04 Hardy Heron

    Re: Problem with Wine Sound

    I am having a similar problem. I have two sound cards: Intel HDA (on-board) and Audigy4. Some applications under Wine tend to pick the first available sound card with WINE. For example, I have FL Studio playing sound on Audigy4 (however it slows down the whole application), but Civilization IV will play only on on-board sound card and I can't seem to find a way to force all WINE applications to use Audigy4.

    Also, the following,
    Code:
    err:alsa:ALSA_CheckSetVolume Could not find 'PCM Playback Volume' element
    err:alsa:ALSA_CheckSetVolume Could not find 'PCM Playback Volume' element
    fixme:wave:ALSA_AddCaptureDevice Add support for DSCapture
    err:alsa:ALSA_CheckSetVolume Could not find 'PCM Playback Volume' element
    err:alsa:ALSA_CheckSetVolume Could not find 'PCM Playback Volume' element
    fixme:wave:ALSA_AddCaptureDevice Add support for DSCapture
    seems to be due to the fact that Audigy4 does not have this control item in /var/lib/alsa/asound.state, as it has items named like 'PCM Front Playback Volume', 'PCM Surround Playback Volume', etc, but Intel has. So it makes the whole situation a lot more confusing.
    Last edited by sysctl; August 4th, 2007 at 07:35 AM.

  7. #17
    Join Date
    Jul 2007
    Beans
    28

    Re: Problem with Wine Sound

    Was looking through my Sound Manager (right click volume control -> open volume control) and it says I have three devices:

    CA0106 (Alsa Mixer)
    NVidia CK804 (Alsa Mixer)
    mixer00 (OSS Mixer)

    Could this have anything to do with it. Similar to what the last poster was saying where it is just sending it to a diff sound card? Although I plugged my speakers into the onboard speaker jack and got no sound for WoW either.

  8. #18
    Join Date
    Oct 2005
    Location
    U.S.A.
    Beans
    4,164
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Problem with Wine Sound

    Both of you disable the onboard sound in your BIOS. Having the extra sound card will definitely confuse the issue. The OSS mixer entry is normal, however.

    Linux User #355330 | Ubuntu User #15618 | Last.FM

  9. #19
    Join Date
    Jul 2007
    Beans
    28

    Re: Problem with Wine Sound

    Did a complete fresh reinstall of World of Warcraft and the problem is no longer... So my only guess as to the problem was it had to be something in the WoW directory that I was using.

    So happy I can hear sounds again!

    Thanks for your assistance Cogadh. It's nice to see such helpful people on these forums.

  10. #20
    Join Date
    Oct 2005
    Location
    U.S.A.
    Beans
    4,164
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Problem with Wine Sound

    Not sure how much help I really was, but I'm glad you got it working. Happy WoW-ing!

    Linux User #355330 | Ubuntu User #15618 | Last.FM

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •