Results 1 to 6 of 6

Thread: Vmware Server Clock Synchronisation (ubuntu host & guest)

  1. #1
    Join Date
    Jul 2007
    Beans
    6

    Vmware Server Clock Synchronisation (ubuntu host & guest)

    Hello, i've installed VmwareServer under a ubuntu host :

    C2D E4200 + 1Gig memory

    then I've installed ubuntu server 7.04 as guest.

    I've a big clock drift ( about 10 minutes per hour faster than the host clock ).

    I've set tools.syncTime = "TRUE" in the vmx file,
    I've installed vmware tools in the guest and it's running !

    Code:
    root      3770  0.1  0.2   2040   656 ?        Ss   10:20   0:02 /usr/sbin/vmware-guestd --background /var/run/vmware-guestd.pid
    Code:
    $ sudo ntpdate ntp.ubuntu.com
     2 Aug 10:35:09 ntpdate[3960]: step time server 82.211.81.145 offset -673.188035 sec
    and 1 minute later :
    Code:
    $ sudo ntpdate ntp.ubuntu.com
     2 Aug 10:35:34 ntpdate[3961]: step time server 82.211.81.145 offset -8.511885 sec
    ... ok i've added the following lines to grub :
    append="clock=pit nosmp noapic nolapic"

    and the clock always drift

    somebody have an idea ?

  2. #2
    Join Date
    Jun 2006
    Location
    Ohio
    Beans
    2,370
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Vmware Server Clock Synchronisation (ubuntu host & guest)

    so you have a dual core HOST, are your VMs set up as single core or using both? ... i have a similar issue myself and even tho it's kinda working itself out (the longer the host is up, then i reboot the VMs - the better the time is) i used to have a cron job that would set the system time based off the hwclock (which was generally correct) ...

    and my VMs were essentially ignoring the "syncTime" setting ...

    i have a dual core AMD as the HOST and single core VMs ... if i use both CPUs for the VMs, networking doesn't work - odd!
    (Ubuntu 7.10) PC#1 SPECS / (Ubuntu 7.10) PC#2 SPECS / (Vista HomePremium | Arch Linux 2007.08-2) Gateway 6841
    VMs: Server 2k3, CentOS5 in Xen [mysql/apache/named], CentOS5 [zimbra server]

  3. #3
    Join Date
    Apr 2006
    Beans
    9

    Re: Vmware Server Clock Synchronisation (ubuntu host & guest)

    would you mind sharing the cron script you used to sync the system time to the hwclock?

    thanks

  4. #4
    Join Date
    Feb 2005
    Location
    Melbourne, Australia
    Beans
    13,505
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Vmware Server Clock Synchronisation (ubuntu host & guest)

    Quote Originally Posted by feeling367 View Post
    Hello, i've installed VmwareServer under a ubuntu host :

    C2D E4200 + 1Gig memory

    then I've installed ubuntu server 7.04 as guest.

    I've a big clock drift ( about 10 minutes per hour faster than the host clock ).
    ........
    somebody have an idea ?
    Is this any help (it seems to work for me)?:

    http://blog.autoedification.com/2006...runs-fast.html
    Regards, David.
    Please use the Forum search and Wiki search for immediate help
    Please mark your thread as Solved when appropriate
    New to technical forums?: How To Ask Questions The Smart Way

  5. #5
    Join Date
    Jun 2006
    Location
    Ohio
    Beans
    2,370
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Vmware Server Clock Synchronisation (ubuntu host & guest)

    Quote Originally Posted by midspot View Post
    would you mind sharing the cron script you used to sync the system time to the hwclock?

    thanks
    for me, the clock drift ended up being the result of AMD's CnQ / frequency scaling -- so i turned that off and my clocks have been fine ever since ...
    (Ubuntu 7.10) PC#1 SPECS / (Ubuntu 7.10) PC#2 SPECS / (Vista HomePremium | Arch Linux 2007.08-2) Gateway 6841
    VMs: Server 2k3, CentOS5 in Xen [mysql/apache/named], CentOS5 [zimbra server]

  6. #6
    Join Date
    Aug 2006
    Location
    Jakarta, Indonesia
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Vmware Server Clock Synchronisation (ubuntu host & guest)

    Quote Originally Posted by scxtt View Post
    for me, the clock drift ended up being the result of AMD's CnQ / frequency scaling -- so i turned that off and my clocks have been fine ever since ...
    Nice hint, thanks.

    A bit more info on this; to find out your CPU's current speed settings, type cpufreq-info

    If it's not installed, type aptitude install cpufrequtils

    You can set the CPU's speed setting as well. An example :

    cpufreq-set -c 1 -g performance

    This will set "max performance" for the second CPU core.

    Hope it helps.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •