Hi,

This is my first post in the forum. I had problems configuring Evolution to use hotmail but finally got it working. Several threads in different sites pointed to solutions that didn't work for my current configuration:
  • Ubuntu Intrepid Ibex (8.10)
  • Evolution 2.24
  • xinetd (eXtended InterNET Daemon) instead of inetd


Here are the steps I followed:

1- Using Synaptic install hotway and hotsmtp (you can find both of them by typing hotmail in the Quick Search Box).

2- Open a terminal and type:

sudo gedit /etc/xinetd.d/hotwayd

in the new window that opens type (or copy & paste) this:


service hotwayd
{
disable = no
type = unlisted
socket_type = stream
protocol = tcp
wait = no
user = nobody
groups = yes
server = /usr/bin/hotwayd
server_args = -r
port = 110
}


save the file and close gedit

3- You should be back to the terminal you opened in step 2. Now type:

sudo gedit /etc/xinetd.d/hotsmtpd

in the new window that opens copy this:

service hotsmtpd
{
disable = no
type = unlisted
socket_type = stream
protocol = tcp
wait = no
user = nobody
groups = yes
server = /usr/bin/hotsmtpd
#server_args = -r
port = 25
}


save the file and close gedit.

4 - You're back at the same Terminal window. Type:

sudo gedit /etc/hosts

this command will open a file which content should be similar to this one:

127.0.0.1 localhost
127.0.1.1 Lobo

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts


in this file you need to add the following two lines:

hotwayd: 127.0.0.1
hotsmtpd: 127.0.0.1


So the new content of the hosts file will be:


127.0.0.1 localhost
127.0.1.1 Lobo
hotwayd: 127.0.0.1
hotsmtpd: 127.0.0.1

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts


save the file and close gedit.

5 - You're back at the Terminal window. Now we need to restart xinetd, so type:

sudo /etc/init.d/xinetd restart

the output you'll get should be:

* Stopping internet superserver xinetd [ OK ]
* Starting internet superserver xinetd [ OK ]


6 - We're going to try the previous configuration works by typing in the Terminal window:

sudo telnet localhost 25


the output you'll get should be similar to:

Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 Lobo SMTP hotsmtpd v0.8.4. ESMTP-HTTPMail Gateway based on hotwayd.


now type:

quit

and hit the Enter key.

you'll get the following output:

221 Service closing transmission channel
Connection closed by foreign host.


7 - We are going to repeat step 6 for port 110, so type in the Terminal window:

sudo telnet localhost 110


the output you'll get should be similar to:
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
+OK POP3 hotwayd v0.8.4 -> The POP3-HTTPMail Gateway. Server on Lobo active.


now type:

quit

and hit the Enter key.

you'll get the following output:

+OK see you later!
Connection closed by foreign host.


8 - It's time to configure Evolution now. Open Evolution and go to Edit -> Preferences. In the Preferences window you will be looking at the Mail Accounts. Click on Add. You'll be in the Identity tab. Fill in the information in that tab.

Now go to Receiving Email. There you need put the following info:

Server Type: POP
Server: 127.0.0.1:110
Username: (full hotmail address, including @hotmail.com)
Use Secure Connection: No Encryption
Authentication Type: Password

Check Remember Password if you want.

Now go to Sending Email. There you need to put the following info:


Server Type: SMTP
Server: 127.0.0.1:25
Check Server Requires authentication
Use Secure Connection: No Encryption
Authentication Type: Plain
Username: (full hotmail address, including @hotmail.com)
Check Remember Password if you want.

Click OK



We are done! You should be able to send and receive e-mail through Hotmail now!
Enjoy!