Page 3 of 9 FirstFirst 12345 ... LastLast
Results 21 to 30 of 89

Thread: Internet Connection Sharing Documentation

  1. #21
    Join Date
    May 2007
    Location
    Portland, OR, USA
    Beans
    50
    Distro
    Kubuntu 8.04 Hardy Heron

    Re: Internet Connection Sharing Documentation

    I seem to be having a similar problem to kazbear. I followed the wiki and can ssh between the two computers but can't connect to the internet from the second one. kazbear, can you post what you did to fix it?

    My laptop is connected to a wireless network. I'm trying to share the connection with my desktop through ethernet. I've tried using both static IPs and dhcp, with similar results. ssh works but the internet doesn't. The only difference is that with static IPs, when I ping google from the desktop it says it couldn't resolve the name and when I ping google's IP it says it's unreachable. However, with dhcp the pings don't print errors, they just timeout. Any ideas?

    thanks

  2. #22
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Internet Connection Sharing Documentation

    Are you sure you configured the dns servers on the desktop, as described under "Client set up"?

  3. #23
    Join Date
    May 2007
    Location
    Portland, OR, USA
    Beans
    50
    Distro
    Kubuntu 8.04 Hardy Heron

    Re: Internet Connection Sharing Documentation

    Are you sure you configured the dns servers on the desktop, as described under "Client set up"?
    Fairly sure, unless I missed something. See below.

    Actually, one thing important that I just now noticed: the ping on the desktop is actually able to resolve google's IP, it just can't transfer any data.

    Code:
    tcarls@desktop$ grep prepend /etc/dhcp3/dhclient.conf
    #prepend domain-name-servers 127.0.0.1;
    prepend domain-name-servers 208.67.222.222,208.67.220.200;
    
    tcarls@desktop$ cat /etc/resolv.conf
    search example.org
    nameserver 208.67.222.222
    nameserver 208.67.220.220
    nameserver 208.67.216.132
    nameserver 208.67.216.132
    Below is the output of a few more commands that may be useful. Note: I changed the subnet from 192.168.0 to 192.168.2 so it wouldn't conflict with the wireless subnet.

    Code:
    tcarls@desktop$ route
    Kernel IP routing table
    Destination    Gateway    Genmask          Flags Metric Ref    Use Iface
    192.168.2.0    *          255.255.255.0    U     0      0        0 eth0
    default        laptop     0.0.0.0          UG    0      0        0 eth0
    
    
    tcarls@desktop$ ifconfig eth0 | grep 'inet addr'
        inet addr:192.168.2.20 Bcast:192.168.2.20  Bcast:192.168.2.255  Mask:255.255.255.0
    
    tcarls@desktop$ ping 192.168.2.1
    PING 192.168.2.1 (192.168.2.1) 56(84) bytes of data.
    64 bytes from 192.168.2.1: icmp_seq=1 ttl=64 time=0.000 ms
    ^C
    
    --- 192.168.2.1 ping statistics ---
    1 packets transmitted, 1 received, 0% packet loss, time 0ms
    rtt min/avg/max/mdev = 0.000/0.000/0.000/0.000 ms
    
    tcarls@desktop$ ping www.google.com
    PING www.l.google.com (209.85.173.147) 56(84) bytes of data.
    ^C
    
    --- www.l.google.com ping statistics ---
    60 packets transmitted, 0 received, 100% packet loss, time 59007ms
    Code:
    tcarls@laptop$ ifconfig eth0 | grep 'inet addr'
              inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
    
    tcarls@laptop$ ifconfig wlan0 | grep 'inet addr'
              inet addr:192.168.0.104  Bcast:192.168.0.255  Mask:255.255.255.0
    
    tcarls@laptop$ cat /proc/sys/net/ipv4/ip_forward
    1
    
    # I'm using Hardy. The wiki said there's a bug in Gutsy and
    # a couple lines need to be added. I wasn't sure if it still
    # applied to Hardy to I tried with and without them.
    tcarls@laptop$ grep forward /etc/sysctl.conf
    # Uncomment the next line to enable packet forwarding for IPv4
    net.ipv4.ip_forward=1
    # Uncomment the next line to enable packet forwarding for IPv6
    net.ipv6.ip_forward=1
    #net.ipv4.conf.default.forwarding=1
    #net.ipv4.conf.all.forwarding=1

  4. #24
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Internet Connection Sharing Documentation

    Okay, I've tested this on a few systems so it may also work for you.

    Let's try dumping your current firewall configuration with the following command:
    Code:
    sudo iptables -F
    Make sure there are no remaining iptables rules in place:
    Code:
    $ sudo iptables -L
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    Then try this firewall argument:
    Code:
    sudo iptables -t nat -A POSTROUTING -o wlan0 -j MASQUERADE

  5. #25
    Join Date
    Dec 2006
    Beans
    56

    Re: Internet Connection Sharing Documentation

    >Open /etc/resolve.conf with your favorite text editor:
    >sudo nano /etc/dhcp3/dhclient.conf

    seems to me there is an error here because /etc/dhcp3/dhclient.conf != /etc/resolve.conf


    also it did not work for me

  6. #26
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Internet Connection Sharing Documentation

    Quote Originally Posted by Dmole View Post
    >Open /etc/resolve.conf with your favorite text editor:
    >sudo nano /etc/dhcp3/dhclient.conf

    seems to me there is an error here because /etc/dhcp3/dhclient.conf != /etc/resolve.conf


    also it did not work for me
    Thank you for pointing this out. I've updated the wiki.

    You may have to restart your networking (or reboot) before these settings will take effect.

  7. #27
    Join Date
    Mar 2008
    Beans
    122
    Distro
    Ubuntu 11.04 Natty Narwhal

    Unhappy Re: Internet Connection Sharing Documentation

    The wiki says

    Unless your ICS gateway can also perform DNS, you must manually configure the client with your ISP DNS servers. If you do not know your ISP's DNS servers, you can use OpenDNS servers instead.
    all three of these options fail.
    • Option 1: "Perform DNS." The link is to the Wikipedia entry on DNS. Not very helpful, I still have no idea whether or not my computer can do this or how to set it up. So I give up and move on.
    • Option 2: "ISP DNS servers." What are those??!! How do I find out what my ISP DNS servers are? I searched the internet to no avail.
    • Option 3: "use OpenDNS." The link to a very helpful step-by-step is great, however, I get stuck on step 3, as no connection shows up. In fact, Network Manager has a little X by it like I have no connection (though I do now have a connection, having gone through the ICS steps). Actually, the client computer is Ubuntu Studio, and it didn't even have Network Manager installed by default, so I had to install it and reboot (which deleted my connection and I had to do it all over again.)

    So I definitely think the Wiki should be updated in this part, with more info on how people can pursue these different options.

    ----
    PS: Please help me if you know the answers to these questions! I just want to have internet on my second computer! Thanks.
    Last edited by brnetonboy; March 3rd, 2009 at 08:29 AM.
    multiple cursors is here: http://alec.mooo.com/mpx.html

  8. #28
    Join Date
    Mar 2008
    Beans
    122
    Distro
    Ubuntu 11.04 Natty Narwhal

    Angry Re: Internet Connection Sharing Documentation

    Quote Originally Posted by brnetonboy View Post
    Option 3: "use OpenDNS." The link to a very helpful step-by-step is great, however, I get stuck on step 3, as no connection shows up. In fact, Network Manager has a little X by it like I have no connection (though I do now have a connection, having gone through the ICS steps). Actually, the client computer is Ubuntu Studio, and it didn't even have Network Manager installed by default, so I had to install it and reboot (which deleted my connection and I had to do it all over again.)
    I just had a thought... is it possible that the wiki wants me to configure OpenDNS on the Gateway, as opposed to the Client? The wiki does not specify. Which is it? I can easily follow the directions to install it on the Gateway computer. Please help! Then update the wiki to be more clear on this point.
    multiple cursors is here: http://alec.mooo.com/mpx.html

  9. #29
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Internet Connection Sharing Documentation

    Quote Originally Posted by brnetonboy View Post
    I just had a thought... is it possible that the wiki wants me to configure OpenDNS on the Gateway, as opposed to the Client? The wiki does not specify. Which is it? I can easily follow the directions to install it on the Gateway computer. Please help! Then update the wiki to be more clear on this point.
    Nope, you'll have to configure OpenDNS on the client. It's under the client configuration settings so I thought it was clear enough. I'll take another look in a bit.

    Your gateway AND client are both Ubuntu?

    Edit: took another look at the wiki. This is what's currently written, and what you quoted earlier ->

    Unless your ICS gateway can also perform DNS, you must manually configure the client with your ISP DNS servers. If you do not know your ISP's DNS servers, you can use OpenDNS servers instead.
    Is there something about the wording that made you confused?
    Last edited by dmizer; March 3rd, 2009 at 08:55 AM.

  10. #30
    Join Date
    Mar 2008
    Beans
    122
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Internet Connection Sharing Documentation

    Quote Originally Posted by dmizer View Post
    Nope, you'll have to configure OpenDNS on the client. It's under the client configuration settings so I thought it was clear enough. I'll take another look in a bit.

    Your gateway AND client are both Ubuntu?
    You are probably right that it is clear enough but since I'm running into hurdles I started second guessing everything and thinking I must be doing something wrong.

    Yes, both are Ubuntu. Gateway is Ibex 8.10, Client is Ubuntu Studio (8.10 as well).
    multiple cursors is here: http://alec.mooo.com/mpx.html

Page 3 of 9 FirstFirst 12345 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •