Page 1 of 4 123 ... LastLast
Results 1 to 10 of 41

Thread: Ralink RT73 USB Wireless Drivers in Feisty Fawn (7.04)

Hybrid View

  1. #1
    Join Date
    Oct 2006
    Beans
    59
    Distro
    Ubuntu 7.04 Feisty Fawn

    Ralink RT73 USB Wireless Drivers in Feisty Fawn (7.04)

    This guide uses p_larbigs's drivers instead of the serialmonkey drivers because p_larbigs's are based off of the serialmonkey drivers, but have been already patched for Fragmentation Attacks and Injection, so you can utilize more features in Aircrack.

    The wireless card I tested this on is an Alfa AWUS036S, the system I tested this on is a clean install of Ubuntu Feisty Fawn 7.04 with all updates as of 7/4/07.

    Remove the old drivers

    Code:
    cd /lib/modules/2.6.20-16-generic/kernel/ubuntu/wireless/
    sudo rm -r rt2x00
    sudo rm -r rt2x00-legacy/
    Get the new drivers and install them
    Download http://homepages.tu-darmstadt.de/~p_larbig/wlan/rt73-k2wrlz-1.1.0.tar.bz2 and extract it to your desktop.
    Code:
    cd Desktop/rt73-k2wrlz-1.1.0/Module/
    sudo make
    sudo strip -S rt73.ko
        (before 2.7MB after 242k)
    sudo make install
    Bring the device up
    Code:
    sudo ifconfig rausb0 up
    The RT73 drivers do not support the network manager, so you need to remove it and install RutilT, which I like better anyways.

    Download and install RutilT
    Download http://cbbk.free.fr/bonrom/?download=RutilTv0.15.tar.gz and extract it to your desktop.
    Code:
    sudo apt-get install libgtk2.0-dev g++
    cd Desktop/RutilTv0.15/
    ./configure.sh --launcher=external
    sudo make
    sudo make install

    Remove network-manager
    Code:
    sudo apt-get remove network-manager
    If you want rausb0 brought up when you start ubuntu

    Code:
    sudo gedit /etc/network/interfaces
         auto rausb0
         iface rausb0 inet dhcp
    If you want RutilT to start with Ubuntu

    System>Preferences>Sessions>New>
    Name:rutilt, Command:rutilt

    If you don't want to see RutilT window every time Ubuntu starts up, inside RutilT check the box next to "Start hidden in tray".

    *Just a note, you click on tray icon to show/hide the RutilT window.

    Getting Kismet Configured
    Code:
    sudo gedit /etc/kismet/kismet.conf
         #suiduser=(your user name)
         source=rt2500,rausb0,RT73
    Last edited by webcrawler42; October 3rd, 2007 at 05:01 AM.

  2. #2
    Join Date
    Jan 2007
    Beans
    689
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ralink RT73 USB Wireless Drivers in Feisty Fawn (7.04)

    This almost worked for me. The driver is detected and the wireless works... for a short while. I started downloading my Ubuntu updates (from a new install) and the wireless suddenly stopped working altogether. Even during normal browsing, the wireless abruptly ceases to function. Do you know what might cause this to happen? ifconfig shows that all packets are being dropped after a certain point and using any program to attempt to reconnect to the wireless network fails.

  3. #3
    Join Date
    Oct 2006
    Beans
    59
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Ralink RT73 USB Wireless Drivers in Feisty Fawn (7.04)

    Are you using Network-Manager or RutilT?

  4. #4
    Join Date
    Jan 2007
    Beans
    689
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ralink RT73 USB Wireless Drivers in Feisty Fawn (7.04)

    I fixed it. It had something to do with the ehci_hcd module; I simply removed it.

    I was using RutilT and Edgy. RutilT is pretty cool; I like it better than any other WiFi program I've seen. Thanks for the help!

  5. #5
    Join Date
    Oct 2006
    Beans
    59
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Ralink RT73 USB Wireless Drivers in Feisty Fawn (7.04)

    No problem, glad I could help.

  6. #6
    Join Date
    May 2005
    Beans
    41
    Distro
    Edubuntu 7.04 Feisty Fawn

    Re: Ralink RT73 USB Wireless Drivers in Feisty Fawn (7.04)

    thanks for the tutorial!

    I had the serial monkey drivers install previously followed the instructions to remove them and install the new ones and they work great, except when doing an arp inject i get:

    Read 5842 packets (got 0 ARP requests), sent 0 packets...(0 pps)

    so it seems injection still isnt working

    any suggestions?
    To most hackers crippling Microsoft is the geek equivalent of taking down the Death Star

  7. #7
    Join Date
    Oct 2006
    Beans
    59
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Ralink RT73 USB Wireless Drivers in Feisty Fawn (7.04)

    Are you fakeauth with the network? and are you sure that a arp request has been captured?(pretty sure its needed before you start injecting)

  8. #8
    Join Date
    Aug 2005
    Beans
    20

    Re: Ralink RT73 USB Wireless Drivers in Feisty Fawn (7.04)

    I'll get an "rausb0: ERROR while getting interface flags: No such device" when trying to bring rausb0 up What to do ? One another thing, what is that Kismet thing? Can't configure it anyways...

  9. #9
    Join Date
    Nov 2005
    Location
    Bordeaux, France
    Beans
    11,297
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ralink RT73 USB Wireless Drivers in Feisty Fawn (7.04)

    Are you sure your interface is called rausb0 ? What does sudo iwconfig tell you ?
    「明後日の夕方には帰ってるからね。」


  10. #10
    Join Date
    Oct 2007
    Location
    Edinburgh
    Beans
    24
    Distro
    Ubuntu

    Re: Ralink RT73 USB Wireless Drivers in Feisty Fawn (7.04)

    Hi,
    thanks for the guide, I've been messing around for ages trying to get my Sitecom WL-113 usb wifi working. I tried for ages but couldn't get the DHCP to give me an IP address even though iwconfig reported the correct mac address of the router I was trying to connect to.

    Anyway, following your guide worked wonders and now everything seems to be working but I still have one question. I put the command "rutilt -tp MY_ROUTER" in the startup programs list (System->Preferences->sessions) to bring up the connection automatically, but when I log on and the command is executed I have to put in my root/sudo/admin (whatever its called) password. Is there a way of making it not ask me for my password every time I log on?

    Thanks again, great guide, although it may be worth pointing out that once I removed network-manager I couldn't go online to download RutilT without manually bringing up the wired connection again. It may be better download RutilT before removing network-manager

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •