Page 71 of 71 FirstFirst ... 2161697071
Results 701 to 702 of 702

Thread: HOWTO: Lexmark Printers

  1. #701
    Join Date
    Feb 2011
    Beans
    23
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Lexmark Printers

    Just an update to my previous thread:

    the link I provided to get the libstdc++5 library is now broken. But you can download it from one of the mirrors listed at

    http://packages.debian.org/squeeze/i...dc++5/download

  2. #702
    Join Date
    Dec 2012
    Beans
    1

    Re: HOWTO: Lexmark Printers

    Quote Originally Posted by Geezanansa View Post
    All credit to and thank you to black hole sun for starting this thread and sharing how to get lexmark printers working in ubuntu.

    Just adding update for what worked to get my old lexmark x1270 working in ubuntu 12.04.

    Referring to https://help.ubuntu.com/community/UsingTheTerminal was very handy for getting to grips of what and how to do simple tasks using Terminal.


    Download and save the driver cjlz600le-cups-1.0-1.tar.gz (which Lexmark calls "Driver for RedHat Linux 9.0") from http://support.lexmark.com using your favorite browser.

    From terminal install alien and libstdc++5 which are z600cups dependencies
    Code:
    sudo apt-get install alien
    Code:
    sudo apt-get install libstdc++5
    To unzip and install driver-give these commands from terminal
    Code:
    $mkdir Lexmark
    $cd Downloads #or location of file downloaded from Lexmark website.
    $mv CJLZ600LE-CUPS-1.0-1.TAR.gz ~/Lexmark
    $cd Lexmark
    $ tar -xvzf CJLZ600LE-CUPS-1.0-1.TAR.gz # extract the driver. 
    $ tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz # the sh script is broken for newer systems. use `tail` to extract the binary portion of the script. 
    $ tar -xvzf install.tar.gz # extract the contents produced by tail 
    $ sudo alien --scripts -t z600cups-1.0-1.i386.rpm # convert unusable rpm packages to tgz. 
    $ sudo alien --scripts -t z600llpddk-2.0-1.i386.rpm # convert unusable rpm packages to tgz. 
    $ sudo tar xvzf  z600llpddk-2.0.tgz -C / # extract the tgz's to / putting the files in their right place 
    $ sudo tar xvzf z600cups-1.0.tgz -C / # extract the tgz's to / putting the files in their right place 
    $ sudo ldconfig # DO NOT SKIP THIS STEP or your printer backend won't find required libraries 
    $ cd /usr/share/cups/model 
    $ sudo gunzip Lexmark-Z600-lxz600cj-cups.ppd.gz # unzip the ppd, which should _not_ be gzipped
    $ exit
    Then connect printer and switch on and go to settings button at top right of unity desktop click and select printers.
    Click Add
    Select device from list and click forward
    Leaving "Select printer from database" selected choose "Lexmark" and then click forward
    Select Z600 v1.0-1 driver
    Rename device and description to your liking and apply.

    Reboot


    Go printing.
    I tried your how-to for my Lexmark X1150 on Ubuntu 12.04. The installation went fine, the printer was detected correctly. However, it don't print anything. I'm at a loss what to do... Any suggestions? Thanks in advance.

Page 71 of 71 FirstFirst ... 2161697071

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •