Page 58 of 71 FirstFirst ... 848565758596068 ... LastLast
Results 571 to 580 of 702

Thread: HOWTO: Lexmark Printers

  1. #571
    Join Date
    Jun 2007
    Location
    Nottingham, UK
    Beans
    1,659
    Distro
    Ubuntu

    Re: HOWTO: Lexmark Printers

    When I get home I will write a script to do this automatically.
    Rather than manually choosing a PPD, is there a way to get the Z600 driver included in the list of Lexmark printers?
    This would probably make it easier.
    email: me@rory.sh
    IRC: ​blazemore@freenode

  2. #572
    Join Date
    Jan 2006
    Location
    Tampa FL
    Beans
    93

    Re: HOWTO: Lexmark Printers

    Quote Originally Posted by blazemore View Post
    When I get home I will write a script to do this automatically.
    Rather than manually choosing a PPD, is there a way to get the Z600 driver included in the list of Lexmark printers?
    This would probably make it easier.
    I believe this step does add the PPD to the database.
    I was able to select Lexmark/Z600 and assume these steps
    made that happen (AKA B-2)

    Code:
    cd ~/Desktop/lexmark
    Now, enter the following commands.

    Code:
    sudo -s
    alien -t z600cups-1.0-1.i386.rpm
    alien -t z600llpddk-2.0-1.i386.rpm
    tar xvzf z600llpddk-2.0.tgz -C /
    tar xvzf z600cups-1.0.tgz -C /
    ldconfig
    cd /usr/share/cups/model
    gunzip Lexmark-Z600-lxz600cj-cups.ppd.gz
    exit
    Step B-3. Restart CUPS and check the driver backend

    Restart CUPS:
    Code:
    sudo /etc/init.d/cups restart
    Tom

  3. #573
    Join Date
    Jun 2007
    Location
    Nottingham, UK
    Beans
    1,659
    Distro
    Ubuntu

    Re: HOWTO: Lexmark Printers

    Oh right, OK.
    I just assumed it wouldn't be, as the guide says to manually browse to the PPD.
    Thanks.
    email: me@rory.sh
    IRC: ​blazemore@freenode

  4. #574
    Join Date
    Oct 2009
    Beans
    88

    Re: HOWTO: Lexmark Printers

    w2vy, are you saying your printer works even though you get no output if you run ./z600 from /usr/lib/cups/backend, or could you clarify what you mean by it gives no output but the driver works?

    By the way, has anyone gotten any errors when they enter
    Code:
    sudo /etc/init.d/cups restart
    to restart CUPS? It worked for me but I've seen different ways of restarting CUPS so I wonder if it's different for certain systems.. anyone know?
    Last edited by ShadowMage; November 23rd, 2009 at 06:24 PM.

  5. #575
    Join Date
    May 2008
    Location
    Edinburgh, UK
    Beans
    187
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Lexmark Printers

    Woohoo it's working!!! Thanks ShadowMage.

    I had in fact done the chown/chgrp commands you pointed me to, but did them again and the printer is now functioning as well as it ever has under linux. Great stuff, thanks!

  6. #576
    Join Date
    May 2009
    Beans
    25

    Re: HOWTO: Lexmark Printers

    ok i am getting an error when trying to check the file ./z600, although i may have errors before, when i execute

    Code:
    root@kopasakis-desktop:/usr/share/cups/model# sudo -s
    root@kopasakis-desktop:/usr/share/cups/model# alien -t z600cups-1.0-1.i386.rpm
    File "z600cups-1.0-1.i386.rpm" not found.
    root@kopasakis-desktop:/usr/share/cups/model# alien -t z600llpddk-2.0-1.i386.rpmFile "z600llpddk-2.0-1.i386.rpm" not found.
    root@kopasakis-desktop:/usr/share/cups/model# tar xvzf z600llpddk-2.0.tgz -C /
    tar: z600llpddk-2.0.tgz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Exiting with failure status due to previous errors
    root@kopasakis-desktop:/usr/share/cups/model# tar xvzf z600cups-1.0.tgz -C /
    tar: z600cups-1.0.tgz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Exiting with failure status due to previous errors
    root@kopasakis-desktop:/usr/share/cups/model# ldconfig
    root@kopasakis-desktop:/usr/share/cups/model# cd /usr/share/cups/model
    root@kopasakis-desktop:/usr/share/cups/model# gunzip Lexmark-Z600-lxz600cj-cups.ppd.gz
    gzip: Lexmark-Z600-lxz600cj-cups.ppd already exists; do you wish to overwrite (y or n)? y
        not overwritten
    root@kopasakis-desktop:/usr/share/cups/model# exit
    exit
    root@kopasakis-desktop:/usr/share/cups/model#
    i don't know if this is right or not but i decided to continue
    i can restart cups fine but then when i check the backend i get an error
    Code:
    ./z600: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory
    so i go ahead and insert
    Code:
    "usbfs         /proc/bus/usb usbfs   devgid=14,devmode=0660 0 0"
    in fstb

    so then i insert and then get

    Code:
    sudo mount usbfs
    mount: usbfs already mounted or /proc/bus/usb busy
    mount: according to mtab, usbfs is already mounted on /proc/bus/usb
    and then i get no such file directory again

    when i open the folder that is mentioned in the code /usr/lib/cups/backend i see an executable titled z600 that opens with wine

    so when i go through to add the printer i get everything to go through like normal i find the pdd file and the printer is added but when i go to print nothing comes out and i get an error message saying to fix the printer

  7. #577
    Join Date
    Nov 2009
    Beans
    5
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Lexmark Printers

    At last, after several days and wearily reading every post in this thread, my X1180 is working perfectly on 9.04. Many thanks to all concerned. You guys are all so patient, even when people are going back to Windows or posting shouty threads. I find it both thrilling and humbling to have joined such a community. It also taught me more about using command line than any book could have, and has given me confidence to go ahead and sort out other stuff. Here's one who's never going back! Thanks again.

    Just noticed I'm registered under Karmic. I went back to 9.04 because I couldn't sort other problems, but I'll have another go NOW!
    Last edited by yourlonglostpal; November 27th, 2009 at 10:24 PM. Reason: Extra info

  8. #578
    Join Date
    Nov 2009
    Beans
    5
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Lexmark Printers

    Quote Originally Posted by ShadowMage View Post
    w2vy, are you saying your printer works even though you get no output if you run ./z600 from /usr/lib/cups/backend, or could you clarify what you mean by it gives no output but the driver works?

    By the way, has anyone gotten any errors when they enter
    Code:
    sudo /etc/init.d/cups restart
    to restart CUPS? It worked for me but I've seen different ways of restarting CUPS so I wonder if it's different for certain systems.. anyone know?
    ShadowMage, I got no output when I entered ./z600 from /usr/lib/cups/backend but I thought what the hell and went on with the other steps, and the printer worked perfectly. Hope this is of help.
    Al.

  9. #579
    Join Date
    Oct 2009
    Beans
    88

    Re: HOWTO: Lexmark Printers

    @tiggsy: No problem, I'm glad to hear it's working now

    @yourlonglostpal: I'm glad to hear your printer is working as well Thanks for the note about the output.

    @Kopasakis:
    It looks like the problem might be here.
    Quote Originally Posted by Kopasakis View Post
    i can restart cups fine but then when i check the backend i get an error
    Code:
    ./z600: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory
    Did you install libstdc++5? Are you using a 64-bit system or a 32-bit system? The Z600 driver needs the 32-bit version of libstdc++5. So if you're using a 64-bit system, you need to install both versions of libstdc++5 (32-bit and 64-bit). Or if you're using a 32-bit system, you need to install just the 32-bit version of libstdc++5. Hope this helps.
    Last edited by ShadowMage; December 1st, 2009 at 11:53 PM. Reason: typo

  10. #580
    Join Date
    Jun 2008
    Beans
    25

    Re: HOWTO: Lexmark Printers

    hy guys.
    I'm another victim of 9.10. Before with 9.04 I had a splendid lexmark z645 running and printing.

    Now all broken, no printing at all. I tried to make it working with your guides. But till now nothing running.

    ./z600 gives no output.

    Before trying to add usbfs to /etc/fstab when installing new printer I had usb choice, now it disappeared, only 'other' choice .
    I added usbfs in fstab and mounted it.

    I cancelled all old printers, also a pdf that with 9.04 was working (missing pdf backend ...).
    I installed new printer z645 with ppd ... and URI z600:/dev/usb/lp0 ....

    I don't know what I can do to test and solve.


    Any idea ?
    Thanks to any helping me.
    M.

Page 58 of 71 FirstFirst ... 848565758596068 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •