Page 22 of 71 FirstFirst ... 12202122232432 ... LastLast
Results 211 to 220 of 702

Thread: HOWTO: Lexmark Printers

  1. #211
    Join Date
    Aug 2006
    Beans
    12

    Re: HOWTO: Lexmark Printers

    Wow, works with my Lexmark X1270, excellent stuff!

    Note to several members of this thread (if they're still around) - if your printer is already on the list when you go to System>Administration>Printing (that's in 6.06), try that first!!!

    Also, to swa2b41, in the instructions it gives an optional line to move the downloaded tar.gz file to the newly created lexmark folder. If you did that line, you have to do:

    Code:
    cd lexmark
    right afterwards so you can start working with the files from that directory.

    One last hint to avoid spelling mistakes, when you get to long confusing names, type the first letter or two and hit <TAB>, or just highlight the individual commands on the first page, bring up your terminal window and click your mouse wheel (the wonderful copy and paste method that I always miss when I'm in Windows).

  2. #212
    Join Date
    Sep 2006
    Beans
    3

    Re: HOWTO: Lexmark Printers

    Nice tutorial!
    It did make my Z645 works under Ubuntu Edgy. But I had to give the PPD file path, when asked by printing dialogs, to make the z600 model available on the items list.

  3. #213
    Join Date
    Mar 2007
    Beans
    8

    STUCK with LEXMARK z600

    UG!! PLEASE HELP

    I followed the instructions to the LETTER! NOTHING but error messages.. and why does it ask me for a password? I am already logged in as an administrator...

    devin@devin-desktop:~$ mkdir lexmark
    mkdir: cannot create directory `lexmark': File exists
    devin@devin-desktop:~$ mv CJLZ600LE-CUPS-1.0-1.TAR.gz lexmark #
    mv: cannot stat `CJLZ600LE-CUPS-1.0-1.TAR.gz': No such file or directory
    devin@devin-desktop:~$ tar -xvzf CJLZ600LE-CUPS-1.0-1.TAR.gz #
    tar: CJLZ600LE-CUPS-1.0-1.TAR.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    devin@devin-desktop:~$ tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz #
    tail: cannot open `z600cups-1.0-1.gz.sh' for reading: No such file or directory
    devin@devin-desktop:~$ tar -xvzf install.tar.gz #

    gzip: stdin: unexpected end of file
    tar: Child returned status 1
    tar: Error exit delayed from previous errors
    devin@devin-desktop:~$ alien -t z600cups-1.0-1.i386.rpm #
    bash: alien: command not found
    devin@devin-desktop:~$ alien -t z600llpddk-2.0-1.i386.rpm #
    bash: alien: command not found
    devin@devin-desktop:~$ sudo tar xvzf z600llpddk-2.0.tgz -C / #
    Password:
    Sorry, try again.
    Password:

  4. #214
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: HOWTO: Lexmark Printers

    Thanks, works perfectly with my X1110. Could not at first find the new installed z600 driver.Found it finally in: /usr/share/cups/model

  5. #215
    Join Date
    Mar 2007
    Location
    Sandy Springs, GA
    Beans
    98
    Distro
    Ubuntu Studio 13.10 Saucy Salamander

    Cool Re: HOWTO: Lexmark Printers

    I found that my Dell A920 will work in 6.06 using these instructions

    https://wiki.ubuntu.com/HardwareSupp...rs/LexmarkZ605

    I never could get it to work in 6.10, so I went back to 6.06

  6. #216
    Join Date
    Mar 2007
    Beans
    15

    Re: HOWTO: Lexmark Printers

    Hi,

    I have followed all the directions to the part where I run ./z600. I get no output. I have mounted usbfs as shown, and that still doesn't change it. Can anyone suggest more ideas? Thanks

  7. #217
    Join Date
    Apr 2007
    Beans
    1

    Re: HOWTO: Lexmark Printers

    I had a little different setup, I was connecting to a Lexmark 510 series printer attached to a windows XP box on my home network.

    This howto works to the point where you try to use System/Administration/Printers to setup the printer. It would never show the driver and if you tried to install it, it would say that it was already installed.

    I got some help from this post http://www.aquarionics.com/article/n...r_Debian_Linux

    The default printer utility doesn't allow you to setup the printer. You can set it up by connecting to http://localhost:631 and using the web admin interface to setup your printer. I set mine up to connect to the printer using smb://WindowsXPcomputerName/PrinterName
    as the URI and then choosing the z600 driver in /usr/share/cups/model directory. This set the printer up and I could then print to it.

    The default Gnome printer utility is a little brain dead and never shows the new printer driver or allows you to manually choose it. Using the Cups web admin interface gives you much better control and selection in setting the printer up correctly under Feisty Fawn Beta.

    So to use this howto under Edgy or Feisty, follow it till the end and Don't try to use the Gnome printer setup utility, Use the Cups web interface at the end of the tutorial by connecting to http:/localhost:631 to do the final configuration after you have the z600 driver installed.

  8. #218
    Join Date
    Apr 2007
    Beans
    3

    Re: HOWTO: Lexmark Printers

    For those who are still getting the scanner to work for a X1100 series AIO, this is the small step that often gets left out. The standard setup for sane looks for the scanner at /dev/usb/scanner0. The answer that I always find for this is don't use udev. What?!

    It's such an easy fix once someone actually takes the time to put out there. Sane looks for the scanner based on the config file for the scanner in /etc/sane.d/lexmark.conf. Guess what that file says:

    /dev/usb/scanner0

    So, I assume that's where the scanner is supposed to be. No. To find out where the scanner really is, look in the file /etc/sane.d/hotplug/libsane.db.

    In there, you will see that the X1100 scanners are at:

    0x043d 0x007c

    To make a long story short, your /etc/sane.d/lexmark.conf file (or wherever Ubuntu puts it, I run Debian) should have this one line in it:

    usb 0x043d 0x007c
    So, to repeat. Here's what I did.

    $su
    Password:
    #vi /etc/sane.d/lexmark.conf

    Then I deleted the line that reads "usb /dev/usb/scanner0" by hitting "dd", type "i" to insert, typed in the line above, hit escape to get out of insert mode and typed in ":wq".

    Then just make sure you exit out of root before trying scanimage or xsane or anything.

    For some reason my X1150 still won't scan, but it does something to let me know Debian found it.

    I guess it's more appropriate to say that usb 0x043d 0x007c is what the vendor code for the scanner is. Linux will find it based off of you telling it what the vendor ID is even though it already knows that something with the ID of 0x043d 0x007c is connected to it.

    Scanner access now easy.

    Edit: If you don't want to look through config files, the vendor ID can be located with "lsusb -v". Of course that produces a rather large output and there's more than one ID on the X1100.
    Last edited by trigggl; April 8th, 2007 at 02:58 PM. Reason: forgot to mention something

  9. #219
    Join Date
    Feb 2007
    Location
    Brampton, Ontario
    Beans
    883

    Exclamation Re: HOWTO: Lexmark Printers

    Quote Originally Posted by o0blueardvarko0 View Post
    Ok. I tried all of that already. The way you have it laid out but once i get to the part you extract it using the tail command everything just fails. Can you help me? Maybe tell me why my Lexmark X1185 isnt working?
    Yeah, I get lots of really funky, wierdo output when I run the tail command, it just keeps going, I don't know what to do. Someone help??
    "For those who believe, no explanation is necessary. For those who do not, none will suffice." - Joseph Dunninger

  10. #220
    Join Date
    Mar 2007
    Location
    127.0.0.1
    Beans
    206
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: Lexmark Printers

    Thank you very much. I got my Lexmark x1150 that is connected to my wife's xp box working across the wireless. I too had to manually install the .ppd to get z600 on the list, but once that happened it worked perfectly. Thanks again.

Page 22 of 71 FirstFirst ... 12202122232432 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •