Page 14 of 71 FirstFirst ... 412131415162464 ... LastLast
Results 131 to 140 of 702

Thread: HOWTO: Lexmark Printers

  1. #131
    Join Date
    Jan 2006
    Location
    Franklin, KY
    Beans
    40
    Distro
    Ubuntu 6.06

    Re: HOWTO: Lexmark Printers

    Dapper 6.06. Configuring Lexmark z515.

    Tried everything I could find about installing the z600le driver. I tried for hours but nothing worked for me (I'm new to command line).

    I learned a lot along the way; thanks to all who contributed to this thread.

    Then I found this installation How To:

    https://wiki.ubuntu.com/HardwareSupp...rs/LexmarkZ605

    I followed these directions and EUREKA! My z515 works perfectly. Thank you all for help.
    Last edited by imhdd; July 20th, 2006 at 02:40 PM. Reason: better link to page

  2. #132
    Join Date
    Jan 2006
    Location
    Oud-Vossemeer, The Netherlands
    Beans
    27
    Distro
    Ubuntu 6.06

    Re: HOWTO: last steps in Dapper don't work

    Quote Originally Posted by ivuntu View Post
    Hi,

    I followed your guide in Breezy: it worked very good, but in Dapper, the printer failed to work, so I followed the howto again. it gets down to this: I get no output when I type ./z600. So I added
    Code:
    usbfs         /proc/bus/usb usbfs   devgid=14,devmode=0660 0 0
    in /etc/fstab.

    When I typed

    Code:
    sudo mount usbfs
    I got this:
    Code:
    mount: usbfs already mounted or /proc/bus/usb busy
    mount: according to mtab, procbususb is already mounted on /proc/bus/usb
    Any suggestions?
    I got it working again: it was a faulty USB Hub. The HOWTO works for Dapper too, it seems. good luck everybody

  3. #133
    Join Date
    Jul 2006
    Beans
    1

    Smile Re: HOWTO: Lexmark Printers

    Worked lika charm --Lexmark z515
    Many thanx

  4. #134
    Join Date
    Jul 2006
    Location
    Ottawa, Ontario
    Beans
    83
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Lexmark Printers

    Finally! I got my Lexmark x1110 printer to work in Dapper! I haven't tested my scanner, yet, though.

    Thank you so much!

    BTW, I can't seem to be able to print from Firefox. Anyone else have this issue?
    Leonivek
    Microsoft can go format themselves.
    Linux FUD: http://linuxFUD.wordpress.com/

  5. #135
    Join Date
    Aug 2006
    Beans
    Hidden!

    Re: HOWTO: Lexmark Printers

    Quote Originally Posted by black hole sun View Post
    Everyone -- I'm so sorry I haven't been here for a long time so I haven't been able to help you guys.

    I figured out your problem -- you need to mount the usb filesystem. Add this line to /etc/fstab

    usbfs /proc/bus/usb usbfs devgid=14,devmode=0660 0 0

    Then type

    sudo mount usbfs

    Try the backend again and it should work.
    Excuse my lack of Linux-knowlege, but how do you "add" that line to /etc/fstab.

  6. #136
    Join Date
    Dec 2005
    Location
    Montreal
    Beans
    5
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Lexmark Printers

    This Howto works with my Lexmark X1195 and dapper.

    Thanks a lot for your work

  7. #137
    Join Date
    Aug 2006
    Beans
    1

    Talking Re: HOWTO: Lexmark Printers

    Hi,
    Got that driver going for my lexmark-X1195 on SuSE 10.0. The only changes I had to make were :-

    1.did not do the alien part - just did :-
    rpm -ivh --nodeps ( both rpms on same line )
    2.to reatart cups :- /etc/init.d/cups restart
    3.added that usbfs line to my existing fstab ( after backing up fstab )
    4.umount usbfs & did 'mount usbfs'
    5.ran out the test print via gnome ... all went well !!


    Regards, .

  8. #138
    Join Date
    Apr 2006
    Location
    North Carolina, USA
    Beans
    1
    Distro
    Ubuntu Breezy 5.10

    Re: HOWTO: Lexmark Printers

    Many thanks! Absolute newbee and your thorough indtructions were the best!

  9. #139
    Join Date
    Aug 2006
    Location
    milwaukee, wi
    Beans
    Hidden!
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Lexmark Printers

    Quote Originally Posted by imhdd View Post
    Dapper 6.06. Configuring Lexmark z515.

    Tried everything I could find about installing the z600le driver. I tried for hours but nothing worked for me (I'm new to command line).

    I learned a lot along the way; thanks to all who contributed to this thread.

    Then I found this installation How To:

    https://wiki.ubuntu.com/HardwareSupp...rs/LexmarkZ605

    I followed these directions and EUREKA! My z515 works perfectly. Thank you all for help.
    being a complete newbie my self . where do i put those commands. i tryed opening terminal but got nothing but error messages after typing in the commands listed on that link.
    thanks

  10. #140
    Join Date
    Aug 2006
    Location
    milwaukee, wi
    Beans
    Hidden!
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Lexmark Printers

    Quote Originally Posted by black hole sun View Post
    Hello everyone. This is a ubuntu-adopted version of the gentoo howto (which I originally wrote) http://gentoo-wiki.com/HOWTO_Lexmark_Printers

    Printers that this howto covers (there are many, many others, but these are the printers that have been confirmed to work so far (also note that Dell's printers are merely rebranded Lexmarks):

    With that said, let's get to it!

    The driver we'll be using is the z600 one, which can be found here. Even if your printer isn't a z600 this driver works with a LOT of Lexmark's, so try this driver first.

    Download the driver, save it to a desktop folder such as `lexmark` (I say _folder_ because extracting the driver is a messy process!).

    Obviously, exclude the comments to the right of the hash (#) marks, I include them only to explain the commands.

    Code:
    $ mkdir lexmark
    $ mv CJLZ600LE-CUPS-1.0-1.TAR.gz lexmark # move the package to a folder. optional, but recommended. 
    $ tar -xvzf CJLZ600LE-CUPS-1.0-1.TAR.gz # extract the driver.
    $ tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz # the sh script is broken for newer systems. use `tail` to extract the binary portion of the script.
    $ tar -xvzf install.tar.gz # extract the contents produced by tail
    $ alien -t z600cups-1.0-1.i386.rpm # convert unusable rpm packages to tgz.
    $ alien -t z600llpddk-2.0-1.i386.rpm # convert unusable rpm packages to tgz.
    $ sudo tar xvzf  z600llpddk-2.0.tgz -C / # extract the tgz's to / putting the files in their right place
    $ sudo tar xvzf z600cups-1.0.tgz -C / # extract the tgz's to / putting the files in their right place
    $ sudo ldconfig # DO NOT SKIP THIS STEP or your printer backend won't find required libraries
    $ cd /usr/share/cups/model
    $ sudo gunzip Lexmark-Z600-lxz600cj-cups.ppd.gz # unzip the ppd, which should _not_ be gzipped
    The driver is now installed. Restart the cups daemon:
    Code:
    /etc/rc2.d/S19cupsys restart
    Check whether the printer backend works;
    Code:
    $ cd /usr/lib/cups/backend
    $ ./z600
    The output of the above command should be _similar_ to this:
    If you get no output, mount the usb filesystem.

    Add this to your /etc/fstab file:

    Code:
    usbfs         /proc/bus/usb usbfs   devgid=14,devmode=0660 0 0
    Then just type: sudo mount usbfs. That should fix it.

    Now simply set up your printer through the System->Administration->Printing in gnome. Make sure you select the z600 driver, and you're golden.

    For KDE users...well, you'll have to use whatever printer dialogue that KDE provides.

    There you have it! If you need any help, post to this thread.
    ok, i opened terminal typed in the commands as you had them written.
    i downloaded the driver from lexmark.
    but when i got to the 2nd one, the reply i got the file connot be found in any file or directory.
    what did i do wrong?
    thanks

Page 14 of 71 FirstFirst ... 412131415162464 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •