Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Can anyone help: need correct reolution and fullscreen for xp-guest in vmware-server?

  1. #11
    Join Date
    May 2007
    Beans
    24
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Can anyone help: need correct reolution and fullscreen for xp-guest in vmware-ser

    OK I thought I'd post a follow-up.

    I found this thread, which worked for me, and I am now getting 1440x900 in WinXP.

    Buzz

  2. #12
    Join Date
    Dec 2007
    Beans
    123

    Re: Can anyone help: need correct reolution and fullscreen for xp-guest in vmware-ser

    yet another bump, this came up in a search. XP won't run fullscreen for me either.

    I've done the above link and it didn't work.

    I've also done the matching resolution thing. After some wrestling I was able to get Fedora7 running as a client by running vmware-config-tools.pl and set the res in there.


    is there maybe a vm setting somewhere that needs editing to point to xorg.conf instead of XF86Config?


    I have found a workaround, if 'Quick Switch' works for you. (never had probs with it.)

    Go ahead and start XPclient. Then go into VM's >View and uncheck tabs, status bar, turn off icons etc, then when everything is off hit the 'Fit Guest Now'. You'll still have access to VM via a hidden panel.

    On my system that's as close to XP full screen as close can get. Really cool part is a ctrl+alt double tap releases me from XP and I'm back in linux.
    Last edited by MonsterMaxx; January 15th, 2008 at 03:30 AM.

  3. #13
    Join Date
    Oct 2006
    Beans
    124

    Re: Can anyone help: need correct reolution and fullscreen for xp-guest in vmware-ser

    Another solution that might work...
    Code:
    DISPLAY=:0 vmware
    To make your shortcuts work like this, change their command to
    Code:
    env DISPLAY=:0 vmware

  4. #14
    Join Date
    Dec 2007
    Beans
    118
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Can anyone help: need correct reolution and fullscreen for xp-guest in vmware-ser

    Try this link. The instrux look very straightforward and make sense conceptually

    http://www.ubuntugeek.com/how-to-set...u-desktop.html

  5. #15
    Join Date
    Dec 2007
    Beans
    123

    Re: Can anyone help: need correct reolution and fullscreen for xp-guest in vmware-ser

    I had the same problem.
    Assuming you are using Nvidia drivers, they do not setup the xorg right for vmware. You need to make your xorg.conf include the display modes.

    Here's mine, it works, XP, full screen, etc.

    It needs the SubSection "Display" entry

    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (buildmeister@builder3)  Thu Dec 13 19:10:32 PST 2007
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Thu Dec 13 19:09:35 PST 2007
    # Xorg configuration created by system-config-display
    # Section "Module"
    #    Load           "glx"
    # EndSection
    
    Section "ServerLayout"
    	Identifier     "single head configuration"
    	Screen      0  "Screen0" 0 0
    	Screen      1  "Screen1" RightOf "Screen0"
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "ServerFlags"
    	Option	    "Xinerama" "0"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "auto"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "Emulate3Buttons" "no"
    	Option	    "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "us"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor0"
    	VendorName   "Unknown"
    	ModelName    "CRT-0"
     ### Comment all HorizSync and VertSync values to use DDC:
    	HorizSync    30.0 - 110.0
    	VertRefresh  50.0 - 150.0
    	Option	    "DPMS"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor1"
    	VendorName   "Unknown"
    	ModelName    "TV-0"
     ### Comment all HorizSync and VertSync values to use DDC:
    	HorizSync    28.0 - 33.0
    	VertRefresh  43.0 - 72.0
    EndSection
    
    Section "Device"
    	Identifier  "Videocard0"
    	Driver      "nvidia"
    	VendorName  "NVIDIA Corporation"
    	BoardName   "GeForce 7800 GS"
    	BusID       "PCI:1:0:0"
    EndSection
    
    Section "Device"
    	Identifier  "Videocard1"
    	Driver      "nvidia"
    	VendorName  "NVIDIA Corporation"
    	BoardName   "GeForce 7800 GS"
    	BusID       "PCI:1:0:0"
    	Screen      1
    EndSection
    
    Section "Screen"
    
    # Removed Option "metamodes" "CRT: 1280x1024 +0+0"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	Monitor    "Monitor0"
    	DefaultDepth     24
    	Option	    "TwinView" "0"
    	Option	    "TwinViewXineramaInfoOrder" "CRT-0"
    	Option	    "metamodes" "CRT: 1280x1024_85 +0+0; CRT: 1280x1024 +0+0"
    	SubSection "Display"
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "Screen1"
    	Device     "Videocard1"
    	Monitor    "Monitor1"
    	DefaultDepth     24
    	Option	    "TwinView" "0"
    	Option	    "metamodes" "TV: nvidia-auto-select +0+0"
    	SubSection "Display"
    		Depth     24
    	EndSubSection
    EndSection
    Hope that helps.
    Last edited by MonsterMaxx; March 18th, 2008 at 09:46 PM.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •