Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: No Sound Running Starcraft on WINE

  1. #1
    Join Date
    May 2007
    Beans
    853
    Distro
    Ubuntu 9.10 Karmic Koala

    No Sound Running Starcraft on WINE

    hey guys! the title kinda says it all.


    I'm an Ubuntu noob - I've been using it for around 9 days now and it's the best OS I've ever used..

    however, I need to dual boot to windows just to play games, and I'm trying to get around that with my favorite game - Starcraft.

    I downloaded Wine from the add/remove programs list and installed starcraft with it... It loaded great and i can play... but there is no sound.

    The sound is kind of crucial since it tells you whether you are being attacked or not.


    has anyone else had this problem?


    I'm running Feisty 32 bit.

  2. #2
    Join Date
    Apr 2007
    Beans
    Hidden!

    Re: No Sound Running Starcraft on WINE

    Hi, try going into winecfg (type it in a terminal) and set the audio to Oss and Full Emulation. This settings worked to me

  3. #3
    Join Date
    May 2007
    Beans
    853
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: No Sound Running Starcraft on WINE

    I get this error when i try to do that

    Code:
    mykola@MykolaUbuntu:~$ winecfg
    fixme:jack:JACK_drvLoad error loading the jack library libjack.so, please install this library to use jack

  4. #4
    Join Date
    May 2007
    Beans
    853
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: No Sound Running Starcraft on WINE

    LOL... surprisingly, it still works.

    thanks m8

  5. #5
    Join Date
    May 2007
    Beans
    853
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: No Sound Running Starcraft on WINE

    Ah... but now it's got a different issue


    Battle.Net wont work.

  6. #6
    Join Date
    Oct 2005
    Location
    Ottawa Ontario Canada
    Beans
    50

    Re: No Sound Running Starcraft on WINE

    I'm currently having a problem with Starcraft as well. When selecting OSS, there is no sound whatsoever. using ALSA has so far worked better but as soon as I enter a campaign mission, the sounds begin to stutter and loop without end.

    any suggestions? as I've said, OSS doesn't work for me

    thanks

    PS. I'm using Feisty.

  7. #7
    Join Date
    Oct 2005
    Location
    Belgium
    Beans
    76
    Distro
    Ubuntu Development Release

    Re: No Sound Running Starcraft on WINE

    ...try setting everything in winecfg to 'emulation'. It worked fine for me when using ALSA.

  8. #8
    Join Date
    May 2007
    Beans
    853
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: No Sound Running Starcraft on WINE

    yep. emulation works.

    also, there is a downloadable add on to let battle.net work (though i can't remember where it is)

    the performance is still shoddy, but once you get into the game online, it works perfectly.
    The box said that I needed to have Windows 98 or better... so I installed Linux
    Need help with shell commands? click
    Need MORE help with shell commands? advanced click

  9. #9
    Join Date
    Jun 2007
    Beans
    11

    Re: No Sound Running Starcraft on WINE

    "also, there is a downloadable add on to let battle.net work (though i can't remember where it is)"

    I have the same problem with Battle.net. If you remember/come across it again, would you mind posting it here or pming it to me?

    Thanks,

    Amyn

  10. #10
    Join Date
    Oct 2005
    Location
    Ottawa Ontario Canada
    Beans
    50

    Re: No Sound Running Starcraft on WINE

    Sound is working now there's some persistent static sometimes but not loud enough to be distracting once you're playing.

    Thanks for the help

    Dan

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •