Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: error en activar la configuració XKB

  1. #1
    Join Date
    Nov 2005
    Beans
    79

    error en activar la configuració XKB

    Bon dia a tothom. En engegar l'ordinador em surt l'error que copio més avall. La conseqüència, que no puc escriure ni l'arrova ni altres funcions del teclat...

    S'ha produït un error en activar la configuració XKB.
    Això pot passar per diversos motius:
    - un error de programació en la biblioteca libxklavier
    - un error de programació en el servidor X (utilitats xkbcomp, xmodmap)
    - Un servidor X amb una implementació incompatible de libxkbfile

    Dades de la versió del servidor d'X:
    The X.Org Foundation
    70200000

    Si informeu d'aquesta situació en un informe d'error, incloeu-hi:
    - El resultat de xprop -root | grep XKB
    - El resultat de gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

  2. #2
    Join Date
    Nov 2006
    Location
    Catalunya
    Beans
    153
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: error en activar la configuració XKB

    Té pinta de configuració de xorg prova de fer:
    Code:
    sudo dpkg-reconfigure xserver-xorg
    en cas de no funcionar, escriu-nos un missatge amb el configut de:
    cat /etc/X11/xorg.conf
    i de:
    xprop -root | grep XKB
    gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

    tal i com t'indicava l'error anterior.
    Crazy!

  3. #3
    Join Date
    Nov 2005
    Beans
    79

    Re: error en activar la configuració XKB

    Gràcies per la resposta. Us escric el configut que em demaneu:

    /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Files"
    FontPath "/usr/share/X11/fonts/misc"
    FontPath "/usr/share/X11/fonts/cyrillic"
    FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/share/X11/fonts/Type1"
    FontPath "/usr/share/X11/fonts/100dpi"
    FontPath "/usr/share/X11/fonts/75dpi"
    FontPath "/usr/share/fonts/X11/misc"
    # path to defoma fonts
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection

    Section "Module"
    Load "bitmap"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "record"
    Load "type1"
    Load "vbe"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "es"
    Option "XkbVariant" "es"
    Option "XkbOptions" "es"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ExplorerPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "stylus"
    Option "Device" "/dev/wacom" # Change to
    # /dev/input/event
    # for USB
    Option "Type" "stylus"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "eraser"
    Option "Device" "/dev/wacom" # Change to
    # /dev/input/event
    # for USB
    Option "Type" "eraser"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "cursor"
    Option "Device" "/dev/wacom" # Change to
    # /dev/input/event
    # for USB
    Option "Type" "cursor"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "Device"
    Identifier "ATI Technologies, Inc. Rage 128 PF/PRO AGP 4x TMDS"
    Driver "vesa"
    BusID "PCI:1:0:0"
    EndSection

    Section "Monitor"
    Identifier "DELL E770p"
    Option "DPMS"
    HorizSync 28-49
    VertRefresh 43-72
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "ATI Technologies, Inc. Rage 128 PF/PRO AGP 4x TMDS"
    Monitor "DELL E770p"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    InputDevice "stylus" "SendCoreEvents"
    InputDevice "cursor" "SendCoreEvents"
    InputDevice "eraser" "SendCoreEvents"
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    xprop -root | grep XKB
    _XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "es", "es", "es"
    _XKB_RULES_NAMES(STRING) = "xorg", "pc105", "es,es", "", "es"

    gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
    layouts = [es es,ad,es cat]
    model =
    options = [grp grp:alts_toggle,lv3 lv3:ralt_switch]
    overrideSettings = true

  4. #4
    Join Date
    Nov 2006
    Location
    Catalunya
    Beans
    153
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: error en activar la configuració XKB

    Has provat de fer:
    Code:
    sudo dpkg-reconfigure -phigh xserver-xorg
    ???

    No veigt res estrany i pel que dius deu ser la configuració del teclat o que el teu teclat es extrany.... pots provar també d'engegar una LiveCd a veure si t'ho diu, i fer un cat /etc/X11/xorg.conf, si trobes alguna diferencia en l'apartat: Section "InputDevice"
    Identifier "Generic Keyboard" pot ser aquesta la causa... bé masses coses, primer prova d'executar la comanda que dic, i ens dius que tal... et demanarà password d'administrador, que si ho ets, es el mateix password de l'usuari amb el que executes la comanda.
    Crazy!

  5. #5
    Join Date
    Nov 2005
    Beans
    79

    Re: error en activar la configuració XKB

    He fet la comanda, però res no canvia. El mateix error en engegar.
    Segueixo només tenint una manera d'escriure l'arrova: he de fer
    setxkbmap -layout 'es,es' -model pc105
    cada vegada....

    Moltes gràcies per l'ajut!

    ps: el cas és que abans d'actualitzar a la darrera versió d'Ubuntu, em funcionava perfectament...

  6. #6
    Join Date
    Aug 2005
    Location
    Països Catalans
    Beans
    1,530
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: error en activar la configuració XKB

    No tindras les XGL com a gestor d'Xs?

  7. #7
    Join Date
    Nov 2005
    Beans
    79

    Re: error en activar la configuració XKB

    Ostres! em sap greu, però no arribo ni a entendre la pregunta. Per tant, no ho sé pas

    Gràcies!

  8. #8
    Join Date
    Aug 2005
    Location
    Països Catalans
    Beans
    1,530
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: error en activar la configuració XKB

    Això t'ha començat a passar al finalitzar la instaŀlació (o actualització) o ja portaves un temps funcionant amb feisty?

    Una mala instaŀlació del compiz o beryl (efectes d'escriptori) pot produir un mal funcionament del teclat similar al que descrius. I la gràfica que tens configurada Rage 128 amb el controlador vesa no ho suporta segur.

    Comprova si de cas a Sistema > Preferències > Efectes d'escriptori que estigui tot deshabilitat.

    Prova també xmodmap /usr/share/xmodmap/xmodmap.es
    Last edited by CarlesOriol; June 1st, 2007 at 07:04 AM.

  9. #9
    Join Date
    Nov 2005
    Beans
    79

    Re: error en activar la configuració XKB

    Moltes gràcies. Però, de moment he fet tot el que em dius i continuo sense l'arrova...
    Em va passar tot d'una que vaig instal·lar la Feisty.

    Fins ara i més gràcies!

  10. #10
    Join Date
    Nov 2006
    Location
    Catalunya
    Beans
    153
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: error en activar la configuració XKB

    As provat configurant el teclat des de gnome?
    Sistema-->Preferencies --> Teclat? després reinicies les X i et dirà que tens paràmetres diferents entre gnome i les X... tries les de gnome
    Anims!
    Crazy!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •