Page 14 of 21 FirstFirst ... 41213141516 ... LastLast
Results 131 to 140 of 209

Thread: HOWTO: Make your fonts smooth enough to drool over.

  1. #131
    Join Date
    May 2006
    Location
    Netherlands
    Beans
    467

    Re: HOWTO: Make your fonts smooth enough to drool over.

    Wow...my fonts are so smooth...now...thanks a lot!
    Educate men without faith and you make them clever devils
    Educate men without Linux, then yeah, the opposite happens
    Let Chakra guide the way
    U.3F

  2. #132
    Join Date
    Jan 2006
    Beans
    1,352

    Re: HOWTO: Make your fonts smooth enough to drool over.

    This is an old thread, but it's still on the edgy wiki for smooth fonts. I had found sub pixel rendering in the user interface settings "Font Rendering", and check all three boxes. It made all my fonts smooth.

    Then I added the .fonts.conf from the wiki page and I didn't notice much of a change. Now whenever I use terminal and run mousepad, I get this error:

    Code:
    blah@blah-blah:~$ sudo mousepad ~/.fonts.conf
    Password:
    Fontconfig error: "~/.fonts.conf", line 1: XML declaration not well-formed
    blah@blah-blah:~$
    Should line one be written differently?

    Code:
    <?xml version=”1.0” ?>
    <!DOCTYPE fontconfig SYSTEM “fonts.dtd”>
    <fontconfig>
    <match target=”font”>
    <edit name=”autohint” mode=”assign”>
    <bool>true</bool>
    </edit>
    </match>
    </fontconfig>

  3. #133
    Join Date
    Apr 2005
    Location
    Lincoln, NE
    Beans
    9

    Re: HOWTO: Make your fonts smooth enough to drool over.

    I was able to fix the XML validation notices by changing the quotes:

    Code:
    <?xml version='1.0' ?>
    <!DOCTYPE fontconfig SYSTEM "fonts.dtd">
    <fontconfig>
    <match target='font'>
    <edit name='autohint' mode='assign'>
    <bool>true</bool>
    </edit>
    </match>
    </fontconfig>

  4. #134
    Join Date
    Sep 2006
    Beans
    110

    Angry Re: HOWTO: Make your fonts smooth enough to drool over.

    Quote Originally Posted by dagnabit dang doohickey View Post
    LCD users may get even better results if you use the following code in your .fonts.conf file. This may work for CRT users as well, but I cannot confirm since I have only used this on my laptop.

    Code:
    <?xml version="1.0"?>
    <!DOCTYPE fontconfig SYSTEM "fonts.dtd">
    
    <!-- the cathectic LCD tweaks, from linuxquestions.org,
    http://www.linuxquestions.org/questions/showthread.php?postid=1361098#post1361098
    -->
    
    <fontconfig>
    
    <!-- Disable sub-pixel rendering. X detects it anyway, and if you set
    this as well, it just looks really horrible  -->
    <match target="font" >
     <edit mode="assign" name="rgba" >
      <const>none</const>
     </edit>
     </match>
     <match target="font" >
     <edit mode="assign" name="hinting">
      <bool>true</bool>
     </edit>
     </match>
     <match target="font" >
     <edit mode="assign" name="hintstyle">
      <const>hintfull</const>
     </edit>
     </match>
    
    <!-- The first part of the 'magic.' This makes the fonts start to look
    nice, but some of the shapes will be distorted, so hinting is needed
    still -->
     <match target="font" >
     <edit mode="assign" name="antialias">
      <bool>true</bool>
     </edit>
     </match>
    
    <!-- Autohinter is not turned on automatically. Only disable this if
    you have recompiled Freetype with the bytecode interpreter, which is
    run automatically. Although to be honest, Freetype are right, there
    isn't much difference between the two. Note that OpenOffice is built
    against the bytecode interpreter, so even if you have compiled it and
    override it with the autohinter, OOo will still use the bytecode
    interpreter -->
     <match target="pattern" >
     <edit mode="assign" name="autohint">
      <bool>true</bool>
     </edit>
     </match>
    
    <!-- Helvetica is a non true type font, and will look bad. This
    replaces it with whatever is the default sans-serif font -->
     <match target="pattern" name="family" >
     <test name="family" qual="any" >
      <string>Helvetica</string>
     </test>
     <edit mode="assign" name="family" >
      <string>sans-serif</string>
     </edit>
     </match>
     <dir>~/.fonts</dir>
    </fontconfig>

    I found this hack here[michael-and-mary.net], who in turn found it from it's original creator here[linuxquestions.org].
    I did this and now I have boxes instead of fonts in fasterfox and kde and gedit. I am looking for help on how to restore the original fonts.conf file. I am using opera to type this. Thanks fo all help I resolved this by using a live CD and replacing fonts.conf with a backup. Thanks for reading.
    Last edited by ferd; April 27th, 2007 at 10:02 PM. Reason: Resolved

  5. #135
    Join Date
    May 2005
    Beans
    20
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: Make your fonts smooth enough to drool over.

    hi there,

    i did this and also updated the freetype lib thingy for my edgy install so its automatically smooth... (followed the ubuntuguide.org way) and now i was wondering is there a way to make wine applications have smoother fonts? I managed to install office2003 using wine (works great) but the fonts are not smoothened at all. No cleartype or nothing.

    if someone can help me out a little that'd be awesome .

    cheers,
    Alkaif.

  6. #136
    Join Date
    Jan 2006
    Location
    Florida
    Beans
    377
    Distro
    Ubuntu 6.06 Dapper

    Re: HOWTO: Make your fonts smooth enough to drool over.

    I am now using Feisty Fawn. Your .fonts.conf was working great for me till I was using edgy.

    I did an upgrade to Feisty and my fonts don't look smooth anymore.

    What should I do ?

    My .fonts.conf looks like

    Code:
    <?xml version="1.0"?>
    <!DOCTYPE fontconfig SYSTEM "fonts.dtd">
    
    <!-- the cathectic LCD tweaks, from linuxquestions.org,
    http://www.linuxquestions.org/questions/showthread.php?postid=1361098#post1361098
    -->
    
    <fontconfig>
    
    <!-- Disable sub-pixel rendering. X detects it anyway, and if you set
    this as well, it just looks really horrible  -->
    <match target="font" >
     <edit mode="assign" name="rgba" >
      <const>none</const>
     </edit>
     </match>
     <match target="font" >
     <edit mode="assign" name="hinting">
      <bool>true</bool>
     </edit>
     </match>
     <match target="font" >
     <edit mode="assign" name="hintstyle">
      <const>hintfull</const>
     </edit>
     </match>
    
    <!-- The first part of the 'magic.' This makes the fonts start to look
    nice, but some of the shapes will be distorted, so hinting is needed
    still -->
     <match target="font" >
     <edit mode="assign" name="antialias">
      <bool>true</bool>
     </edit>
     </match>
    
    <!-- Autohinter is not turned on automatically. Only disable this if
    you have recompiled Freetype with the bytecode interpreter, which is
    run automatically. Although to be honest, Freetype are right, there
    isn't much difference between the two. Note that OpenOffice is built
    against the bytecode interpreter, so even if you have compiled it and
    override it with the autohinter, OOo will still use the bytecode
    interpreter -->
     <match target="pattern" >
     <edit mode="assign" name="autohint">
      <bool>true</bool>
     </edit>
     </match>
    
    <!-- Helvetica is a non true type font, and will look bad. This
    replaces it with whatever is the default sans-serif font -->
     <match target="pattern" name="family" >
     <test name="family" qual="any" >
      <string>Helvetica</string>
     </test>
     <edit mode="assign" name="family" >
      <string>sans-serif</string>
     </edit>
     </match>
     <dir>~/.fonts</dir>
    </fontconfig>

    Every help is appreciated.

    Thanks

    Quote Originally Posted by dagnabit dang doohickey View Post
    You can try this fix I posted on the previous page. It's what I currently use and it gives the best results I've seen so far.

  7. #137
    Join Date
    Apr 2006
    Location
    Germany
    Beans
    320
    Distro
    Ubuntu

    Re: HOWTO: Make your fonts smooth enough to drool over.

    yeah fonts look kinda shittyin feisty, especially openoffice and firefox (those checkboxes and radio buttones even, yuck... vomit)

  8. #138
    Join Date
    Apr 2007
    Beans
    6

    Re: HOWTO: Make your fonts smooth enough to drool over.

    Ditto--firefox, epiphany, and in general, everywhere.

  9. #139
    Join Date
    Sep 2005
    Beans
    68
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: Make your fonts smooth enough to drool over.

    so this trick don't work anymore in feisy ?

  10. #140
    Join Date
    Apr 2006
    Beans
    131

    Re: HOWTO: Make your fonts smooth enough to drool over.

    Hi, it just works on feisty, but you have to change the [ " ]'s by [ ' ]'s.

    Here it is:
    Code:
    <?xml version='1.0' ?>
    <!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
    <fontconfig>
    <match target='font'>
    <edit name='autohint' mode='assign'>
    <bool>true</bool>
    </edit>
    </match>
    </fontconfig>
    The "XML declaration not well-formed" error is now gone, and i now , like said, just drool over my fonts.
    Small fonts size are more sharp , precise. Nice !

    Thanks for info.

Page 14 of 21 FirstFirst ... 41213141516 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •