Page 1 of 7 123 ... LastLast
Results 1 to 10 of 64

Thread: HOW TO: Logitech MX5000 via (bluetooth)

  1. #1
    Join Date
    May 2005
    Location
    Yoshi Island
    Beans
    514
    Distro
    Ubuntu 9.10 Karmic Koala

    HOW TO: Logitech MX5000 via (bluetooth)

    Ok I can't take the credit for this, I found out how to get my mx5000 working via bluetooth from bug reports. I thought I would share with you all.

    Got all the info from here thanks to kryilian and amedee

    Ok so first thing you should notice when you have a Logitech bluetooth device is at login (gdm) that more or less it does not work. However unplugging and replugging in the adapter puts the device in USB emulation mode but you can not use bluetooth to transfer files for example or use other blue tooth devices with in this mode.

    So after going through bluetooth bug reports I finally got my MX5000 working in feisty.

    What you need:
    you need either a spare keyboard and mouse or need to know your keyboard and mouses mac address. For those of use who dual boot Vista and Ubuntu you can get your devices mac address (if you are using the set over bluetooth of course)

    For those who are using a spare keyboard and mouse, or do not use vista you can skip this part. Now you are in vista if you are using the set over bluetooth you should see the bluetooth logo in your systray, when you double click it, you should get a window, displaying all the bluetooth devices connected. In the device properties you should see the devices MAC addresses, now write them down, in fact if you want write down any other devices mac address you intend to use like your wii mote ;p.



    now write them down.

    Ok if you want to do this the spare keyboard and mouse way, what you do is obviously plug the spare keyboard and mouse in, and the bluetooth mouse and keyboard. Once you get to gdm you obviously have to use the spare keyboard. What you need to do is first set your device in discoverable mode, ie with a phone do it through the settings, or press the connect button on your logitech keyboard or mouse. Now enter hcitool scan in terminal, this should find your device and output the its mac address. I had it once not able to find the device, so I just re-entered the command in terminal, and it found my keyboard and mouse. So just be warned you may need to do it a couple of times.


    Now you have your devices mac addresses you now just need to do the following.....

    Those who do not have the spare keyboard and mouse, unplug the usb adapter and plug it back in to get the set in the usb emulation mode, log in and then open up terminal.

    Those using the spare keyboard and mouse might notice the bluetooth logo in the gnome notification area. Now open terminal and enter;

    Code:
    hcitool dev
    and I get an output like this;
    Code:
    hci0    00:07:61:40:CC:77
    now what you can do is this, I found that the automatic startup wont connect unless you manually connect at least once. So to do this put the keyboard and mouse in discoverable mode (little red buttons on the bottom of the keyboard and mouse)
    in terminal enter this;
    Code:
    sudo hidd -search
    this will connect any discoverable bluetooth devices, like your wiimote if you put it in discovery mode as well. Once they are connected continue to make your keyboard and mouse connect automatically.

    this basically to my understanding is the bluetooth adapters id and mac address. Not what you want to do is open up /etc/default/bluetooth so;
    Code:
    gksudo gedit /etc/default/bluetooth
    or
    Code:
    sudo nano /etc/default/bluetooth
    now look for a section that looks like this
    Code:
    ############ HIDD
    #
    # To have Bluetooth mouse and keyboard support, get the
    # Linux 2.6.6 patch or better from bluez.org, and set 
    # HIDD_ENABLED to 1.
    HIDD_ENABLED=0
    HIDD_OPTIONS="--master --server"
    # to make hidd always use a particular interface, use something
    # like this, substituting the bdaddr of the interface:
    # HIDD_OPTIONS="-i AA:BB:CC:DD:EE:FF --server"
    #
    # remove '--master' if you're having trouble working with Ericsson
    # T630 phones with hidd operational at the same time.
    So now what you need to do is change the HIDD_ENABLED and HIDD_OPTIONS
    you need to change the HIDD_ENABLED to HIDD_ENABLED=1, now this is where it gets a little tricky...this is the HIDD_OPTIONS line that worked for me.....but others have used different lines to get this to work;

    my settings, that got my mx5000 to work;
    Code:
    HIDD_ENABLED=1
    HIDD_OPTIONS="-i hci0 --connect 00:07:61:32:70:6F --connect 00:07:61:33:CF:33 --master --server"
    however these HIDD_OPTIONS have worked, according to others in the bug report;
    [code]
    HIDD_OPTIONS="--master --connect 00:07:61:34xx--connect 00:07:61:37xx --server"
    HIDD_OPTIONS="--connect 00:07:61:07:XX:XX --connect 00:07:61:06:YY:YY --connect 00:07:61:06:ZZ:ZZ --master --server"
    [code]

    bascially if you get a similar output as me when doing hcitool dev try my line, do not forget use your devices mac address to connect.

    OK ..... there is one more change I made, I have no Idea if this change made a difference or not but open up /etc/init.d/bluetooth, however you wish to do; now look for this section;

    Code:
      restart|force-reload)
    	log_daemon_msg "Restarting $DESC"
    	stop_hid || true
    	stop_pan || true
    	start-stop-daemon --stop --quiet --exec $HCID || true
    	sleep 1
    	if test "$BLUETOOTH_ENABLED" == "0"; then
    		log_progress_msg "disabled. see /etc/default/bluetooth"
    		log_end_msg 0
    		exit 0
    	fi
    	start-stop-daemon --start --quiet --exec $HCID -- $HCID_OPTIONS || true
    	log_progress_msg "$HCID_NAME"
    	start_pan || true
    	start_hid || true
    	restart_rfcomm
    	log_end_msg 0
        ;;
      *)
    I added the line enable_hci_input || true after the start_hid || true line err, like this;

    Code:
      restart|force-reload)
    	log_daemon_msg "Restarting $DESC"
    	stop_hid || true
    	stop_pan || true
    	start-stop-daemon --stop --quiet --exec $HCID || true
    	sleep 1
    	if test "$BLUETOOTH_ENABLED" == "0"; then
    		log_progress_msg "disabled. see /etc/default/bluetooth"
    		log_end_msg 0
    		exit 0
    	fi
    	start-stop-daemon --start --quiet --exec $HCID -- $HCID_OPTIONS || true
    	log_progress_msg "$HCID_NAME"
    	start_pan || true
    	start_hid || true
    	enable_hci_input || true
    	restart_rfcomm
    	log_end_msg 0
        ;;
      *)
    now you can restart bluetooth via
    Code:
    sudo /etc/init.d/bluetooth restart
    hopefully this will get your mouse and keyboard working. Ok so now you should have a working bluetooth keyboard and mouse.

    Ok I haven't found a way to get my mx1000 working properly and the same for the keyboard, but you if open up keyboard preferences, the hit the layout tab, and then pick the Logtiech itouch cordless keyboard (model Y-RB6) as the model, you can use the regular Logitech itough cordless keyboard, which properly detects the volume touch sliders raise volume as XF86VolumeRaise, but for some reason does not work when trying to raise the volume, however, if you use the other model I suggest it detects the raise slider as XF86Launch1, but at least you can raise and lower your volume. Also the FMode keys do work however but the word, excel and powerpoint do not work and neither do the smart keys... :\ and also none of the top shortcut keys except for the email button, which works.

    Ok now I can use my keyboard and mouse in grub, (once it did complain about wanting a passkey) I just entered something random and then was able to freely do what I wished in grub.

    The only other thing is that, when I restart from windows, I loose the keyboards bluetooth connection.

    Also if you want to send and receive files via blue tooth its easy, first install gnome-bluetooth
    Code:
    sudo apt-get install gnome-bluetooth
    then run gnome obex server, send as you would from the other device to recieve and to send files from your computer just right click pick send to and in the send as field pick bluetooth


    *** ALSO NOTE *** I found that updating the dongles firmware makes the keyboard behave strangely, media keys and some keypad buttons do not work, that is available on the logitech website.
    Last edited by spockrock; July 11th, 2007 at 02:11 AM.

  2. #2
    Join Date
    Jun 2005
    Beans
    117

    Re: HOW TO: Logitech MX5000 via (bluetooth)

    Good guide! my hcitool dev returns "hci0 11:11:11:11:11:11" maybe its real I'll give it a try and report back...

  3. #3
    Join Date
    Jun 2005
    Beans
    117

    Re: HOW TO: Logitech MX5000 via (bluetooth)

    My device id was not 11:11:11:11:11:11

    I have to plug in the bluetooth stick, uncheck bluetooth device management in system/admin/services, then check again, and use a spare keyboard and mouse (good thing I'm on a laptop) to open the terminal and execute "hcitool dev"



    I got "hci0 00:07:61:40:B9:94". I press the connect button on my MX mouse and enter "hcitool scan", then I got:

    00:07:61:36:37:FA Logitech MX1000 mouse
    00:12:37:9D:BD:17 Pocket PC

    Wow I found my mouse...

    But I couldn't seem to get it to work yet...
    HIDD_ENABLED=1
    HIDD_OPTIONS="-i hci0 --connect 00:07:61:36:37:FA --master --server"

    I tried the method you mention, including modification to /etc/init/d/bluetooth, not working yet... but I'll keep trying.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	service.jpg 
Views:	4788 
Size:	42.6 KB 
ID:	31737  

  4. #4
    Join Date
    Jun 2005
    Beans
    117

    Re: HOW TO: Logitech MX5000 via (bluetooth)

    This post in the bug report (https://bugs.launchpad.net/ubuntu/+s...ils/+bug/32415) made my mouse work! I followed no. 3) hidd -i hci0 --connect 00:07:61:36:37:FA and now my mouse is working My mouse pointer is faster and smoother than before

    1/ check /etc/default/bluetooth
    HIDD_ENABLED=1
    and add "-i hci0" in HIDD_OPTIONS :
    HIDD_OPTIONS="-i hci0 --master --server"

    2/
    add in /etc/init.d/bluetooth, in "start)" and "restart|force-reload)" sections :
    enable_hci_input || true

    3/ I had to force the very first pairing with this script (launch with sudo)
    hid2hci --tohci
    sleep 1
    /etc/init.d/bluetooth restart
    sleep 1
    #Connect the mouse
    hidd -i hci0 --connect 00:07:61:36:37:FA
    #Connect the keyboard
    hidd -i hci0 --connect xxx... kb adress

    Now everything works, even after reboot, no need to reconnect using the command "hidd -i hci0 --connect 00:07:61:36:37:FA" Weeeeeeeeee!
    Last edited by edmondt; May 4th, 2007 at 05:15 PM.

  5. #5
    Join Date
    May 2007
    Beans
    52
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOW TO: Logitech MX5000 via (bluetooth)

    I don't use my MX5000 or MX1000 in bluetooth mode, I use the standard RF Radio mode (bluetooth mode is only when you hold the red button when inserting the dongle) because I find it more stable and it works before my OS loads.

    I still can't get my keyboard and mouse to work on boot. I can only install via the Alternate installer (in which the keyboard works fine) as the LiveCD kills off my mouse and keyboard somewhere between the desktop appearing and all the icons, panels etc appearing.

    I did not have any of these problems on fedora, even with bluetooth enabled (but not used, as the dongle was not in bluetooth mode it was just totally unaware that my keyboard/mouse/dongle was capable of bluetooth).

    Anyone have any idea 1) why it doesn't work out of the box (it starts working and then dies) and 2) how to get it to work without using bluetooth mode?

  6. #6
    Join Date
    Apr 2007
    Beans
    9

    Re: HOW TO: Logitech MX5000 via (bluetooth)

    As to why it's not working per default:

    When your system recognises the BT dongle as a BT adapter, it switches the adapter from USB emulation mode (which is used at boot time) to BT adapter. After that, any bluetooth hardware wish to use (including the mouse and keyboard) will have to be connected. The HOWTO above specifies how you can have these connections established by default. Your solution of not starting BT services effectively keeps the BT dongle in USB mode (which is fine, realy, except you can't connect to other BT hardware from the same machine, not even if you have another BT interface). Unfortunately, the UBUNTU install CD seems to be the only install/live CD that actually enables bluetooth by default (and thus it does not support BT mouse and/or keyboard after GDM starts, but does support communication with all BT devices, including phones, PDA's and such, after they have been connected properly)

    As to how to get it working without BT mode: remove BT support ( sudo apt-get remove bluez-utils )
    Last edited by martijn_bakker; May 10th, 2007 at 03:53 PM.

  7. #7
    Join Date
    Apr 2007
    Beans
    3

    Re: HOW TO: Logitech MX5000 via (bluetooth)

    it works

    thanks for sharing this!!!

  8. #8
    Join Date
    May 2007
    Beans
    5

    Re: HOW TO: Logitech MX5000 via (bluetooth)

    i have tried that, and when i do hcitool dev i get a blank beside Devices


    my logitech MX5000 works, after repluging in the reciver, just fine though, would that be the only solution to my problem?

  9. #9
    Join Date
    May 2005
    Location
    Yoshi Island
    Beans
    514
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOW TO: Logitech MX5000 via (bluetooth)

    when you unplug and plug it back in the dongle goes into a USB emulation mode, the reason why you get a blank output fromt he hcitool dev, is because you are in the USB emulation mode, and not in bluetooth mode.

    Do you have a spare keyboard temperoraly so you find your keyboard and mouses bt address, so you can configure your bluetooth settings to automatically connect to them on startup?

  10. #10
    Join Date
    May 2007
    Beans
    24

    Question Re: HOW TO: Logitech MX5000 via (bluetooth)

    Hi there,

    Just a quick question for you.

    With this set-up, do all the media keys, etc on the keyboard work ok? Need any further config???

    Any info appreicated.

    Cheers
    Fatmcgav

Page 1 of 7 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •