Page 8 of 14 FirstFirst ... 678910 ... LastLast
Results 71 to 80 of 139

Thread: SSHFS AUTOmount on Feisty

  1. #71
    Join Date
    Jan 2009
    Beans
    10

    Re: SSHFS AUTOmount on Feisty

    I had problems with non-root unmounting.

    Fixed it by adding "fsname=sshfs#<user>@<host>:<path>" to the fstab options (kept all other options).

    Code:
    sshfs#<user>@<host>:<path> <local path> fuse comment=sshfs,noauto,users,exec,uid=1000,gid=1000,allow_other,reconnect,transform_symlinks,BatchMode=yes,fsname=sshfs#<user>@<host>:<path> 0 0
    Read this for more information:
    https://bugs.launchpad.net/ubuntu/+s...se/+bug/243298

    Regards,
    Ola

  2. #72
    Join Date
    Jan 2009
    Beans
    1

    Re: SSHFS AUTOmount on Feisty

    Hi there,

    i have Problems with the automount.

    My System is Ubuntu 8.10 and I want to connect to a Terastation with running OpenSSH.
    On my old system (Ubuntu 8.04) this script already has worked!! But not with my 8.10...

    I have setup public key authentification, so i can connect to my terastation via
    Code:
    ssh root@192.168.178.25
    without password.


    My fstab looks like this
    Code:
    sshfs#root@192.168.178.25:/mnt/array1/data /home/niko/mnt/terastation fuse fsname=sshfs#root@192.168.178.25:/mnt/array1/data,comment=sshfs,noauto,users,exec,uid=1000,gid=1000,allow_other,reconnect,transform_symlinks,BatchMode=yes 0 0

    If i run the /etc/network/if-up.d/mountsshfs with my user, the mount is working well!
    Code:
    niko@nik-thinkpad:/etc/network/if-up.d$ ./mountsshfs
    /home/niko/mnt/terastation mounted as current user (niko)
    niko@nik-thinkpad:/etc/network/if-up.d$
    But when i run this script as sudo i get a: connection reset by pear
    Code:
    niko@nik-thinkpad:/etc/network/if-up.d$ sudo ./mountsshfs
    read: Connection reset by peer
    /home/niko/mnt/terastation failed to mount as #1000
    niko@nik-thinkpad:/etc/network/if-up.d$
    So the automount on system start doesnt's work for me.

    The files mountsshfs and unmountsshfs are chown to root:root with chmod 755.

    Whats going wrong?

    //Edit: Ok, found the Problem: I have setup a phasphrase for my rsa_key. Without the a phasphrase it works.
    Last edited by shuthichi; January 28th, 2009 at 11:23 PM. Reason: Problem fixed for me

  3. #73
    Join Date
    Nov 2008
    Beans
    7

    Re: SSHFS AUTOmount on Feisty

    These scripts work flawlessly out of the box for me between two Intrepid machines. More importantly, you documented every single step, command, and edit clearly instead of providing the usual "just copy and paste this, it'll work" type of post that plagues Linux forums. Thank you so much.

  4. #74
    Join Date
    May 2007
    Location
    SF, CA
    Beans
    45
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: SSHFS AUTOmount on Feisty

    Thanks!
    Much better than nfs for video streaming on my boxes!

  5. #75
    Join Date
    Apr 2009
    Beans
    5

    Re: SSHFS AUTOmount on Feisty

    Including de sshfs mount in my fstab does not work for me. The system tries to mount before the network is available, causing the automount to fail.

    I made a very simple script to work around that:

    Code:
    #!/bin/bash
    
    SERVER="xxx.xxx.xxx.xxx"
    
    until ping $SERVER -W 5 -c 1 -q; do continue; done
    
    sshfs $SERVER:[server path] [local path]
    
    exit 0
    I made this script run at startup. This way, I get the ssfs share automount as soon the server is up. This is particular useful when the client machine starts up before server.

    It simply pings the server every 5 seconds, and when it's available, it mounts the sshfs share.

  6. #76
    Join Date
    Feb 2007
    Beans
    77

    Re: SSHFS AUTOmount on Feisty

    That should not be necessary. You simply need to use the noauto mount option. As the title implies, my guide already shows a way to automatically mount your sshfs mounts when the network comes up. You simply need to use the /etc/network/if-up.d/ directory. Any scripts in that directory will only be executed after the network is up.

  7. #77
    Join Date
    Jan 2007
    Location
    Albany, NY, US
    Beans
    64
    Distro
    Kubuntu 10.10 Maverick Meerkat

    Re: SSHFS AUTOmount on Feisty

    In Kubuntu Jaunty, I was actually getting Permission denied errors from fuse even after uncommenting user_allow_other in fuse.conf. The problem seems to be this bug: https://bugs.launchpad.net/ubuntu/+s...se/+bug/123501

    The solution is to add yourself to the fuse group:
    Code:
    sudo adduser <youruser> fuse
    Then logout and log back in for the group change to take effect.
    Last edited by hedgefighter; November 5th, 2010 at 12:43 AM.

  8. #78
    Join Date
    Jun 2006
    Location
    Parma, Italy
    Beans
    679
    Distro
    Kubuntu

    Re: SSHFS AUTOmount on Feisty

    Thanks a lot! This solved quite a few problems for me.

  9. #79
    Join Date
    Sep 2006
    Location
    California, USA
    Beans
    1,045
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: SSHFS AUTOmount on Fesity, Gutsy, Hardy, Intrepid

    This is an excellent tutorial, and I've implemented it successfully on two machines. My wife loves seemless access to her stuff on our home server.

    Two points of update:
    1) The link for passwordless SSH login is broken as of this post.

    2) Running Jaunty, I seem to be able to unmount sshfs from a non-root user using the original fstab entry. So the perl fix at the end should be specified for 8.04 and 8.10.
    System76 Darter Ultra gen3, 12" Glossy LCD
    Intel Pentium Core 2 Duo, 2.53ghz
    4gb DDR2 SDRAM; 250gb, 7200rpm, SATA HDD
    Intel X4500 Graphics Card

  10. #80
    Join Date
    May 2006
    Location
    The Netherlands
    Beans
    395
    Distro
    Ubuntu Development Release

    Re: SSHFS AUTOmount on Feisty

    I made a support package that integrates sshfs better with the ifup and ifdown network systems, it works with all network managers like gnome-network-manager or the /ect/network/interfaces systems.

    I hope you like it, there is also a private repository and a mailinglist see the readme in the root of the svn repoisory, join and help out if you like.

    package is also in debian mentors waiting for a sponser:
    http://mentors.debian.net/debian/poo...sshfs-storage/

    https://secure.powercraft.nl/svn/pac....1.0-1_all.deb

    Code:
    Source: pct-sshfs-storage
    Section: misc
    Priority: extra
    Maintainer: Jelle de Jong <jelledejong at powercraft dot nl>
    Build-Depends: debhelper (>= 7)
    Standards-Version: 3.8.1
    Homepage: https://secure.powercraft.nl/svn/packages/trunk/source/pct-sshfs-storage/
    
    Package: pct-sshfs-storage
    Architecture: all
    Depends: sudo, sshfs, ifupdown
    Description: intergrate sshfs fstab (u)mount with ifup and ifdown systems
     This package contains scripts and a configuration system to easily
     intergrate your sshfs remote storage system with the standard ifup and
     ifdown systems. This will make it possible to disconnect and reconnect
     to diffrent networks without freezing your sshfs mounts.
     .
     Features:
      - uses the sshfs entry in /etc/fstab
      - supports multiple users, servers, and mount locations
      - connect and disconnect sshfs mounts when network goes up/down
      - possiblility to automatic make smart symbolic links
      - prechecks on mount points and debuging options
      - uses bash, mount and umount mainstream processing tools

Page 8 of 14 FirstFirst ... 678910 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •