Page 13 of 14 FirstFirst ... 311121314 LastLast
Results 121 to 130 of 139

Thread: SSHFS AUTOmount on Feisty

  1. #121
    Join Date
    Feb 2007
    Beans
    77

    Re: SSHFS AUTOmount on Feisty

    If you're getting private key password prompts, then you have a problem with your provate keys. There are already enough howtos on the internet for setting up keys, and my howto here doesn't cover that.

  2. #122
    Join Date
    Jan 2007
    Location
    West Coast
    Beans
    69
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: SSHFS AUTOmount on Feisty

    I can login via ssh without a password without an issue (CLI). I am getting a GUI window asking for passcode.

  3. #123

    Re: SSHFS AUTOmount on Feisty

    rkrizan, your copied lines have space characters between some words and commas.
    Narcis Garcia

  4. #124
    Join Date
    Jan 2007
    Location
    West Coast
    Beans
    69
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: SSHFS AUTOmount on Feisty

    I just checked fstab. I'm not clear why it post that way here, but there isn't spaces in the fstab entry.

  5. #125
    Join Date
    Jan 2007
    Location
    West Coast
    Beans
    69
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: SSHFS AUTOmount on Feisty

    Just to show that I am able to login without a password with the 1000 id:


    root@capone:~# umount /home/ryan/fuse
    root@capone:~# /etc/network/if-up.d/mountsshfs
    read: Connection reset by peer
    /home/ryan/fuse failed to mount as #1000
    root@capone:~# su ryan
    ryan@capone:/root$ ssh ryankrizan@youecho.com cat /proc/cpuinfo|grep bogomips
    bogomips : 5985.37
    bogomips : 5984.25
    ryan@capone:/root$

  6. #126
    Join Date
    Apr 2006
    Beans
    181

    Re: SSHFS AUTOmount on Feisty

    I stumbled upon a question: I use your script not only for sshfs, but also for CIFS mounts to just mount and unmount when the network (dis)connects. (I added the comment also to the CIFS share).

    Since I upgraded to Natty, my computer takes ages to shutdown (actually, 5 minutes). If I look at the messages which are shown on the console during shutdown, I see, just before the computer finally shits down, the follwoing message:

    Code:
    CIFS VFS: Server xxx.xxx.xxx.xxx has not responded in 300 seconds.
    Could this be related to this script? As it works correectly in previous version, I doubt it is related, but you never know...

  7. #127

    Re: SSHFS AUTOmount on Feisty

    ernstblaauw, you need to try the script manually, and also test manually deactivating NetworkManager without shutting down the system.
    Narcis Garcia

  8. #128
    Join Date
    Apr 2006
    Beans
    181

    Re: SSHFS AUTOmount on Feisty

    Quote Originally Posted by narcisgarcia View Post
    ernstblaauw, you need to try the script manually, and also test manually deactivating NetworkManager without shutting down the system.
    Do I need to run the script as root or as normal user?
    If I do "sudo umount /mnt/share", the computer is turned off normally.

  9. #129

    Re: SSHFS AUTOmount on Feisty

    I suggested you a test to diagnose the problem.
    Try the procedure first in the same permissions situation you have, next with root permissions if you feel.
    Narcis Garcia

  10. #130
    Join Date
    Apr 2006
    Beans
    181

    Re: SSHFS AUTOmount on Feisty

    Quote Originally Posted by narcisgarcia View Post
    I suggested you a test to diagnose the problem.
    Try the procedure first in the same permissions situation you have, next with root permissions if you feel.
    I executed manually umountsshfs, as user and with sudo:
    Code:
    $ /etc/network/if-down.d/umountsshfs 
    umount: /home/ernstblaauw/neostrada mount disagrees with the fstab
    $
    
    $ sudo /etc/network/if-down.d/umountsshfs 
    $
    However, the share is still available and if I shutdown, the delay is still there.

    The line in my fstab looks like:
    Code:
    //172.19.3.10/share    /mnt/nmt    cifs    comment=sshfs,username=xxx,password=xxx,noauto,nounix,users,exec,uid=1000,gid=1000,domain=THUISNETWERK,iocharset=utf8    0    0
    I also stopped the network-manager applet:
    Code:
    sudo killall nm-applet
    If I shutdown, the dealy is stil there.

    Do you have any clues what could be the problem, or is probably the CIFS server buggy?

Page 13 of 14 FirstFirst ... 311121314 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •