Is the Lenny dpkg imperative?dpkg: regarding ./dpkg_1.14.7_i386.deb containing dpkg, predependency problem: dpkg pre-depends on libc6 (>= 2.6.1-1)
libc6 is installed, but is version 2.3.6.ds1-13etch2.
dpkg: error processing ./dpkg_1.14.7_i386.deb (--install):
pre-dependency problem - not installing dpkg
Errors were encountered while processing:
Last edited by guyver; October 23rd, 2007 at 02:28 AM.
Might be easier just to start from those
I went ahead with the apt-get update (using all 4 Lenny lines in example of 2nd link) and got the following error:
This is what I put at the beginning of my sources.list file:Reading package lists... Error!
E: Dynamic MMap ran out of room
E: Error occured while processing mgetty (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_gutsy_universe_ binary-i386_Packages
E: The package lists or status file could not be parsed or opened.
Last edited by guyver; October 23rd, 2007 at 02:56 AM.
ftp://ftp.debian.org/debian/dists/te.../images/floppy that'll probably save you some time and frustration; you'll be able to upgrade directly to Gutsy that way
As for the rest, I'm not sure; I haven't tried the Debian-to-Ubuntu-by-dist-upgrade conversion approach since Debian Sarge -> Ubuntu 5.10 so things are likely quite different now