Page 9 of 12 FirstFirst ... 7891011 ... LastLast
Results 81 to 90 of 120

Thread: HOWTO: Fancontrol

  1. #81
    Join Date
    Jun 2008
    Beans
    36

    Re: HOWTO: Fancontrol

    Thanks for this great HOWTO! I now have full control over the CPU fan and noise level has been reduced considerably. However the two chassis fans still make quite a lot of noise. They seem to be running at a constant full speed. I have one fan sucking in and one blowing out. They are not equipped with any RPM sensors and are parallel coupled from the same source. It doesn't seem to be a way to tweak them in the BIOS setup either.

    Is there a way to reduce the voltage going out to these fans and by that way reduce their speed? I know this is possible by installing hardware and tune the voltage manually but I wondered if there is a way to do this with fancontrol or any other software.

    My sensors readout:
    Code:
    k8temp-pci-00c3
    Adapter: PCI adapter
    Core0 Temp:  +34.0C                                    
    Core1 Temp:  +27.0C                                    
    
    it8712-isa-0290
    Adapter: ISA adapter
    VCore 1:     +1.14 V  (min =  +0.00 V, max =  +4.08 V)   
    VCore 2:     +4.08 V  (min =  +0.00 V, max =  +4.08 V)   ALARM
    +3.3V:       +3.30 V  (min =  +0.00 V, max =  +4.08 V)   
    +5V:         +6.85 V  (min =  +0.00 V, max =  +6.85 V)   ALARM
    +12V:       +12.54 V  (min =  +0.00 V, max = +16.32 V)   
    -12V:       -15.46 V  (min = -27.36 V, max =  +3.93 V)   
    -5V:         +4.03 V  (min = -13.64 V, max =  +4.03 V)   ALARM
    Stdby:       +6.85 V  (min =  +0.00 V, max =  +6.85 V)   ALARM
    VBat:        +3.15 V
    fan1:        872 RPM  (min =    0 RPM)
    fan2:          0 RPM  (min =    0 RPM)
    M/B Temp:    +32.0C  (low  =  -1.0C, high = +127.0C)  sensor = transistor
    CPU Temp:    +28.0C  (low  =  -1.0C, high = +127.0C)  sensor = transistor
    Temp3:      +128.0C  (low  =  -1.0C, high = +127.0C)  sensor = disabled
    cpu0_vid:   +1.550 V

  2. #82
    Join Date
    Jun 2007
    Location
    Grand Rapids, MI
    Beans
    24
    Distro
    Ubuntu 8.04 Hardy Heron

    Smile Re: HOWTO: Fancontrol

    Quote Originally Posted by Hoyland84 View Post
    They are not equipped with any RPM sensors and are parallel coupled from the same source. It doesn't seem to be a way to tweak them in the BIOS setup either.[...]but I wondered if there is a way to do this with fancontrol or any other software.
    You could buy some 4-pin-to-3-pin connectors and plug them directly into your motherboard if it has the jacks. Places like xoxide, newegg, zipzoomfly, frozencpu, etc. all sell those types of parts. Take a look and see what you can find; they're really, really cheap if you shop around, usually.

    Hey OP & contributors, thanks a lot for the howto. Worked great on this socket 939 mobo! (DFI Lanparty Ultra-D)

    Cheers!
    -Downhill

    PS: Wish they'd make the process easier, though. If it's gonna probe for when the fan stops anyway, why not use the numbers it collects automatically? *sigh* Well, at least it works well enough to get the job done.

  3. #83
    Join Date
    Feb 2006
    Location
    Italy
    Beans
    443
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Fancontrol

    works for me:
    Sensor: w83627hf

    INTERVAL=10
    FCTEMPS= hwmon0/device/pwm2=hwmon0/device/temp2_input
    FCFANS= hwmon0/device/pwm2=hwmon0/device/fan1_input
    MINTEMP= hwmon0/device/pwm2=36
    MAXTEMP= hwmon0/device/pwm2=53
    MINSTART= hwmon0/device/pwm2=2
    MINSTOP= hwmon0/device/pwm2=0
    MINPWM= hwmon0/device/pwm2=0
    MAXPWM= hwmon0/device/pwm2=255

    Code:
    -=[ CPU Full: Detected 2004.568 MHz processor. ]=-
    -=[ CPU Mhz: 1896.000 ]=-
    -=[ CPU Temp.: +42.0C ]=-
    -=[ CPU Vcore: +1.425 ]=-
    -=[ CPU Fan: 3924 ]=-
    
    -=[ CPU Mhz: 1404.000 ]=-
    -=[ CPU Temp.: +41.5C ]=-
    -=[ CPU Vcore: +1.425 ]=-
    -=[ CPU Fan: 3924 ]=-
    
    -=[ CPU Mhz: 1404.000 ]=-
    -=[ CPU Temp.: +40.0C ]=-
    -=[ CPU Vcore: +1.425 ]=-
    -=[ CPU Fan: 3924 ]=-
    
    -=[ CPU Mhz: 1404.000 ]=-
    -=[ CPU Temp.: +37.5C ]=-
    -=[ CPU Vcore: +1.425 ]=-
    -=[ CPU Fan: 3792 ]=-
    
    -=[ CPU Mhz: 1404.000 ]=-
    -=[ CPU Temp.: +36.5C ]=-
    -=[ CPU Vcore: +1.425 ]=-
    -=[ CPU Fan: 3668 ]=-
    
    -=[ CPU Mhz: 1404.000 ]=-
    -=[ CPU Temp.: +36.0C ]=-
    -=[ CPU Vcore: +1.425 ]=-
    -=[ CPU Fan: 0 ]=-

    Code:
    w83627hf-isa-0290
    Adapter: ISA adapter
    VCore 1:   +1.38 V  (min =  +3.18 V, max =  +3.58 V)       ALARM
    VCore 2:   +2.59 V  (min =  +3.18 V, max =  +3.58 V)       ALARM
    +3.3V:     +3.31 V  (min =  +2.82 V, max =  +3.79 V)
    +5V:       +5.05 V  (min =  +2.02 V, max =  +5.30 V)
    +12V:     +11.92 V  (min =  +7.30 V, max =  +1.95 V)       ALARM
    -12V:     -11.87 V  (min =  -7.26 V, max =  -4.30 V)       ALARM
    -5V:       -5.10 V  (min =  -7.01 V, max =  -4.39 V)
    V5SB:      +5.43 V  (min =  +4.92 V, max =  +1.61 V)       ALARM
    VBat:      +3.57 V  (min =  +1.14 V, max =  +1.65 V)       ALARM
    fan1:     3629 RPM  (min = 3443 RPM, div = 4)
    fan2:        0 RPM  (min = 2205 RPM, div = 4)              ALARM
    fan3:        0 RPM  (min = 1562 RPM, div = 4)              ALARM
    temp1:       +28C  (high =   -74C, hyst =   +20C)   sensor = thermistor   ALARM
    temp2:     +36.5C  (high =   +60C, hyst =   +55C)   sensor = thermistor           (beep)
    temp3:     -47.0C  (high =   +60C, hyst =   +55C)   sensor = thermistor
    vid:      +1.425 V  (VRM Version 9.0)
    alarms:
    beep_enable:
              Sound alarm enabled
    Code:
    PC statistic
    -=[ Kernel info: 2.6.22-14-386 ]=-
    -=[ Ubuntu 7.10 ]=-
    -=[ CPU Info: AMD Athlon(tm)  ]=-
    -=[ CPU Full: Detected 2004.568 MHz processor. ]=-
    -=[ CPU Mhz: 1404.000 ]=-
    -=[ CPU Temp.: +37.0C ]=-
    -=[ CPU Vcore: +1.425 ]=-
    -=[ CPU Fan: 3629 (pwm 20)]=-
    -=[ Incoming/Outgoing: (26.2MB) / (5.9MB) ]=-
    -=[ Used/Total memory: 145 MB / 504 MB ]=-
    -=[ Uptime: 3 hour, 14 min, 57 sec ]=-
    Last edited by flapane; December 30th, 2008 at 09:35 PM.
    Visit my site www.flapane.com - MY GALLERY - MY Linux/OSX REPOSITORY - MY BLOG
    Ibook 12''1,33ghz 1.5GB 160GB HD - PC Intel i3-2120 - MBP 15'' i7 2.2ghz - T-Mobile Vibrant - YamahaP90 - Nikon D80

  4. #84
    Join Date
    Apr 2006
    Location
    Copenhagen
    Beans
    91
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: HOWTO: Fancontrol

    I have been running the init.d script for a long time using 8.04 flawlessly. I recently upgraded to 9.04 and even though /usr/sbin/fancontrol still works as usual the init script does not.

    Has something changed in way Ubuntu interprets the script? Furthermore I tried to find the log file where errors would be located but none of the log files in /var/log contains any information on fancontrol.
    Kind regards
    Thomas Jansson - www.tjansson.dk
    Geek By Nature | Linux By Choice

  5. #85
    Join Date
    Apr 2006
    Location
    London, England
    Beans
    22
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: Fancontrol

    hey guys - can anyone help me?

    First time i set this up it worked fine, but when i rebooted the computer my fancontrol stopped working.

    here is what i get when i try to run it manually:
    kevalp@ ~ $ fancontrol
    File /var/run/fancontrol.pid exists, is fancontrol already running?


    kevalp@ ~ $ sudo /etc/init.d/fancontrol stop
    * Stopping fancontrol daemon... start-stop-daemon: warning: failed to kill 6713: No such process
    [ OK ]
    kevalp@ ~ $ fancontrol
    File /var/run/fancontrol.pid exists, is fancontrol already running?
    kevalp@ ~ $
    any idea?

  6. #86
    Join Date
    Dec 2008
    Beans
    1

    Re: HOWTO: Fancontrol

    Hi, friends. Sorry for offtopic. Is here someone who can help me and others to solve fans problem on Mac Os (Hackintosh Toshiba Laptop). I'm suffering with the extreme overheating problem caused by fans stop at boot. The topic is here http://www.insanelymac.com/forum/ind...&#entry1178198 . My email: jazzminosDOGgmailDOTcom .

    Thanks for attention.

    With great respect, jazzminos.

  7. #87
    Join Date
    Jul 2007
    Beans
    19
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: HOWTO: Fancontrol

    OMFG, I had forgotten what "silence" meant. THANK YOU!!!

    PS Worked great on 9.04!

  8. #88
    Join Date
    Jul 2007
    Beans
    19
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: HOWTO: Fancontrol

    Quote Originally Posted by gam3r View Post
    hey guys - can anyone help me?

    First time i set this up it worked fine, but when i rebooted the computer my fancontrol stopped working.

    here is what i get when i try to run it manually:


    any idea?
    Try deleting the fancontrol PID file displayed in the error.

    Appears the the process was killed w/o using the init.d script and the option "stop".

  9. #89
    Join Date
    Aug 2009
    Beans
    1

    Re: HOWTO: Fancontrol

    Hi guys, great thread - I've got this so close to working on Jaunty.

    The /etc/init.d/fancontrol script won't work unless I sudo it, which means it won't run on startup. Any ideas why it's working for all of you lot but not me? I've only been using Linux for a few weeks so apologies if I'm being stupid!

    In case it's useful here's what happens when I run it (I've edited the script to remove the --background suffix from the start-stop-daemon command so you can see what's going on):

    rory@Reg:~$ /etc/init.d/fancontrol start
    * Starting fan speed regulator fancontrol /usr/sbin/fancontrol: line 50: /var/run/fancontrol.pid: Permission denied
    Loading configuration from /etc/fancontrol ...

    Common settings:
    INTERVAL=10

    Settings for hwmon2/device/pwm1:
    Depends on hwmon2/device/temp1_input
    Controls hwmon2/device/fan1_input
    MINTEMP=40
    MAXTEMP=55
    MINSTART=80
    MINSTOP=45
    MINPWM=0
    MAXPWM=255

    Enabling PWM on fans...
    /usr/sbin/fancontrol: line 230: hwmon2/device/pwm1_enable: Permission denied
    Error enabling PWM on /sys/class/hwmon/hwmon2/device/pwm1
    Aborting, restoring fans...
    /usr/sbin/fancontrol: line 198: hwmon2/device/pwm1_enable: Permission denied
    Verify fans have returned to full speed
    Cheers, Rory

  10. #90
    Join Date
    Jun 2008
    Beans
    38

    Question Re: HOWTO: Fancontrol

    anyone has the pwconfig file for jaunty? the line 68 does not seems to be aligned with what mentioned in the root of this topic?

    my line 68 script block:

    DIR=/proc/sys/dev/sensors
    if [ ! -d $DIR ]
    then
    if [ -d "/sys/class/hwmon" ]
    then
    SYSFS=2
    DIR="/sys/class/hwmon"
    elif [ -d "/sys/bus/i2c/devices" ]
    then
    SYSFS=1
    DIR="/sys/bus/i2c/devices"
    else
    echo $0: 'No sensors found! (modprobe sensor modules?)'
    exit 1
    fi
    fi

Page 9 of 12 FirstFirst ... 7891011 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •