Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: New Racer Installer

  1. #1
    Join Date
    Feb 2007
    Beans
    116
    Distro
    Kubuntu 9.10 Karmic Koala

    New Racer Installer

    I can install and run the new Racer install file from Loki's site. When I attempt to run the game, I can get to the car when this happens:
    Code:
    ...
    ODE Message 2: vector has zero size in dNormalize4()
    Floating point exception (core dumped)
    What's up with that? Can anyone else confirm this error?

  2. #2
    Join Date
    Sep 2005
    Location
    Mexicali, Mexico
    Beans
    3,114
    Distro
    Ubuntu Development Release

    Re: New Racer Installer

    Hi. Is this the game you downloaded, or is it another one?
    NOT a morning person...

  3. #3
    Join Date
    Jan 2007
    Beans
    107

    Re: New Racer Installer

    your best bet would be to compile it yourself. It's pretty easy. You just download the source, un tar it, and run ./configure then make then sudo make install. So now you have no excuse to say you are a n00b and don't know how to compile. I'm a n00b and i've learned in less then a day. It's fun fun fun! (linux and learning)

  4. #4
    Join Date
    Feb 2007
    Beans
    116
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: New Racer Installer

    To confirm, I downloaded the game listed at http://www.racer.nl/ However, I downloaded the installer from http://liflg.org/ I am attempting to compile my own version from source and see if that makes a difference. Can anyone else download the installer from Loki's site listed above and see if they can recreate this error?

  5. #5
    Join Date
    Feb 2007
    Beans
    116
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: New Racer Installer

    Well, I compiled version 0.5.0, and I must say I am impressed. I really want to get the updated version running. The Loki site has the updated installer for the latest beta version of racer, 0.5.3beta6 and I can get it to open the menus, but it will not get into the actual game. Anyone else having this problem or is it just me?

    ...
    ODE Message 2: vector has zero size in dNormalize4()
    Floating point exception (core dumped)

  6. #6
    Join Date
    Sep 2005
    Location
    Mexicali, Mexico
    Beans
    3,114
    Distro
    Ubuntu Development Release

    Re: New Racer Installer

    Did you download the beta version? And if so, did you follow these instructions from the Racer page?

    The latest Linux beta version is v0.5.3 beta 6. An installer has been made by Loki:
    Download the Loki Racer version from here.
    Run the downloaded file (racer_0.5.3beta6-english.run)

    Alternatively, follow these steps for a manual installation:
    Download the Windows Racer v0.5.3 beta 5 data files (18Mb/zip) from here.
    Download the Linux v0.5.3 beta 6 executable (and fmod v4.06) from here (19-3-07, 1Mb zip).
    Unzip the Windows files; they'll probably end up in racer053b5/
    Unzip the Linux zip and move the 'racer' and 'libfmodex.so' files into racer053b5/.
    cd into racer053b5
    Next, to run, first try:
    export LD_LIBRARY_PATH=.:${LD_LIBRARY_PATH}; ./racer
    If that doesn't work, try:
    Copy libfmodex.so to /usr/local/lib (be careful not to overwrite any possible existing file) and run 'sudo ldconfig'.
    Run ./racer
    Editing settings can be done using 'vi racer.ini', error checking after a run can be done with 'cat QLOG.txt'.
    Last edited by RomeReactor; April 16th, 2007 at 11:54 PM.
    NOT a morning person...

  7. #7
    Join Date
    Feb 2007
    Beans
    116
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: New Racer Installer

    Yes exactly. I can compile the source version, and I can get the older version of the beta up. This new installer, however, creates that error.

  8. #8
    Join Date
    Sep 2005
    Location
    Mexicali, Mexico
    Beans
    3,114
    Distro
    Ubuntu Development Release

    Re: New Racer Installer

    I'm downloading the beta installer from loki (racer_0.5.3beta6-english.run); I'll post back if I make any progress.
    NOT a morning person...

  9. #9
    Join Date
    Sep 2005
    Location
    Mexicali, Mexico
    Beans
    3,114
    Distro
    Ubuntu Development Release

    Re: New Racer Installer

    I couldn't find the error; I just ran the installer and it installed correctly here, without any other input from me; did you try to install it using sudo?

    Code:
    sudo sh racer_0.5.3beta6-english.run
    perhaps the problem has to do with not having hardware acceleration enabled for your graphics card. Also, is it ATI or NVIDIA?
    Last edited by RomeReactor; April 17th, 2007 at 05:12 AM. Reason: Corrected spelling.
    NOT a morning person...

  10. #10
    Join Date
    Feb 2007
    Beans
    116
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: New Racer Installer

    nVidia GeForce MX 420 card. I did not use sudo. It must be something on my end.. what could it be? I have no other problems and I have multiple other games... btw RomeReactor thanks for your help thus far.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •