Results 1 to 6 of 6

Thread: Update packages "can't be authenticated"?

  1. #1
    Join Date
    Feb 2007
    Beans
    4

    Update packages "can't be authenticated"?

    Today I suddenly finds that all new packages (which are going to be downloaded from the internet) cannot be authenciated. So I am forced to abandon the updates.

    The update function was okay yesterday. What happened?

    (PS. install new software will also produce the same problem)

  2. #2
    Join Date
    Mar 2006
    Location
    Murcia, Spain
    Beans
    150

    Re: Update packages "can't be authenticated"?

    There was a problem with the archive, but it was fixed. I think the problem was with the gpg keys, but I'm not sure about that.

  3. #3
    Join Date
    Aug 2007
    Location
    Sweden
    Beans
    197
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: Update packages "can't be authenticated"?

    I had this problem in Ubuntu 7.10. This solved it for me:

    Code:
    sudo apt-get update
    Then use the update manager as usual.

    (Thanks to the commenter on this blog entry http://linuxtnt.wordpress.com/2007/08/27/cant-be-authenticated-2)

  4. #4

    Re: Update packages "can't be authenticated"?

    FYI: I received the following error when executing apt-get update:



    W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://ubuntu.media.mit.edu maverick Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

    W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://ubuntu.media.mit.edu maverick-updates Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

    W: Failed to fetch http://ubuntu.media.mit.edu/ubuntu/d...verick/Release

    W: Failed to fetch http://ubuntu.media.mit.edu/ubuntu/d...pdates/Release

    W: Some index files failed to download, they have been ignored, or old ones used instead.

  5. #5
    Join Date
    Mar 2010
    Location
    skelmersdale, england
    Beans
    209
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Update packages "can't be authenticated"?

    I recieved the same errors when trying to update one time.

    Running the following commands one after another fixed it.

    to run the commands, click on Applications then Accessories then terminal. copy and paste each command one by one into the terminal and press enter, if it prompts for your password then enter it and press enter.

    gpg --keyserver keyserver.ubuntu.com --recv 2EBC26B60C5A2783
    gpg --export --armor 2EBC26B60C5A2783 | sudo apt-key add -
    gpg --keyserver keyserver.ubuntu.com --recv 40976EAF437D05B5
    gpg --export --armor 40976EAF437D05B5 | sudo apt-key add -
    sudo rm /var/lib/apt/lists/partial/*
    sudo rm /var/lib/apt/lists/*
    sudo apt-get update

  6. #6
    Join Date
    Feb 2009
    Beans
    11

    Re: Update packages "can't be authenticated"?

    Good answer! Removing the contents of lists and lists/partial helped! Thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •